You are not logged in.

#1 2005-02-14 17:38:55

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

"error loading kio_http"( db-4.2.52.2-2 req'd)

Is there an error in xorg to cause loss of internet access via konqueror but pacman downloads OK.?


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#2 2005-02-14 18:18:42

Pajaro
Member
Registered: 2004-04-21
Posts: 875

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

can you give more information, please?

what things you do in xorg to say there's no internet?

Offline

#3 2005-02-14 18:38:52

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

attempt to use konqueror gives the subject error and there is no internet access as a result.

Pacman operates correctly and k-mail is operable.

Only konqueror produces an error as stated.

Perhaps one of the kde downloads is in error?

Cannot provide much more without internet access in arch.

I am in knoppix now.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#4 2005-02-14 20:04:53

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,017

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Error with kio_http occured in one of recent broken kdelibs(base?) builds. Is your kde up-to-date?

Offline

#5 2005-02-14 21:07:06

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

I just downloaded the whole schmeer of kde.

I will delete the cache and try again.

Thanks for the info.!! big_smile


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#6 2005-02-15 01:42:47

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Performed ...pacman -Scc to clear the cache.

Performed...pacman -Syf kdelibs

After download and install, received the same error in konqueror.

Is there a more suitable way to correct this problem?


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#7 2005-02-15 02:20:51

soniX
Member
From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

you wouldnt happen to have enabled the testing repo ?
I dont know if its directly related, but I remember problems with the db in the testing repos. after rolling back to the db in current, the kio problems were gone..

Offline

#8 2005-02-15 02:47:02

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Wella,wella,wella!!!! Yes I have recently opened testing repo to get the xorg latest version.

I will report back after i shut it down!!!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#9 2005-02-15 03:38:04

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Commented out testing....

Repeated the ...pacman -Scc
Re-installed from extra ...pacman -Sy kdelibs

re-booted....Problem still persists......

Perhaps all of kde needs re-install?  It takes 30 seconds to pass muster thru the X environment before Kde starts.  Konqueror is sometimes very slow to initiate display.

Is there another approach?


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#10 2005-02-15 04:30:24

soniX
Member
From: Oslo, Norway
Registered: 2004-01-23
Posts: 161

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

what you just did doesnt change anything as there is no kde-stuff in testing and I was talking about the program/lib called "db"

remove db-4.3-27-1(from testing) and install db-4.2.52-2 (from current) and see if that helps

edit: I upgraded to the db in testing to check out if I could reproduce the error, but it seems to be working just fine under kde 3.4 beta 2, so I really have no idea...

I thought this should have been fixed anyway according to this thread  http://bbs.archlinux.org/viewtopic.php? … ghlight=db
so I guess it was a wild shot...

Offline

#11 2005-02-15 05:14:51

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

I have researched the forum items on this problem and conclude that there is much confusion and not a definite handle has been blandly stated by anyone.  Many "solutions" end up failing in short order.

The closest to a solution might well be the db version so I will try that one.

The really funny part of this is that I skipped past the 0.6 Version to avoid the problems there and I get whacked with this one in 0.7CD!

Some are getting it in _Syu!

I don't know why announcements forum doesn't include info on such matters.  It seems it is never changed or at least seldom...

I have two hdd installs with the same kde problem...now that is consistency!!!!  Bravo!!!

==============================================

Asking may get you knowwhere.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#12 2005-02-15 05:42:06

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

From the Archlinux Frontpage news:

if you experience problems after kdebase and kdelibs update with no working kio_http
you have to install heimdal
pacman -S heimdal and all should work fine again

Offline

#13 2005-02-15 05:58:20

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

This is one of the many "solutions" which has been reported but has been followed by repeated failures and further trials.

I think I have heimdal installed as well.

I will check and report findings. big_smile


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#14 2005-02-15 06:32:28

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

I confirm that heimdal0.6.3-2 is present in pacman -Q.

I confirm that the object files concerned with this failure are present in the wrong files as reported by tpowa in other forum postings.

I have kdelibs -5 version installed which is supposed to hold the kio_http files referred to above.   Thus , I have duplicate references to
kio_http files.  These all came through pacman downloads.

Advice was to try another mirror...which one is problematic! roll If I have the wrong files, what download will correct the erroneous files if the latest download contains the problem.  My build was from CD0.7 with an upgrade _Syu.

I am not aware of the manner in which I can eliminate the doubling of the files, because I may mess up other dependent variables if not done correctly.

================================================================
Asking may get you knowwhere.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#15 2005-02-15 19:15:58

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

run this one:
ldd /opt/kde/lib/kde3/kio_http.so | grep found

Install the package that provides the library that's missing.

Offline

#16 2005-02-15 20:02:02

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

JGC;

I entered the command exactly as you provided...result...no such file or directory...

Re- commanded the sequence to:

     ldd  /opt/kde/lib/kde3/kio_http.so |grep found 

Result     ;   libdb-4.2.so  =>not found
                  libdb-4.2.so =>not found
                  libdb-4.2.so =>not found

Your instructions say to install the missing files found.

My.... pacman -Q ...reports db-4.3.27-1 installed per latest upgrade.

Thusly, I have the latest and have no way to get db-4.2 via pacman which always downloads the latest and greatest.

What version of kdelibs is correct, and is heimdal involved?  These have been alluded to in posts on this forum.  All is confusion!

I have the -5 version of kdelibs, xorg6.8-2,heimdal0.6.3-2and arch0.7CD install, base followed by -Syu.

Still no konqueror.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#17 2005-02-15 20:14:36

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

You probably have db from the testing repo.
db 4.2.52.2-2   is in current.  Comment the testing repo in pacman.conf and do:

pacman -Sy db

Offline

#18 2005-02-16 02:10:41

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Snowman;

I had previously commented out testing.

I ran ...pacman -Sy db
Result:  db-4.3.27-1 continue?  no 

The file in ...pacman -Q ...db-4.3.27-1

I cannot download thru pacman a file of lower precedence in the normal use of pacman.  It can be forced if the file to be forced is available.  It seems not to be available.
I am not familiar with any "cure" for the failure of pacman to provide the means to "call" a previous version and force install it.

I had opened testing to get the latest xorg.  I didn't realize the consequences of leaving it open!!! It seems current has the offending file anyhow!!!


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#19 2005-02-16 04:38:10

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Download the package with wget or a browser:
ftp://ftp.archlinux.org/current/os/i686 … pkg.tar.gz
Install with:

pacman -U db-4.2.52.2-2.pkg.tar.gz

Offline

#20 2005-02-16 05:05:39

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Snowman;

Happy to try the wget procedure(don't think its in current)..

Performed the wget and received the statement;

   resolving db-4.2.25.2-2.pkg.tar.gz
    failed   : Host not found

Perhaps the ID of the db file is incorrect?  File not downloaded.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#21 2005-02-16 05:46:01

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

wget needs the full path:

wget ftp://ftp.archlinux.org/current/os/i686/db-4.2.52.2-2.pkg.tar.gz

or you can just paste
ftp://ftp.archlinux.org/current/os/i686 … pkg.tar.gz in your browser's address bar. It will ask you where to save it.

Offline

#22 2005-02-16 05:52:33

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Snowman;
I previously entered the entire full path as you presented it and received the reply as posted previously.

I invite you to perform the procedure to see what happens.


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#23 2005-02-16 05:58:27

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

lilsirecho wrote:

Snowman;
I previously entered the entire full path as you presented it and received the reply as posted previously.

I invite you to perform the procedure to see what happens.

It works for me.  Have you try with the browser?  Maybe try a mirror (the list is in /etc/pacman.d/current)

Offline

#24 2005-02-16 06:01:07

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Snowman;

I will try a mirror but why does it work for you and not me on this URL?

Not just an idle question...

CUL


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

#25 2005-02-16 06:15:52

lilsirecho
Veteran
Registered: 2003-10-24
Posts: 5,000

Re: "error loading kio_http"( db-4.2.52.2-2 req'd)

Snowman;

I re-ran the wget as you listed it and was successful in obtaining the db version listed.

I must have made a typo error the first time i ran it.

I am now in Konqueror Archlinux.

Many thanks for your patient replies and help in "Konquering" this problem!

I am sure there are others that have the same difficulty that will be helped as well.

Have a good night! big_smile


Sign of the times: Navajo blanket..made in China
Hard work does not kill people but why risk it: Charlie Mccarthy
A man is not complete until he is married..then..he is finished.
When ALL is lost, what can be found? Even bytes get lonely for a little bit!     X-ray confirms Iam spineless!

Offline

Board footer

Powered by FluxBB