You are not logged in.

#1 2010-10-23 17:33:53

jwhendy
Member
Registered: 2010-04-01
Posts: 555

Texlive-localmanger + TexLive 2010 not working

Since the update to TexLive 2010, some of us have been getting errors when trying to use texlive-localmanager. See the posts from teme and myself on AUR. The errors are in the form of:

Cannot open /usr/share/texmf-var/arch/installedpkgs/texlive-core_19888.pkgs  # or some other pkgName_rev.pkgs

I've also noticed that pacman -Q |grep texlive no longer returns the packages I had installed with texlive-localmanager. I used to be able to see them and do not any longer. They were in the form of "texlive-local-pkgName" and my queries return no such packages anymore even though I know I've installed many. For now, I'll just focus on the texlive-localmgr issue.

I did a locate for files ending in .pkgs and returned, as far as I can tell, all that texlive-localmgr is looking for:

$ locate *.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-bibtexextra_19862.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-core_19888.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-fontsextra_19878.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-formatsextra_18835.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-games_18651.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-genericextra_19909.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-htmlxml_19804.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-humanities_18675.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-latexextra_19882.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-music_18434.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-pictures_19879.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-plainextra_19883.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-pstricks_19829.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-publishers_19886.pkgs
/var/lib/texmf/arch/installedpkgs/texlive-science_19845.pkgs

But note that texlive-localmanager is looking for them in /usr/share/texmf-var/arch/installedpkgs/, not in /var/lib...

I tried looking around at the various files in /usr/share/texmf-var/arch/tlpkg/*.pm, particularly TLConfig.pm to see if there was a setting somewhere instructing texlive-localmanger where to look for packages. It appears that TexLive-2010 moved the tree to a new location (/var/lib) from its old location (/usr/share) and this is causing the problem. Or perhaps it's the other way around... not sure. Either way, texlive-localmgr is looking in the wrong place. It seems like it could be an easy fix. I couldn't find anything in the PKGBUILD allowing for configuring it differently.

Suggestions?

Offline

#2 2010-10-23 17:49:38

jwhendy
Member
Registered: 2010-04-01
Posts: 555

Re: Texlive-localmanger + TexLive 2010 not working

Hmm. Solved? I found THIS where someone did an ls-l on their /var/lib/texmf dir and it reported this:

lrwxrwxrwx 1 root root 29 Aug 23 17:36 /usr/share/texmf/ls-R -> /var/lib/texmf/ls-R-TEXMFMAIN
lrwxrwxrwx 1 root root 27 Aug 23 17:36 /usr/share/texmf-texlive/ls-R -> /var/lib/texmf/ls-R-TEXLIVE
lrwxrwxrwx 1 root root 27 Aug 23 17:36 /usr/share/texmf-texlive/ls-R -> /var/lib/texmf/ls-R-TEXLIVE

That got me wondering if it was a symlink all along?

Doing this worked for me:

$ sudo ln -s /var/lib/texmf/arch/installedpkgs /usr/share/texmf-var/arch/installedpkgs
$ tllocalmgr --forceupdate

I'll link to this on the AUR and wait a few days for any posts about if this is, indeed, the solution or if there are other suggestions before marking it solved.

Offline

Board footer

Powered by FluxBB