You are not logged in.

#1 2011-06-12 21:02:56

tgoossens
Member
From: Belgium
Registered: 2011-02-06
Posts: 96
Website

Decrease delay of auto-wifi connect afters suspend

Any Ideas on how to do it?

Sometimes I have to wait 30 seconds for wifi to start connecting sad


Share and enjoy!

Offline

#2 2011-06-12 21:27:25

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Decrease delay of auto-wifi connect afters suspend

Mine is almost instant. Do you have similar delays when you boot the system?

Offline

#3 2011-06-13 07:02:47

tgoossens
Member
From: Belgium
Registered: 2011-02-06
Posts: 96
Website

Re: Decrease delay of auto-wifi connect afters suspend

Nope. Then it's instant


Share and enjoy!

Offline

#4 2011-06-13 10:04:31

tgoossens
Member
From: Belgium
Registered: 2011-02-06
Posts: 96
Website

Re: Decrease delay of auto-wifi connect afters suspend

But i noticed that sometimes it is instant.

but sometimes it really takes more than 30 seconds to even start searching for wireless networks


Share and enjoy!

Offline

#5 2011-06-13 10:52:49

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Decrease delay of auto-wifi connect afters suspend

Any clues in dmesg?

Offline

#6 2011-06-13 13:39:21

tgoossens
Member
From: Belgium
Registered: 2011-02-06
Posts: 96
Website

Re: Decrease delay of auto-wifi connect afters suspend

I'll check it next time it is slow


Share and enjoy!

Offline

#7 2011-06-13 14:23:03

rwd
Member
Registered: 2009-02-08
Posts: 646

Re: Decrease delay of auto-wifi connect afters suspend

An essential piece of information missing here is which method you use to manage your wifi connections: Wicd, Netcfg or something else? Also if you disconnect/reconnect by hand does it take as long?

Last edited by rwd (2011-06-13 14:24:48)

Offline

#8 2011-06-14 16:51:46

tgoossens
Member
From: Belgium
Registered: 2011-02-06
Posts: 96
Website

Re: Decrease delay of auto-wifi connect afters suspend

I am using networkmanager


DMESG OUTPUT (when it happened)

[16986.185309] sky2 0000:09:00.0: eth0: enabling interface
[16986.186122] ADDRCONF(NETDEV_UP): eth0: link is not ready
[16996.601659] eth1: no IPv6 routers present

After 30 seconds it started connecting


Share and enjoy!

Offline

#9 2011-06-14 18:45:21

rwd
Member
Registered: 2009-02-08
Posts: 646

Re: Decrease delay of auto-wifi connect afters suspend

Have you disabled ipv6? If not try with it disabled (see arch wiki).

Offline

#10 2011-06-14 19:01:41

tgoossens
Member
From: Belgium
Registered: 2011-02-06
Posts: 96
Website

Re: Decrease delay of auto-wifi connect afters suspend

But why should I disable it.

All IPv4 adressess are in use tongue

IPv6 IS going to be used from now


Share and enjoy!

Offline

#11 2011-06-14 19:14:11

rwd
Member
Registered: 2009-02-08
Posts: 646

Re: Decrease delay of auto-wifi connect afters suspend

I'm not saying you should.Just that it might be a cause of slowdows because not all hard- and software (especially routers and websites) are fully ipv6 compatible yet.

Last edited by rwd (2011-06-14 19:18:00)

Offline

Board footer

Powered by FluxBB