You are not logged in.

#1 2011-10-12 02:15:54

dannydutton
Member
Registered: 2011-10-12
Posts: 3

Xfce panels defaulting at boot

Everytime I go into Xfce, there is a prompt asking if I want to use the default panels on the desktop or none at all. The prompt assumes that this is the first time I have started Xfce in my entire life. I have fully customized my panels everytime I get in just on the off chance that they save that time. For those wondering, I start SLiM with the rest of daemons and have it use Xfce from there. I am not quite sure where the config file responsible would be or even if there is one to blame. My ~/.xinitrc file says:

exec startxfce4

and I have removed the last bits of gnome3 (gross) which were causing previous, but now fixed, issues. All of my other applications are remembering their prefs except for whatever controls the xfce panels. What I find odd isn't that xfce can't remember my panel layout (or any other theme prefrences) but that it is starting from scratch at every boot. I was looking for solutions earlier and did find that there was a bug back in 4.2.something that would cause panels not to save but I have the newest 4.8. I did see something else about file permissions for ~/.config (apparently an xfce4-panel file). Just for giggles, I set it at 777 to see if that would do anything but alas, nothing. I can post my config files, just tell me which ones. The default panel layout and theme wouldn't be so bad except there is some awful looking dock at the bottom of my screen and the color scheme annoys me.

Offline

#2 2011-10-12 04:55:33

moetunes
Member
From: A comfortable couch
Registered: 2010-10-09
Posts: 1,019

Re: Xfce panels defaulting at boot

Sounds like you haven't set xfce to save the session.

Last edited by moetunes (2011-10-12 04:55:52)


You're just jealous because the voices only talk to me.

Offline

#3 2011-10-12 05:15:30

dannydutton
Member
Registered: 2011-10-12
Posts: 3

Re: Xfce panels defaulting at boot

I am saving the session unless this involves more than clicking the check box when logging out of xfce.

Offline

#4 2011-10-12 06:45:22

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: Xfce panels defaulting at boot

Something I tell all xfce users to do if they have session related problems is to clear out ~/.cache/xfce4 and ~/.cache/sessions. There is a checkbox besides the one on the logout prompt. It's in the "Sessions and Startup" settings dialog. There is also a tab in there that lets you manually save the session so you can see if any errors are thrown during a terminal instance of "xfce4-session-settings". Hell, while you're at it, see if any autostarted application could be screwing it up.

I would say the relevant config files are ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml and ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml. As a hack if nothing else works, you could change the default to something more desirable by editing /etc/xdg/xfce4/panel/default.xml.

Last edited by ConnorBehan (2011-10-12 06:46:01)


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#5 2011-10-12 19:40:10

dannydutton
Member
Registered: 2011-10-12
Posts: 3

Re: Xfce panels defaulting at boot

ConnorBehan wrote:

Something I tell all xfce users to do if they have session related problems is to clear out ~/.cache/xfce4 and ~/.cache/sessions. There is a checkbox besides the one on the logout prompt. It's in the "Sessions and Startup" settings dialog. There is also a tab in there that lets you manually save the session so you can see if any errors are thrown during a terminal instance of "xfce4-session-settings". Hell, while you're at it, see if any autostarted application could be screwing it up.

I would say the relevant config files are ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml and ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml. As a hack if nothing else works, you could change the default to something more desirable by editing /etc/xdg/xfce4/panel/default.xml.

Alright, I began with removing the ~/.cache/xfce4 and ~/.cache/sessions. I moved a panel and then logged out. Logged back in and first run dialog was back. I went to the "Sessions and Startup" box ( I don't know how I missed this earlier) and checked the autosave box. I also looked at the other tabs just incase but I didn't want to flip switches too much otherwise I wouldn't know what to do next time it happens. I logged out then in and still the first run dialog box. I went back to the "Sessions and Startup" box and forced a save on the session tab. A dialog box came up and closed pretty quickly, something about saving session. I removed a panel, logged out and then in, and that panel was still gone. Turns out I had to force a save for the stupid thing to catch on. Thank you.

Offline

Board footer

Powered by FluxBB