You are not logged in.

#1 2012-05-21 18:37:42

nos09
Member
Registered: 2011-09-09
Posts: 107

microphone not working.

I followed the instructions on wiki to turn up the mic. but still having no luck so far. i have unmuted all channels in alsamixer too.
i have basically two mic. one in usb camera and the other in headphone. however, i does work in gnome ( i used to have gnome but then i swithced to awesome wm) and in centos 6.2 too. any idea what is up with it ?

Offline

#2 2012-05-21 18:45:01

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: microphone not working.

What have you tried so far? Any more information you can provide us (device information, how do you have sound set up, are you using Pulseaudio)? What application are you trying to use that aren't working?

Offline

#3 2012-05-21 18:59:49

nos09
Member
Registered: 2011-09-09
Posts: 107

Re: microphone not working.

i am not using pulseaudio. Alsa - is what i am using.  so far i have only unmuted all the chennels from alsamixer.

and here's the output of what i have in audio devices :

 x@  ~ $ amixer 
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 29 [94%] [-3.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 28 [90%] [-4.50dB] [on]
  Front Right: Playback 28 [90%] [-4.50dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 237 [93%] [-3.60dB]
  Front Right: Playback 237 [93%] [-3.60dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 28 [90%] [-4.50dB] [on]
  Front Right: Playback 28 [90%] [-4.50dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 28 [90%] [7.50dB] [on]
  Front Right: Playback 28 [90%] [7.50dB] [on]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 1 [33%] [10.00dB]
  Front Right: 1 [33%] [10.00dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [0.00dB] [on]
  Front Right: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [0.00dB] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 28 [90%] [7.50dB] [on]
  Front Right: Playback 28 [90%] [7.50dB] [on]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 16 [52%] [12.00dB] [on]
  Front Right: Capture 16 [52%] [12.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-12.00dB] [off]
  Front Right: Capture 0 [0%] [-12.00dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch'
Simple mixer control 'Digital',0
  Capabilities: cvolume penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Rear Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Rear Mic' 'Front Mic' 'Line'
  Item0: 'Rear Mic'
Simple mixer control 'Rear Mic',0
  Capabilities: pvolume pswitch penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 28 [90%] [7.50dB] [on]
  Front Right: Playback 28 [90%] [7.50dB] [on]
Simple mixer control 'Rear Mic Boost',0
  Capabilities: volume penum
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 1 [33%] [10.00dB]
  Front Right: 1 [33%] [10.00dB]

forgot to mention skype.. is not working. also i have tried 'arecord' as mentioned by wiki.

Last edited by nos09 (2012-05-21 19:01:15)

Offline

#4 2012-05-21 19:07:10

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: microphone not working.

I see two capture channels in there and one is muted. For your usb camera, have you unmuted the channel for that (you'll have to press F6 in alsamixer to switch to it since it will be recognized as a separate card). Also what application are you using to see if you have mic input? Have you used arecord? Audacity works well too to check your mic input if you prefer something graphical.

Offline

#5 2012-05-21 19:11:17

nos09
Member
Registered: 2011-09-09
Posts: 107

Re: microphone not working.

it seems like usb camera's, hw(1,0) microphone is working with skype. but wondering on which port/dev my headphone's is mounted ? and how i choose the defaults ?

Offline

#6 2012-05-21 19:20:41

nos09
Member
Registered: 2011-09-09
Posts: 107

Re: microphone not working.

Pres wrote:

I see two capture channels in there and one is muted. For your usb camera, have you unmuted the channel for that (you'll have to press F6 in alsamixer to switch to it since it will be recognized as a separate card). Also what application are you using to see if you have mic input? Have you used arecord? Audacity works well too to check your mic input if you prefer something graphical.

well i am also using audacity to test.. and trying every hardware decvices one by one. . so far usb camera's working.

Offline

#7 2012-05-21 19:23:58

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: microphone not working.

Appears there are two mic inputs on your PC (Front and Rear). Should be easy to figure out which is which (also, I believe there should be a switch in alsamixer to set which one you want to record sound from).

For how to save the default levels, this is outlined well in the Alsa wiki page. Just make sure you uncheck the box that allows Skype to adjust your mic levels.

Offline

#8 2012-05-21 22:02:49

nos09
Member
Registered: 2011-09-09
Posts: 107

Re: microphone not working.

well it worked. after installing pulseaudio. but there is too much static noice.. will figure something out. thank you guys.

Offline

#9 2012-05-22 00:30:55

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: microphone not working.

If you can hear sound with Pulseaudio, then it should work with ALSA.

Offline

#10 2012-05-23 23:02:57

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,698

Re: microphone not working.

nos09 wrote:

well it worked. after installing pulseaudio. but there is too much static noice.. will figure something out. thank you guys.

If you figure out any solution for the static, could you post what you find?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB