You are not logged in.

#1 2012-09-02 20:16:35

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

[SOLVED] Systemd and laptop-mode-tools frequency scaling

Hi all.
After a long time with no arch updates (november 2011) for various reasons, I decided to reinstall Arch from point 0 on my Clevo laptop.
I was pleased to see nothing went bad, all is now set like I want. I installed systemd yesterday. All very straightforward for me, I only have a problem with CPU frequency scaling plus some minor glitches.

Before systemd, everything went fine. Ondemand governor, set up like I wanted.
Now when on AC the system uses ondemand, but when on battery it uses the conservative governor. What's more, it does not go over 1.6GHz (2.54GHz max).

Here are some infos about it:

[adriano@M735T ~]  cpupower frequency-info
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.53 GHz
  available frequency steps: 2.53 GHz, 2.53 GHz, 1.60 GHz, 800 MHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 800 MHz and 1.60 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.60 GHz.
  boost state support:
    Supported: yes
    Active: yes

[yes this is all come out of the cpupower command, no mention of CPU 1. Is this normal?]

Of course LMT is set up correctly

CONTROL_CPU_FREQUENCY="1"
BATT_CPU_MAXFREQ=fastest
BATT_CPU_MINFREQ=slowest
BATT_CPU_GOVERNOR=ondemand
BATT_CPU_IGNORE_NICE_LOAD=1
LM_AC_CPU_MAXFREQ=fastest
LM_AC_CPU_MINFREQ=slowest
LM_AC_CPU_GOVERNOR=ondemand
LM_AC_CPU_IGNORE_NICE_LOAD=1
NOLM_AC_CPU_MAXFREQ=fastest
NOLM_AC_CPU_MINFREQ=slowest
NOLM_AC_CPU_GOVERNOR=ondemand
NOLM_AC_CPU_IGNORE_NICE_LOAD=0
[adriano@M735T ~]  sudo systemctl status laptop-mode-tools.service
laptop-mode-tools.service - Laptop Power Saving Tools
          Loaded: loaded (/usr/lib/systemd/system/laptop-mode-tools.service; enabled)
          Active: active (exited) since Sun, 02 Sep 2012 17:03:45 +0200; 4h 34min ago
        Main PID: 367 (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/laptop-mode-tools.service

Sep 02 17:03:43 M735T laptop_mode[367]: /usr/sbin/laptop_mode: line 198: /dev/fd/1: No such device or address
Sep 02 17:03:44 M735T laptop_mode[367]: /usr/sbin/laptop_mode: line 198: /dev/fd/1: No such device or address
Sep 02 17:03:44 M735T laptop_mode[367]: /usr/sbin/laptop_mode: line 198: /dev/fd/1: No such device or address

I wonder why LMT status is "exited"

OK bin that, I just now see something is wrong. I said it used conservative, but I'm on battery and it now says ondemand (still 1.6GHz max). However it seems it does so casually.
ACPI:

[adriano@M735T ~]  acpi
Battery 0: Discharging, 53%, rate information unavailable

This may be (?) or may not be linked with nother problem I have: when unplugging the AC the KDE battery monitor does not update. It says AC is plugged and it will not activate power saving features (screen dimming, suspend...)
Note that this battery monitor problem occurred even before systemd, so it should not be linked to the above problem. However I'm not 100% sure the above problems did not occur before installing systemd since I only had the system up and running for a comple of days. I seem to recall I checked and it worked fine.

Any idea why all this happens?

Last edited by OdinEidolon (2012-11-20 08:56:31)


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#2 2012-09-02 20:26:38

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

OK I give up! Now the system is on AC and it uses "ondemand" to the correct max freq of 2.54GHz. It's mad.
If I put it on battery only it'll switch to ondemand (1.6GHz) and if on AC again back to ondemand (2.54MHz).


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#3 2012-09-03 20:05:38

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Bump!


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#4 2012-09-03 21:46:45

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

You probably have pm-utils installed, and by default pm-utils has a few scripts that interfere with laptop-mode-tools modules of equivalent functionality. The default pm-utils cpupower script uses conservative on battery, so thats probably the cause of your governor issue. Back when I used LMT (I just use pm-utils with some extra powersaving scripts these days) the pm-utils laptop-mode script also interfered with LMT causing it to not enable laptop-mode when on battery and other issues. Go through and disable any pm-utils hooks that have equivalent functionality in LMT (or vice-versa).

Here is how you can disable pm-utils hooks: https://wiki.archlinux.org/index.php/Pm … ing_a_hook

Last edited by bwat47 (2012-09-03 21:46:59)

Offline

#5 2012-09-04 00:11:41

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

It is normal for it to "exit" as it is a "oneshot" service. It doesn't actually involve a daemon running at all.

I also get the complaints about /dev/fd/1 since switching to systemd. (Possibly before but I wasn't looking because I wasn't having problems. Not the same problems anyway.)

If you have pm-utils installed, follow those instructions to disable the powersaving scripts. I think I've disabled all of them.

Can you reboot using systemd?

The cpupower output is normal. Use:

cpupower -c 0,1 frequency-info

or whatever to see the first two cores, for example.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#6 2012-09-04 07:43:40

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Thank you both for your answers.
I disabled:

clock  cpufreq  laptop-mode  powersave

But the problem persists. I cannot uninstall pm-utils since it is required by upower which is required by KDE. Right now I'm on battery and it uses conservative (no problem about that) but the frequency is still limited to 1.6GHz. Sometimes it decides it's time to use ondemand, but the frequency is still capped at 1.6GHz. When on AC it uses ondemand and 2.54GHz with no problems.

Yes I can reboot with no problem. Actually just after reading your posts I disabled the hooks and rebooted to see if it had any consequance on the powesaving governor. Guess what, it did not reboot correctly. Hanged at console login. I'll try it again in a second.


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#7 2012-09-04 07:53:47

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Well rebooted twice and worked OK. Just a glitch I guess!
Reading my above post, of course I disabled the hooks with their complete name, 2 digit numbers included.


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#8 2012-09-04 12:29:57

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

The plot thickens. Right now I'm on AC, battery unplugged. The system uses ondemand capped to 1.6GHz (wrong).
Still,
1) acpi -bi returns battery values (it shouldn't since the battery is unplugged)

Battery 0: Unknown, 0%, rate information unavailable
Battery 0: design capacity 4400 mAh, last full capacity 3158 mAh = 71%

But

acpi -a
Adapter 0: on-line

2) KDE battery monitor is locked to 100% (says "AC not plugged in")
3) acpid seems fine, see

sudo systemctl status acpid.service
Password: 
acpid.service - ACPI event daemon
          Loaded: loaded (/usr/lib/systemd/system/acpid.service; enabled)
          Active: active (running) since Tue, 04 Sep 2012 09:51:38 +0200; 4h 35min ago
        Main PID: 237 (acpid)
          CGroup: name=systemd:/system/acpid.service
                  └ 237 /usr/sbin/acpid -f

Sep 04 14:21:34 M735T logger[17917]: ACPI group/action undefined: processor / LNXCPU:00
Sep 04 14:23:07 M735T logger[18057]: ACPI group/action undefined: processor / LNXCPU:00
Sep 04 14:23:49 M735T logger[18160]: ACPI group/action undefined: processor / LNXCPU:01
Sep 04 14:23:59 M735T logger[18175]: ACPI group/action undefined: processor / LNXCPU:01
Sep 04 14:24:09 M735T logger[18191]: ACPI group/action undefined: processor / LNXCPU:00
Sep 04 14:24:19 M735T logger[18225]: ACPI group/action undefined: processor / LNXCPU:00
Sep 04 14:25:01 M735T logger[18314]: ACPI group/action undefined: processor / LNXCPU:01
Sep 04 14:25:11 M735T logger[18325]: ACPI group/action undefined: processor / LNXCPU:00
Sep 04 14:25:52 M735T logger[18423]: ACPI group/action undefined: processor / LNXCPU:00
Sep 04 14:25:52 M735T logger[18427]: ACPI group/action undefined: processor / LNXCPU:01

(I don't know what all those processor calls are)


All these issues are linked for sure... but how?


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#9 2012-09-04 12:38:35

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

One more thing:
both the KDE network manger AND iwconfig report I'm not connected to the internet. But I am!

Maybe related?


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#10 2012-09-04 13:49:21

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

OdinEidolon wrote:

The plot thickens. Right now I'm on AC, battery unplugged. The system uses ondemand capped to 1.6GHz (wrong).
Still [snipped]


Regarding the governor issue it sounds like the pm-utils cpupower hook is still running for some reason. Check the pm-utils log with this command:

cat /var/log/pm-powersave.log

What does the output show for the cpupower script? I have it enabled on my system so I get:


[brandon@brandon-arch ~]$ cat /var/log/pm-powersave.log
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
Setting cpu: 1
Setting cpu: 2
Setting cpu: 3

/usr/lib/pm-utils/power.d/cpupower true: success.

With the hook disabled you should get:

[brandon@brandon-arch ~]$ cat /var/log/pm-powersave.log
Running hook /etc/pm/power.d/cpupower true:

EDIT: it appears the wiki introductions for disabling the hooks is a bit inaccurate. For me putting the dummy file in /etc/pm/sleep.d did not work at all, it needed to be placed in /etc/pm/power.d. So

sudo touch /etc/pm/power.d/cpupower

should disable it, I tested it on my machine and that worked.

Last edited by bwat47 (2012-09-04 14:48:52)

Offline

#11 2012-09-04 14:09:16

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Ok rebooted and this is the output of the pm-powersave log file:
(AC IN, no battery)
(pastebin)
http://pastebin.com/Kf2Lx7UQ


If I grep cpupower:

Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower true:
Setting cpupower frequency governor to conservative...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower true: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.
Running hook /usr/lib/pm-utils/power.d/cpupower false:
Setting cpupower frequency governor to ondemand...Setting cpu: 0
/usr/lib/pm-utils/power.d/cpupower false: success.

right now:

1) cpupower reports ondemand and 2.54GHz (right)
2) acpi -bi reports nothing as it should (battery is disconnected)
3) acpi -a reports AC in as it should
4) all KDE stuff works OK


Now I plug the battery in:

1) cpupower reports ondemand and 2.54GHz (right)
2) acpi -bi reports nothing, which is wrong
3) acpi -a reports AC in as it should
4) KDE battery monitor reports no battery in, as signaled by acpi
5) if performing acpi_listen ,it reports nothing interesting

Now I unplug AC:

Absolutely nothing changes (not even in the log file) but:
1) cpupower reports ondemand and 1.6GHz (wrong)
2) acpi -bi reports nothing, which is wrong
3) acpi -a reports no AC as it should
4) KDE battery monitor reports no battery in, as signaled by acpi,  but it also reports AC is inserted


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#12 2012-09-04 14:47:59

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

did you try disabling pm-utils cpupower via a dummy file in power.d as opposed to sleep.d (as in the edit in my above post)? from those logs It appears your pm-utils cpupower script is still running. I'm not sure about the acpi issues, but if the cpupower script is properly disabled it should at least stop setting your governor to conservative.

Last edited by bwat47 (2012-09-04 14:51:24)

Offline

#13 2012-09-04 14:58:49

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

bwat47 wrote:

did you try disabling pm-utils cpupower via a dummy file in power.d as opposed to sleep.d (as in the edit in my above post)? from those logs It appears your pm-utils cpupower script is still running. I'm not sure about the acpi issues, but if the cpupower script is properly disabled it should at least stop setting your governor to conservative.

Did not see the edit. By the way I used the "alternative method" described in the wiki.
I'll now try your method. However I have:

[adriano@M735T ~]  ls /usr/lib/pm-utils/sleep.d/
00logging  00powersave  01grub  01laptop-mode  49bluetooth  75modules  90clock  94cpufreq  95led  98video-quirk-db-handler  99video

As you see the module is cpufreq, not cpupower. Should I touch cpupower, cpufreq or 94cpufreq?

The cpupower systemd service is disabled, this is how it should be right? (LMT enabled) Just to be sure I'm not missing something idiotic right now, this issue is driving me mad.


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#14 2012-09-04 15:52:04

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

OdinEidolon wrote:
bwat47 wrote:

did you try disabling pm-utils cpupower via a dummy file in power.d as opposed to sleep.d (as in the edit in my above post)? from those logs It appears your pm-utils cpupower script is still running. I'm not sure about the acpi issues, but if the cpupower script is properly disabled it should at least stop setting your governor to conservative.

Did not see the edit. By the way I used the "alternative method" described in the wiki.
I'll now try your method. However I have:

[adriano@M735T ~]  ls /usr/lib/pm-utils/sleep.d/
00logging  00powersave  01grub  01laptop-mode  49bluetooth  75modules  90clock  94cpufreq  95led  98video-quirk-db-handler  99video

As you see the module is cpufreq, not cpupower. Should I touch cpupower, cpufreq or 94cpufreq?

The cpupower systemd service is disabled, this is how it should be right? (LMT enabled) Just to be sure I'm not missing something idiotic right now, this issue is driving me mad.

I didn't touch any of the default files under /usr/lib/pm-utils/sleep.d, I have the same ones. For some reason the main method on the wiki (putting dummy file in /etc/pm/sleep.d) and the alternative method (putting a blacklist file listing the modules in /etc/pm/config.d) don't work for me now. I know the alternate one at least used to work at one time, because that's the one I used to use. Right now the only method that seems to work for me for disabling pm-utils powersaving scripts is putting a dummy file of the same name in /etc/pm/power.d. I'm thinking the sleep.d method only works for disabling hooks in /usr/lib/pm-utils/sleep.d, and the power.d method only works for hooks in /usr/lib/pm-utils/power.d. I should probably add this to the wiki smile

Your culprit for this issue specifically is this script:  /usr/lib/pm-utils/power.d/cpupower. this is the script you see executed in the pm-powersave log setting the governor to conservative (you can also open the script and look at it, you can see the script is designed to use conservative on battery). scripts in /etc/pm/power.d override any pm-utils scripts in /usr/lib/pm-utils/power.d with the same name, so putting an empty file named "cpupower" in /etc/pm/power.d disables it. You could also copy the cpupower script from the /usr/lib directory to /etc/pm/power.d, modify it so it uses ondemand on battery too and use that to control cpupower instead of the LMT cpufreq module if you wanted to.

The systemd service file should be disabled unless you want to use that instead of LMT or pm-utils to set your governor. If you wanted to you could disable the LMT cpufreq module and the pm-utils cpupower script and enable the systemd cpupower service, which I *think* should set it to use ondemand on both ac and battery with any extra config needed (because since kernel 3.4 the default governor is ondemand afiak, and the systemd cpupower service won't change the governor depending on the power source, it just sets it once)

Last edited by bwat47 (2012-09-04 16:22:08)

Offline

#15 2012-09-04 17:04:51

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Unfortunately blocking cpupower, laptop-mode etc. hooks does not seem to work. The frequency is still capped at 1.6GHz by something, governor is ondemand.
The frequency capping is the problem.

I have absolutely no idea why this happens. I'll try changing the boot kernel line to see what happens.

Last edited by OdinEidolon (2012-09-04 17:05:29)


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#16 2012-09-04 17:20:35

bwat47
Member
Registered: 2009-10-07
Posts: 637

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

OdinEidolon wrote:

Unfortunately blocking cpupower, laptop-mode etc. hooks does not seem to work. The frequency is still capped at 1.6GHz by something, governor is ondemand.
The frequency capping is the problem.

I have absolutely no idea why this happens. I'll try changing the boot kernel line to see what happens.

So its at least stopped being set to conservative though? If its not getting set to conservative that that at least should rule out pm-utils causing anymore issues. Unfortunately, I have no idea what would cause it to stay capped at 1.6 if its telling you its on ondemand hmm Must be some other configuration somewhere setting that. Have you checked your /etc/conf.d/cpupower file? Make sure max_freq= isn't uncommented and set to 1.6?

Have you tried disabling the LMT cpufreq module too?

Last edited by bwat47 (2012-09-04 17:25:56)

Offline

#17 2012-09-04 18:01:35

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

bwat47 wrote:
OdinEidolon wrote:

Unfortunately blocking cpupower, laptop-mode etc. hooks does not seem to work. The frequency is still capped at 1.6GHz by something, governor is ondemand.
The frequency capping is the problem.

I have absolutely no idea why this happens. I'll try changing the boot kernel line to see what happens.

So its at least stopped being set to conservative though? If its not getting set to conservative that that at least should rule out pm-utils causing anymore issues. Unfortunately, I have no idea what would cause it to stay capped at 1.6 if its telling you its on ondemand hmm Must be some other configuration somewhere setting that. Have you checked your /etc/conf.d/cpupower file? Make sure max_freq= isn't uncommented and set to 1.6?

Have you tried disabling the LMT cpufreq module too?

Before it sometimes switched to conservative without any indication of doing so. But it mostly still run on ondemand. Now it seems to run only ondemand.
The cpupower file is commented apart from the governor line (ondemand). I have absolutely no idea on why it caps the frequency when on battery.
It seems there is something that echoes continuously 1600000 to

/sys/devices/system/cpu/cpu*/cpufreq/scaling_max_freq

, when it should be 2534000.


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#18 2012-09-04 20:34:39

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Have you checked whether laptop mode tools is doing this? It lets you set the maximum and minimum frequency under various conditions.

Also, check that cpupower.service is disabled. I don't understand the script for this but it definitely seems to do something with min/max frequencies.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#19 2012-09-05 06:58:37

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

cfr wrote:

Have you checked whether laptop mode tools is doing this? It lets you set the maximum and minimum frequency under various conditions.

Also, check that cpupower.service is disabled. I don't understand the script for this but it definitely seems to do something with min/max frequencies.

As per the first post the LMT config file seems OK, cpupower is disabled of course. I tried enabling it and disabling LMT and the freqency was still capped at 1.6GHz for some unknown reason.

Last edited by OdinEidolon (2012-09-05 07:01:39)


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#20 2012-09-05 08:18:47

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Ok I give up. It is completely senseless, now I'm on AC with the battery plugged, LMT active, cpupower inactive, and it is capped to 1.6GHz.

If I leave AC only (no battery) it stays 1.6GHz and acpi reports the battery as still present but 0%.

Putting the battery back in gets the actual acpi charge back.

The problem is that it acts casually. There is no real pattern to identify the problem.
If I reboot it will probably act differently. Why oh why!


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#21 2012-09-05 23:25:45

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

OdinEidolon wrote:

As per the first post the LMT config file seems OK, cpupower is disabled of course. I tried enabling it and disabling LMT and the freqency was still capped at 1.6GHz for some unknown reason.

Does that show the entire config? /etc/laptop-mode/conf.d/cpufreq.conf has further settings on my machine. In particular, do you have:

CONTROL_CPU_THROTTLING=0

?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#22 2012-09-06 07:13:56

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

cfr wrote:
OdinEidolon wrote:

As per the first post the LMT config file seems OK, cpupower is disabled of course. I tried enabling it and disabling LMT and the freqency was still capped at 1.6GHz for some unknown reason.

Does that show the entire config? /etc/laptop-mode/conf.d/cpufreq.conf has further settings on my machine. In particular, do you have:

CONTROL_CPU_THROTTLING=0

?

Yes, I do have that line and it is like yours. After all my CPU never throttles (like almost all old laptops) as it never goes above 80°C even trying to stress it to the limit. It stays at 45-50°C during normal day to day use. Intel's declared thermal limit is 105 or 110°C on this CPU.


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#23 2012-09-09 09:04:17

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

Bump, I really hate this problem. Booting with other kernels does not solve the problem.


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#24 2012-09-12 07:24:16

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 373

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

This issue still bothers me. I've not seen conservative anymore but on battery the frequency is still capped at 1.6GHz. And added to this there is acpi which sometimes is extremely slow at picking up events, and sometimes even when it does KDE randomly decides not to pick them up from acpi!


Hardware: 2016 Dell XPS15 - FullHD - i5-6300HQ - 8GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#25 2012-09-12 23:47:29

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,675

Re: [SOLVED] Systemd and laptop-mode-tools frequency scaling

If you boot a live distro, do you have the same issue?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

Board footer

Powered by FluxBB