You are not logged in.

#1 2012-10-04 12:57:44

miro279
Member
Registered: 2010-10-02
Posts: 137

[SOLVED] Different versions of catalyst-utils

I updated the system today and wasn't able to boot intoo X. After all the reason for that was that I had installed a newer version of catalyst-utils that doesn't support my video-card. There is community/catalyst-utils 12.8-0.3 and catalyst-hd234k/catalyst-utils 12.6-1. I can only use the later.
Still when I run a system update pacman want's to update to the community package. How can I prevent?

Last edited by miro279 (2012-10-05 05:35:38)

Offline

#2 2012-10-04 15:43:24

p0x8
Member
Registered: 2012-09-20
Posts: 67

Re: [SOLVED] Different versions of catalyst-utils

Check the wiki at https://wiki.archlinux.org/index.php/Pa … g_upgraded.
I'm not sure if you can specify a 'repository/package' combination though.

Offline

#3 2012-10-04 18:15:36

miro279
Member
Registered: 2010-10-02
Posts: 137

Re: [SOLVED] Different versions of catalyst-utils

I don't want to skip any further updates. I'm using a repository for older ati cards, eg catalyst-hd234k, the community repository is for the newer cards.. Problem is that  both packages have the same name and the community one has the newer version. I'd need a way to somewho blacklist the community version.
I don't know how this was handled before, mayb the version numbers where the same? Community version was updated today which seems to have caused the problem..

Offline

#4 2012-10-04 19:35:47

ilusi0n
Member
Registered: 2010-06-09
Posts: 187

Re: [SOLVED] Different versions of catalyst-utils

in /etc/pacman.conf just put the catalyst-hd234k repository above the core repository and you will not have those kind of conflits

Offline

#5 2012-10-05 05:35:59

miro279
Member
Registered: 2010-10-02
Posts: 137

Re: [SOLVED] Different versions of catalyst-utils

That did the trick! Thanks a lot!

Offline

Board footer

Powered by FluxBB