You are not logged in.

#1 2012-11-24 22:19:41

CaptainKirk
Member
Registered: 2009-06-07
Posts: 335

[Solved] Hebrew File Names

I have Hebrew installed I think:

[kirk@arch ~]$ locale
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=
[kirk@arch ~]$ locale -a
C
POSIX
en_US
en_US.iso88591
en_US.utf8
he_IL
he_IL.iso88598
he_IL.utf8
hebrew
[kirk@arch ~]$ more  /etc/fstab
# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
tmpfs		/tmp	tmpfs	nodev,nosuid	0	0
# UUID=92d68525-22b2-4619-a35a-0ba35df05b89
/dev/sda2           	/         	ext4      	rw,relatime,data=ordered	0 1 

# UUID=fb6f5666-6075-4cfc-9105-30052be224e3
/dev/sda1           	/boot     	ext4      	rw,relatime,data=ordered	0 2

# UUID=fcb00885-7ad0-46c0-8d68-40cde74e1a1a
/dev/sda5           	/srv      	ext4      	rw,relatime,data=ordered	0 2

# UUID=35b3b21c-82f5-4db6-8406-8bd19c9d4aeb
/dev/sda3           	/home     	ext4      	rw,relatime,data=ordered	0 2

and setxkbmap il works to set Hebrew for my applications (I have the culmus package installed which provides Hebrew fonts), but not for my terminal and I can't save filenames in Hebrew.

What am I doing wrong? Do I need to put Hebrew fonts into my Console fonts directory?

Last edited by CaptainKirk (2012-11-25 13:55:08)

Offline

#2 2012-11-25 05:22:08

fschiff
Member
Registered: 2011-10-06
Posts: 71

Re: [Solved] Hebrew File Names

post your /etc/locale.conf and /etc/vconsole.conf

LANG=C
means you don't have a language set

You did uncomment the codes in /etc/locale.gen for English and Hebrew
before typing locale-gen at the command prompt?

Last edited by fschiff (2012-11-25 05:32:06)

Offline

#3 2012-11-25 09:56:49

CaptainKirk
Member
Registered: 2009-06-07
Posts: 335

Re: [Solved] Hebrew File Names

fschiff wrote:

post your /etc/locale.conf and /etc/vconsole.conf

Both are "No such file or directory"

fschiff wrote:

LANG=C
means you don't have a language set

I was wondering about that. Anyhow I want English as my main language. I just want Hebrew also.

fschiff wrote:

You did uncomment the codes in /etc/locale.gen for English and Hebrew
before typing locale-gen at the command prompt?

Yes.

Offline

#4 2012-11-25 10:19:51

SoleSoul
Member
From: Israel
Registered: 2009-06-29
Posts: 309

Re: [Solved] Hebrew File Names

If you use systemd you should use its config files: https://wiki.archlinux.org/index.php/Sy … figuration

The locale output you posted is not related to your question. I have Hebrew enabled and typing locale here outputs:

% locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

The locale -a output is similar to yours.
If you changed your locale configurations before the last kernel update you may need to "mkinitcpio" manually. Not sure.

Edit: Hebrew file names work fine.

Last edited by SoleSoul (2012-11-25 10:21:21)

Offline

#5 2012-11-25 11:12:36

thisoldman
Member
From: Pittsburgh
Registered: 2009-04-25
Posts: 1,172

Re: [Solved] Hebrew File Names

Yes, you do have to set a console font that includes Hebrew characters.  The default console font does not include them.  The culmus AUR package does not include any console fonts.

Offline

#6 2012-11-25 13:28:22

fschiff
Member
Registered: 2011-10-06
Posts: 71

Re: [Solved] Hebrew File Names

CaptainKirk wrote:
fschiff wrote:

post your /etc/locale.conf and /etc/vconsole.conf

Both are "No such file or directory"

So, I go over to your house and hit you over the head with a loaf of bread. 
Why? 
Cause you should have those two files setup if you followed the wiki (Beginner's Guide and locale)

You are getting LANG=C because the first file doesn't exist.  You are getting problems seeing the hebrew filesnames cause you are using the default console fonts which don't have support of all languages.

echo LANG="en_US.UTF-8" > /etc/locale.conf

Fill in /etc/vconsole.conf with your console font info and you will see hebrew characters when you type ls in the terminal.

Offline

#7 2012-11-25 13:54:49

CaptainKirk
Member
Registered: 2009-06-07
Posts: 335

Re: [Solved] Hebrew File Names

fschiff wrote:

So, I go over to your house and hit you over the head with a loaf of bread.

Sir, so long as the bread isn't frozen, you are welcome to visit. I have butter for you and chumus for me for the bread, if it survives the collision with my skull. smile

fschiff wrote:

You are getting LANG=C because the first file doesn't exist.  You are getting problems seeing the hebrew filesnames cause you are using the default console fonts which don't have support of all languages.

That indeed fixed it. Thank you very much for your assistance. I really appreciate it.

Offline

Board footer

Powered by FluxBB