You are not logged in.

#1 2013-02-04 03:36:35

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

[Solved] Vim breaks TTY output

Everything works fine in my TTY until I use vim, then all further input is unreadable gibberish until next boot.  I have tested other commands and applications (pstree, canto, iptraf).  None of these cause any problems.  Only vim.

This is the output from ":language" in vim:

Current language: 
"LC_CTYPE=en_US.UTF-8;
LC_NUMERIC=C;
LC_TIME=en_US.UTF-8;
LC_COLLATE=C;
LC_MONETARY=en_US.UTF-8;
LC_MESSAGES=en_US.UTF-8;
LC_PAPER=en_US.UTF-8;
LC_NAME=en_US.UTF-8;
LC_ADDRESS=en_US.UTF-8;
LC_TELEPHONE=en_US.UTF8;LC_MEASUREMENT=en_US.UTF-8;
LC_IDENTIFICATION=en_US.UTF-8"

locale:

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

locale -a

C
POSIX
en_US
en_US.iso88591
en_US.utf8

Last edited by the sad clown (2013-02-04 13:24:21)


I laugh, yet the joke is on me

Offline

#2 2013-02-04 04:12:05

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,424
Website

Re: [Solved] Vim breaks TTY output

I realized I haven't tried Vim in a TTY since upgrading to systemd. Unlike your situation, I don't seem to end up with any gibberish. hmm

Is something in your .vimrc file messing things up?

Offline

#3 2013-02-04 05:02:24

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [Solved] Vim breaks TTY output

I don't have a complex .vimrc:

" All system-wide defaults are set in $VIMRUNTIME/archlinux.vim (usually just
" /usr/share/vim/vimfiles/archlinux.vim) and sourced by the call to :runtime
" you can find below.  If you wish to change any of those settings, you should
" do it in this file (/etc/vimrc), since archlinux.vim will be overwritten
" everytime an upgrade of the vim packages is performed.  It is recommended to
" make changes after sourcing archlinux.vim since it alters the value of the
" 'compatible' option.

" This line should not be removed as it ensures that various options are
" properly set to work with the Vim-related packages.
runtime! archlinux.vim

" If you prefer the old-style vim functionalty, add 'runtime! vimrc_example.vim'
" Or better yet, read /usr/share/vim/vim73/vimrc_example.vim or the vim manual
" and configure vim to your own liking!

filetype plugin indent on
syntax on

I laugh, yet the joke is on me

Offline

#4 2013-02-04 05:12:21

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [Solved] Vim breaks TTY output

I just deleted .vimrc.  Nothing changed.


I laugh, yet the joke is on me

Offline

#5 2013-02-04 12:07:39

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,518
Website

Re: [Solved] Vim breaks TTY output

What is $TERM set to?  If it is not "linux" and you do not otherwise disable it, this might be a result of the "Thanks for flying vim" message which includes escape codes to be put in terminal emulator window titles.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#6 2013-02-04 12:37:42

the sad clown
Member
From: 192.168.0.X
Registered: 2011-03-20
Posts: 833

Re: [Solved] Vim breaks TTY output

You're right, it's set to rxvt-unicode.  How do I correct this?

Edit: nvm, I found the TERM=rxvt-unicode in my .bash_profile.  I still am not sure how it got there since I don't recall putting it there.  I removed it and everything is fine now.  Thanks.

Last edited by the sad clown (2013-02-04 13:22:48)


I laugh, yet the joke is on me

Offline

Board footer

Powered by FluxBB