You are not logged in.

#1 2013-02-23 22:16:24

sberghel
Member
Registered: 2013-02-23
Posts: 20

[SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

When I press Ctrl+Alt+F1, nothing happens. This wiki page suggests I should have agetty installed (although it's also pretty out of date, as it refers to init), but

pacman -Ss agetty

doesn't turn up anything. This is a fresh Arch Linux  install from the 2013.02.01 install disc.

Curiously, on my other computer, I don't appear to have any gettys installed, as

pacman -Ss getty

doesn't show any installed packages, but Ctrl-Alt-F1 gets me to a TTY. That computer has an installation from November.

Last edited by sberghel (2013-12-15 02:32:44)


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#2 2013-02-23 22:40:24

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

The wiki article says agetty is a part of the util-linux package.

/sbin/agetty is owned by util-linux 2.22.2-1

What does "systemctl status getty@tty1.service" show?

Offline

#3 2013-02-23 23:07:26

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

[skye@Banzai chromium]$ systemctl status getty@tty1.service
getty@tty1.service - Getty on tty1
	  Loaded: loaded (/usr/lib/systemd/system/getty@.service; enabled)
	  Active: active (running) since Sat 2013-02-23 13:43:38 PST; 1h 22min ago
	    Docs: man:agetty(8)
	          man:systemd-getty-generator(8)
	          http://0pointer.de/blog/projects/serial-console.html
	Main PID: 370 (agetty)
	  CGroup: name=systemd:/system/getty@.service/tty1
		  └─370 /sbin/agetty --noclear tty1 38400 linux

So it looks like everything is as it should be...except that ctrl-alt-F1 doesn't go to a tty.

Last edited by sberghel (2013-02-23 23:08:56)


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#4 2013-02-23 23:12:42

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

That looks fine. Are you at another tty? Or have you installed X etc.? If the latter, what DE/WM are you running?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#5 2013-02-23 23:15:47

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,001
Website

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

I'm just taking a stab at this without knowing much, but could keyboard layout or keymap change the ctrl+alt+f# ?


github       bible       blog       screenshot

Online

#6 2013-02-23 23:18:24

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

I'm using xfce4, which I get to using SLiM. I'm using a standard US QWERTY keymap/keyboard-layout.


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#7 2013-02-23 23:21:06

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

Perhaps you have "Option "DontVTSwitch"" set to "true" in xorg.conf[.d].

Offline

#8 2013-02-23 23:23:44

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

Nope. In my xorg.conf.d I have 10-evdev.conf:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

and 10-quirks.conf

# Collection of quirks and blacklist/whitelists for specific devices.


# Accelerometer device, posts data through ABS_X/ABS_Y, making X unusable
# http://bugs.freedesktop.org/show_bug.cgi?id=22442 
Section "InputClass"
        Identifier "ThinkPad HDAPS accelerometer blacklist"
        MatchProduct "ThinkPad HDAPS accelerometer data"
        Option "Ignore" "on"
EndSection

Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#9 2013-02-23 23:34:59

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

You don't have anything in /etc/X11/xorg.conf?

Perhaps XFCE has some keyboard layout options like shown on http://askubuntu.com/questions/50855/pr … ching-ttys

Perhaps you did some xmodmap magic.

Do you use slim on the other PC?

What if you don't boot into X or kill X?

You could look at xorg's logs.

Offline

#10 2013-02-23 23:58:15

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,001
Website

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

Have you tried the other F keys? ctrl+alt+f2 ? 
Is there any errors displayed?

can you try

chvt 2

and see if that brings you to tty2?


github       bible       blog       screenshot

Online

#11 2013-02-23 23:59:14

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

No, I have nothing in /etc/X11/xorg.conf .

When I press Ctrl+Alt+F[1-6] I don't see anything happening in my xorg logs. Here's an example log: http://pastebin.com/1tw05wFu

I don't see any options like that in XFCE in either the "keyboard" section or the "keyboard shortcuts" section.

I haven't done any xmodmap magic.

I use Slim on the other PC, where it works.

If I don't boot into X, or if I kill X, then F1-6 work fine (and I get a tty to type on).

Last edited by sberghel (2013-02-24 00:00:26)


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#12 2013-02-23 23:59:57

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

[skye@Banzai xinitrc.d]$ chvt 2
Couldn't get a file descriptor referring to the console

I assume that's bad?


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#13 2013-02-24 00:15:00

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

What's in /etc/systemd/logind.conf?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#14 2013-02-24 00:16:27

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

/etc/systemd/logind.conf:

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# See logind.conf(5) for details

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#IdleAction=ignore
#IdleActionSec=30min

Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#15 2013-02-24 00:17:37

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,001
Website

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

Yes that is the error that is blocking you from getting into tty2.  chvt 2 is the equivalent to ctrl+alt+f2

edit: was this tried in a vritual terminal or after starting x?  (sorry, I'm learning with you as we explore this)

edit: just realized this is a fresh install...

Last edited by frank604 (2013-02-24 00:22:20)


github       bible       blog       screenshot

Online

#16 2013-02-24 00:24:38

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

I tried that after starting X. If I try it in a virtual terminal before I start X, it changes over to tty2.


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

#17 2013-02-24 00:28:44

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,001
Website

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

Then disregard that error, it is as designed.  I'm fresh out of ideas for you.


github       bible       blog       screenshot

Online

#18 2013-02-24 00:33:54

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,001
Website

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

If you don't have xorg.conf can you add the following to it and reboot to test?

Section "ServerFlags"
Option "HandleSpecialKeys" "always"
EndSection

If one exists, can you append to it?

Edit: if it doesn't work with this, just delete it.

Last edited by frank604 (2013-02-24 00:34:21)


github       bible       blog       screenshot

Online

#19 2013-12-15 02:32:12

sberghel
Member
Registered: 2013-02-23
Posts: 20

Re: [SOLVED] I don't appear to have any TTYs - Ctrl+Alt+FX does nothing

That fixed it. Thanks!


Arch machines: Acer Aspire S3, Frankendesktop, netbook, obsolete Thinkpad

Offline

Board footer

Powered by FluxBB