You are not logged in.

#1 2013-03-20 05:26:32

anitac
Member
Registered: 2011-06-15
Posts: 25

Hard drive started spinning down automatically

Recently (possibly after an update) my hard drive seems to spin down after a few seconds of inactivity. How can I make it never spin down automatically?

Offline

#2 2013-03-20 06:04:41

MagicSkyFairy
Member
Registered: 2013-03-14
Posts: 79

Re: Hard drive started spinning down automatically

Goto settings->power manager and uncheck the "Spin down hard disks" checkboxes under battery and ac, maybe?

Last edited by MagicSkyFairy (2013-03-20 06:04:57)


I have wasted atleast a second of your time by making you read my signature.

Offline

#3 2013-03-20 06:18:44

t0m5k1
Member
From: overthere
Registered: 2012-02-10
Posts: 307

Re: Hard drive started spinning down automatically

have you checked to see how often it does spin down?

sudo smartctl -a /dev/sda

this thread may also help:
https://bbs.archlinux.org/viewtopic.php?id=138721

once you are certain you can try:

hdparm -S 0 /dev/sda

there might be other things to try so i suggest searching the bbs & google for more info, also check which make/model the drive in question is & find some info pertaining to your drive.


Optiplex 790, Intel Core i3-2100 CPU @ 3.10GHz 16Mb Corsair Vengeance 1333Mhz - GeForce 970 - AwesomeWM (occasionally XFCE, i3)

If everything in life was easy, we would learn nothing!
Linux User: 401820   Last FM

Offline

#4 2013-03-20 21:51:34

kardia
Member
From: NH, USA
Registered: 2010-01-15
Posts: 14

Re: Hard drive started spinning down automatically

Common issue with laptops, odd that it only started after an update though. The 'Laptop' wiki page details the issue/solution well.

https://wiki.archlinux.org/index.php/La … wn_problem

Offline

#5 2013-03-20 22:19:08

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Hard drive started spinning down automatically

I used to use hdparm to set the value of APM super high.  I had a udev rule to set it automatically when it detected a certain disk that would make crunching sounds when it spun down.


Edit: as noted above, I too noticed just the other day that smartctl seems to also have this functionality, though I have never tried it.  The above suggestion to use "hdparm -S <value> /dev/sdX" might work, as it is the spindown timeout, but you probably want to use the "-B" flag as this is what directly controls APM.  See the hdparm man page for more infos.

Last edited by WonderWoofy (2013-03-20 22:21:22)

Offline

Board footer

Powered by FluxBB