You are not logged in.

#1 2013-04-24 00:00:25

Registered: 2013-04-23
Posts: 2

rfkill block central

Firstly, thank you for having me on your forums. Of all the linux centered forums I've lurked Arch's userbase one of the most knowledgeable and helpful.  smile

My problem basically boils down to Rfkill stubbornly listing my built in wireless chip as hard-blocked, despite all attempts to release it.

Some things to observe:
*The Arch installation I'm on is fresh. After switching from crunchbang I used to beginner guide to hack together the install I'm on now, which is in a fluxbox environment and has a few basically functioning facilities.

*These issues didn't persist on crunchbang

*Booting right now requires 'acpi=off' to be appended in the boot file, otherwise the display locks up and turns dark.

* I've properly setup the b43 drivers needed for my wireless card model. I can assume this since the interface now returns with iwconfig (as wlan0) when it didn't before the fact.

*At the moment I'm getting my internet from a external wireless antenna which hasn't had any of the issues with Rfkill I've mentioned.

Somethings that haven't worked:

*rfkill block all; rfkill unblock all; rmmod b43; or any combination of these and other rfkill commands. 

*blacklisting rfkill in blacklist.conf

*blacklisting b43 in blacklist.conf

*removing the battery.

*modprobe b43

*alternative network managers. NetworkManager or wicd respectively. (Nither of which I got working to capacity to begin with)

*disabling my external wireless antenna.

Some helpful information:

$ iwconfig
wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
enp8s8    no wireless extensions.

lo        no wireless extensions.

wlp0s29f7u4  IEEE 802.11bg  ESSID:"COOLPLAY"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: A8:39:44:4F:67:74   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=64/70  Signal level=-46 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:7  Invalid misc:5   Missed beacon:0
$ rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: phy1: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
$ dmesg | grep firmware
[    0.000000] SFI: Simple Firmware Interface v0.81 [url][/url]
[   11.623366] b43-phy1: Loading firmware version 666.2 (2011-02-23 01:15:07)
$ sudo ip link set wlan0 up
[sudo] password for [redacted username]: 
RTNETLINK answers: Operation not possible due to RF-kill

I'm open to all solutions at this point. Anyone willing to help will have my full cooperation and thanks.

Last edited by Smiffybagels (2013-04-24 00:23:00)


#2 2013-04-24 00:18:21

From: Cymru
Registered: 2011-11-27
Posts: 6,083

Re: rfkill block central

There is no reason this should work but I have a problem which is similar with bluetooth and it works for me there. Have you tried resetting the BIOS to defaults? That's the only thing which works in my case but obviously you are seeing something not the same...

How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L


#3 2013-04-24 00:21:43

Registered: 2013-04-23
Posts: 2

Re: rfkill block central

I wasn't aware I was on an alternate BIOS. I'll google ways of reverting it.

e; as far as I can tell my BIOS isn't changed. Could I be wrong?

Last edited by Smiffybagels (2013-04-24 02:53:56)


Board footer

Powered by FluxBB