You are not logged in.

#1 2013-05-03 14:43:45

bhush
Member
Registered: 2013-05-01
Posts: 7

Lightworks on Arch Linux

So I have managed to write initial PKGBUILD for Lightworks.

https://github.com/bhush9/lightworks-arch

After installation it requires you to install libtiff4 from the AUR,

Now thing is sign in is not working yet...

Does installing openssl fix problem or what...?


The problem is not the problem, Problem is your attitude about the problem.

-Captain Jack Sparrow

Offline

#2 2013-05-03 15:37:05

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,523
Website

Re: Lightworks on Arch Linux

bhush wrote:

After installation it requires you to install libtiff4 from the AUR

I'm confused. If the package "libtiff4" is required, why isn't "libtiff4" in "depends"?

Offline

#3 2013-05-03 16:19:03

bhush
Member
Registered: 2013-05-01
Posts: 7

Re: Lightworks on Arch Linux

okay changed libtiff to libtiff4


The problem is not the problem, Problem is your attitude about the problem.

-Captain Jack Sparrow

Offline

#4 2013-05-03 18:03:43

anonymous_user
Member
Registered: 2009-08-28
Posts: 3,058

Re: Lightworks on Arch Linux

BTW what is the point of having:

conflicts=("lightworks")
provides=("lightworks"="11.1")

The first is simply strange. Whats the point of conflicting with itself? And the second, do other programs rely on lightworks?

Also I cannot download the source url. Do you need an account to access the download?

Offline

#5 2013-05-04 03:46:55

bhush
Member
Registered: 2013-05-01
Posts: 7

Re: Lightworks on Arch Linux

anonymous_user wrote:

Also I cannot download the source url. Do you need an account to access the download?

yes


The problem is not the problem, Problem is your attitude about the problem.

-Captain Jack Sparrow

Offline

#6 2013-05-06 13:14:31

mrdude
Member
Registered: 2013-02-20
Posts: 4

Re: Lightworks on Arch Linux

I had to install nvidia-cg-toolkit to make it work. I was getting this without it :

/usr/lib/lightworks/spawn: error while loading shared libraries: libCg.so: cannot open shared object file: No such file or directory

And had some other minor problems during lightworks package installation

warning: directory permissions differ on /usr/share/lightworks/Preferences/
filesystem: 777  package: 755
ln: failed to create symbolic link ‘./libcurl.so’: File exists
error: command failed to execute correctly

Worked anyway though

Offline

#7 2013-05-07 01:08:33

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,616
Website

Re: Lightworks on Arch Linux

When I try to run it, I get:

/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)

The startup splash screen just hangs at Initialising play engine.... (and they spelled "initialising" that way).


Matt

"It is very difficult to educate the educated."

Offline

#8 2013-05-07 03:56:27

bhush
Member
Registered: 2013-05-01
Posts: 7

Re: Lightworks on Arch Linux

mrunion wrote:

When I try to run it, I get:

/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)

The startup splash screen just hangs at Initialising play engine.... (and they spelled "initialising" that way).

Re install openssl


The problem is not the problem, Problem is your attitude about the problem.

-Captain Jack Sparrow

Offline

#9 2013-05-08 01:46:40

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,616
Website

Re: Lightworks on Arch Linux

I re-installed openssl and still get the same issue. Thanks for trying, though!


Matt

"It is very difficult to educate the educated."

Offline

#10 2013-05-08 01:55:01

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: Lightworks on Arch Linux

AFAIK, that *shouldn't* matter, as that's more a warning than anything and shouldn't affect the function of the program. The situation is that debian/ubuntu patch openssl to provide versioned symbols. Arch, of course, doesn't patch packages if they can help it.

Offline

#11 2013-05-08 23:16:20

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,616
Website

Re: Lightworks on Arch Linux

Cool. Thanks for the info. For whatever reason, it just sticks on the initialization screen above no matter how long I wait -- progress bar stays 50% across and no further movement.

Thanks again for the help, though.


Matt

"It is very difficult to educate the educated."

Offline

#12 2013-05-09 20:58:42

numasan
Member
Registered: 2009-11-13
Posts: 23

Re: Lightworks on Arch Linux

mrunion wrote:

When I try to run it, I get:

/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)

The startup splash screen just hangs at Initialising play engine.... (and they spelled "initialising" that way).

Same here for me. Also re-installed openssl but no go... sad

Offline

#13 2013-05-09 22:00:31

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: Lightworks on Arch Linux

numasan wrote:
mrunion wrote:

When I try to run it, I get:

/usr/lib/lightworks/ntcardvt: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /usr/lib/lightworks/libOSPrivate.so)

The startup splash screen just hangs at Initialising play engine.... (and they spelled "initialising" that way).

Same here for me. Also re-installed openssl but no go... sad


Do

ln -s /usr/lib/libcurl.so /usr/lib/x86_64-linux-gnu/libcurl.so

and lightworks will work properly

Offline

#14 2013-05-10 01:51:11

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,616
Website

Re: Lightworks on Arch Linux

sudo ln -s /usr/lib/libcurl.so /usr/lib/x86_64-linux-gnu/libcurl.so
[sudo] password for <xxxxxxx>: 
ln: failed to create symbolic link ‘/usr/lib/x86_64-linux-gnu/libcurl.so’: No such file or directory

I didn't have 'x86_84-linux-gnu directory on machine. I created it and re-issued the link command. I re-ran lightworks and still got the same problem.

I assume this just won't run for some people? I don't know if there is a missing dependency or something. Thanks for all the suggestions!

Last edited by mrunion (2013-05-10 01:51:45)


Matt

"It is very difficult to educate the educated."

Offline

#15 2013-05-10 09:06:38

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: Lightworks on Arch Linux

I found what causes the error startup error: JACK sound server. By stopping jack portaudio does not raise an error and the program starts. I found that in ~/Lightworks/Logs/StdErr.log

Offline

#16 2013-05-10 10:20:30

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: Lightworks on Arch Linux

mrunion wrote:
sudo ln -s /usr/lib/libcurl.so /usr/lib/x86_64-linux-gnu/libcurl.so
[sudo] password for <xxxxxxx>: 
ln: failed to create symbolic link ‘/usr/lib/x86_64-linux-gnu/libcurl.so’: No such file or directory

I didn't have 'x86_84-linux-gnu directory on machine. I created it and re-issued the link command. I re-ran lightworks and still got the same problem.

I assume this just won't run for some people? I don't know if there is a missing dependency or something. Thanks for all the suggestions!

I also had to create /usr/lib/x86_64-linux-gnu directory and then create symbolic link. I don't have nvidia graphic card but also had to install nvidia-cg-toolkit to make lwks working.

Offline

#17 2013-05-10 10:58:07

Pajaro
Member
Registered: 2004-04-21
Posts: 878

Re: Lightworks on Arch Linux

tydell wrote:
mrunion wrote:
sudo ln -s /usr/lib/libcurl.so /usr/lib/x86_64-linux-gnu/libcurl.so
[sudo] password for <xxxxxxx>: 
ln: failed to create symbolic link ‘/usr/lib/x86_64-linux-gnu/libcurl.so’: No such file or directory

I didn't have 'x86_84-linux-gnu directory on machine. I created it and re-issued the link command. I re-ran lightworks and still got the same problem.

I assume this just won't run for some people? I don't know if there is a missing dependency or something. Thanks for all the suggestions!

I also had to create /usr/lib/x86_64-linux-gnu directory and then create symbolic link. I don't have nvidia graphic card but also had to install nvidia-cg-toolkit to make lwks working.

The new AUR PKGBUILD already takes care of it

EDIT: https://aur.archlinux.org/packages/lwks/

Last edited by Pajaro (2013-05-10 11:04:45)

Offline

#18 2013-05-11 00:50:24

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,616
Website

Re: Lightworks on Arch Linux

I will try building from AUR again. FWIW, this is all that is in my log:

ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
ATTENTION: default value of option vblank_mode overridden by environment.
Compiling shader : /usr/share/lightworks/Shaders/curves.fx .. done
Compiling shader : /usr/share/lightworks/Shaders/chanshift.fx .. done
Compiling shader : /usr/share/lightworks/Shaders/ColourConvert.fx .. done
Compiling shader : /usr/share/lightworks/Shaders/greyscale.fx .. done
Compiling shader : /usr/share/lightworks/Shaders/ColTemp.fx .. done
Compiling shader : /usr/share/lightworks/Shaders/selectivecc.fx .. 

Last edited by mrunion (2013-05-11 00:50:45)


Matt

"It is very difficult to educate the educated."

Offline

#19 2013-05-17 00:08:30

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,616
Website

Re: Lightworks on Arch Linux

FWIW, it's finally running! For a few days I as getting corrupted downloads -- the data.tar.gz file was corrupt in the DEB file.

Anyway, I recompiled and it is running now. Woohoo!

Is it normal that when it ran I have a Pro license that expires in 7 days?


Matt

"It is very difficult to educate the educated."

Offline

#20 2013-05-17 03:26:50

bhush
Member
Registered: 2013-05-01
Posts: 7

Re: Lightworks on Arch Linux

mrunion wrote:

Is it normal that when it ran I have a Pro license that expires in 7 days?

Yes!


The problem is not the problem, Problem is your attitude about the problem.

-Captain Jack Sparrow

Offline

#21 2013-11-18 17:59:21

Daerun
Member
Registered: 2011-02-07
Posts: 74

Re: Lightworks on Arch Linux

Will this program be available again, now that a beta has been released?

http://www.lwks.com/index.php?option=co … d=81#56304

Offline

#22 2014-01-21 16:08:58

Glinx
Member
Registered: 2010-10-12
Posts: 26

Re: Lightworks on Arch Linux

Is anyone experiencing laggy/very slow performance with lightworks?

http://www.lwks.com/index.php?option=co … &Itemid=81

Offline

#23 2014-01-30 00:26:46

ChemBro
Member
Registered: 2008-10-22
Posts: 682

Re: Lightworks on Arch Linux

It's final and out for Linux. Any progress with the AUR package?

Offline

#24 2014-01-31 05:28:18

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: Lightworks on Arch Linux

Offline

#25 2014-02-01 06:01:11

Frabato
Member
Registered: 2007-10-24
Posts: 267

Re: Lightworks on Arch Linux

lwks 11.1.H-2 outdated and it looks like kallisti5 has provided a pkgbuild for version 11.5 but I'm having problems with the build. It requires libtiff4 which I have installed:

[a@StudioA ~]$ yaourt libtiff4
1 aur/lib32-libtiff4 1:3.9.5-6 (48)
    A package that installs libtiff.so.4
2 aur/libtiff4 3.9.7-2 [installed] (117)

but this shows that it's going to be built from AUR:

==> lwks dependencies:
 - gtk3 (already installed)
 - portaudio_cpp (already installed)
 - libgl (already installed)
 - glu (already installed)
 - ffmpeg (already installed)
 - libedit (already installed)
 - libtiff4, (building from AUR)
 - nvidia-cg-toolkit (package found)

and then:

==> Building and installing package
==> Install or build missing dependencies for lwks:
error: target not found: libtiff4,
==> Restart building lwks ? [y/N]
==> -----------------------------
==>

Can anyone help with what I may be missing here?

Thanks

Offline

Board footer

Powered by FluxBB