You are not logged in.

#1 2013-08-01 18:15:03

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

[SOLVED] VLC seg faults - no decoder module

upgraded vlc (2.0.7-2 -> 2.0.8-1)

vlc[615]: segfault at 0 ip af800414 sp b04c4220 error 6 in libavcodec_plugin.so[af7f7000+16000]

91904 Jul 31 03:10 /usr/lib/vlc/plugins/codec/libavcodec_plugin.so*

Last edited by Kilzool (2013-08-02 13:44:16)

Offline

#2 2013-08-01 18:30:59

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] VLC seg faults - no decoder module

I don't have this issue at all.  I think you need to provide a post with some effort put into detailing what is happening for you.

Offline

#3 2013-08-01 18:37:39

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: [SOLVED] VLC seg faults - no decoder module

VLC exits (crashes), with that error in the syslog.. when trying to access a site with WVM3 video/audio.
And I can't give you the site, as it is internal.

Last edited by Kilzool (2013-08-01 18:38:20)

Offline

#4 2013-08-01 18:43:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] VLC seg faults - no decoder module

Okay that it slightly more information.  Honestly, this is a pretty poor effort as providing more information.

I didn't ask you for the site, nor do I think it is relevant if it is happening for a certain type of file and not just a single file.

Offline

#5 2013-08-01 21:49:46

acidrain
Member
Registered: 2012-02-06
Posts: 7

Re: [SOLVED] VLC seg faults - no decoder module

It seems the issue was partly resolved by updating ffmpeg to version 1:2.0-2.  VLC doesn't segfault anymore, but it doesn't read anything anymore.

When I try to play a wmv, it tells me:
No suitable decoder module:
VLC does not support the audio or video format "WMA2". Unfortunately there is no way for you to fix this.
No suitable decoder module:
VLC does not support the audio or video format "WMV3". Unfortunately there is no way for you to fix this.

With videos in H.264, I get:
No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

In the VLC log, I get these messages:
main decoder error: corrupt module: /usr/lib/vlc/plugins/codec/libavcodec_plugin.so

Which seems related to ffmpeg again.

Offline

#6 2013-08-01 22:09:16

saalty
Member
Registered: 2012-04-06
Posts: 46

Re: [SOLVED] VLC seg faults - no decoder module

Hi all!

I tried today to play some videos with vlc but I got always error (yesterday it's worked fine):

No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

Today were upgraded vlc, ffmpeg, installed new package ffmpeg-compat and after this pacman said that ffmpeg is no more requied.
Tried to downgrade both vlc and ffmpeg but problem not solved, even if I removed new ffmpef-compat package.

The newest version are:
vlc 2.0.8-1
ffmpeg-compat 1:0.10.8-3

Offline

#7 2013-08-01 23:02:35

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 150

Re: [SOLVED] VLC seg faults - no decoder module

Experiencing the same problem here with every video format I have tried so far.

If I mount a dvd iso, then that can be played without problem. But so far that is all I have been able to play.

Offline

#8 2013-08-01 23:03:49

lnxsrt
Member
Registered: 2013-03-23
Posts: 12

Re: [SOLVED] VLC seg faults - no decoder module

Same issue here with the

"no suitable decoder module for fourcc `h264'. VLC probably does not support this sound or video format"

message after upgrade today.

Offline

#9 2013-08-01 23:17:36

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,383
Website

Re: [SOLVED] VLC seg faults - no decoder module

Merging with the existing thread...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#10 2013-08-02 00:20:34

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: [SOLVED] VLC seg faults - no decoder module

I think something is wrong with the package. The md5sum listed in the PKGBUILD does not corrospond to the md5sum of the tarball it's downloading. I'm trying a rebuild right now to see if it's any different. If not, I'm going to try building 2.0.8a to see if it's fixed there.

Edit: It won't even build, this could be a while.

Last edited by Scimmia (2013-08-02 00:31:44)

Offline

#11 2013-08-02 00:31:04

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [SOLVED] VLC seg faults - no decoder module

Most likely the problem is with ffmpeg.  I am using the following version with success.  Supports hardware acceleration on my Intel Sandy Bridge laptop, ffmpeg 1:2.0-2 from Extra does not (as far as I can tell).

https://projects.archlinux.org/svntogit … adf3814e33

I also have ffmpeg-compat installed.  Not really sure what ffmpeg-compat adds to the mix, but I believe you still need ffmpeg for full functionality.

Offline

#12 2013-08-02 00:33:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: [SOLVED] VLC seg faults - no decoder module

David Batson, ffmpeg-compat is an old version of ffmpeg. Since the current package is (or atleast should be) using ffmpeg 0.10.8, ffmpeg 2.0 has nothing to do with this.

Edit: no good with either the 2.0.8 rebuild or with 2.0.8a. ldd libavcodec_plugin.so tells me that it can't find libavcodec.so.53 and libavutil.so.51, so the linker isn't finding the ffmpeg-compat libs.

Edit2: OK, got it. I'll file a bug report, but for anyone wanting to fix this now, edit /etc/ld.so.conf.d/ffmpeg-compat.conf and change the '\n' to an actual newline, then run 'sudo ldconfig'

Edit3: bug report: https://bugs.archlinux.org/task/36375

Edit4 (how many can I make smile): After fixing the linker issue, 2.0.8 (both from the repos and my rebuild) is segfaulting, but 2.0.8a is not. I marked vlc out of date, hopefully it will be updated soon.

Last edited by Scimmia (2013-08-02 02:17:26)

Offline

#13 2013-08-02 04:06:13

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] VLC seg faults - no decoder module

Updated VLC 2.0.7 to 2.0.8 yesterday and now getting this error.

No suitable decoder module:
VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this.


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#14 2013-08-02 04:08:50

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,383
Website

Re: [SOLVED] VLC seg faults - no decoder module

Merging with the existing thread...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#15 2013-08-02 04:14:02

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] VLC seg faults - no decoder module

How can I revert back to VLC 2.0.7 package until this issue resolved ?

EDIT: Never mind, found > https://wiki.archlinux.org/index.php/Do … g_Packages

I simply did this;

# ls -t /var/cache/pacman/pkg/ | grep vlc | head -2
# pacman -U /var/cache/pacman/pkg/vlc-2.0.7-2-x86_64.pkg.tar.xz

But the problem still exists. So this is not VLC it self then :-)
Will update this post if I find a workaround :-)

Last edited by TuxLyn (2013-08-02 04:17:25)


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#16 2013-08-02 04:16:36

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: [SOLVED] VLC seg faults - no decoder module

To do that, you would also need to downgrade ffmpeg as well as anything else you have that links to ffmpeg.

Offline

#17 2013-08-02 04:21:13

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] VLC seg faults - no decoder module

@Scimmia, I've just downgraded "ffmpeg" still same issue.

ls -t /var/cache/pacman/pkg/ | grep ffmpeg | head -4
pacman -U /var/cache/pacman/pkg/ffmpeg-1:2.0-1-x86_64.pkg.tar.xz
pacman -U /var/cache/pacman/pkg/ffmpeg-compat-1:0.10.8-3-x86_64.pkg.tar.xz

Try again ^_^


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#18 2013-08-02 04:23:04

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,133

Re: [SOLVED] VLC seg faults - no decoder module

You didn't downgrade far enough. You need ffmpeg 1.2 as well as a vlc package built against that version.

Offline

#19 2013-08-02 04:23:48

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] VLC seg faults - no decoder module

Alright I got it working by also downgrading "x264" pacakge big_smile

ls -t /var/cache/pacman/pkg/ | grep x264 | head -2
pacman -U /var/cache/pacman/pkg/x264-20130206-1-x86_64.pkg.tar.xz

This will do, until its fixed ^_^


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#20 2013-08-02 04:28:13

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] VLC seg faults - no decoder module

Also, if you want to ingore this packages for now. Edit /etc/pacman.conf
by uncommenting "IgnorePkg" line and adding this following pacakges;
IgnorePkg   = vlc ffmpeg ffmpeg-compat x264


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#21 2013-08-02 09:31:16

Daerandin
Member
From: Norway
Registered: 2013-05-07
Posts: 150

Re: [SOLVED] VLC seg faults - no decoder module

ffmpeg-compat, vlc and x264 was just updated, and it fixed the issue for me.

Offline

#22 2013-08-02 10:01:29

TuxLyn
Member
From: United States
Registered: 2011-10-26
Posts: 283

Re: [SOLVED] VLC seg faults - no decoder module

I can confirm, everything works now with this latest update smile Thank you.


::: Using Arch Linux Since October 25, 2011 :::
::: Tutorials: http://distrogeeks.com/ :::

Offline

#23 2013-08-02 12:20:03

silenceleaf
Member
Registered: 2013-03-16
Posts: 37

Re: [SOLVED] VLC seg faults - no decoder module

I hava exactly same problem on my laptop. I am in China

Offline

#24 2013-08-02 13:16:53

N3mes1s
Member
Registered: 2010-07-21
Posts: 10

Re: [SOLVED] VLC seg faults - no decoder module

same problem here, even after updating

Offline

#25 2013-08-02 13:42:44

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 228

Re: [SOLVED] VLC seg faults - no decoder module

Upgrade (since original post) has fixed the issue.

[PACMAN] upgraded x264 (20130702-1 -> 20130702-2)
[PACMAN] upgraded ffmpeg (1:2.0-1 -> 1:2.0-2)
[PACMAN] upgraded ffmpeg-compat (1:0.10.8-2 -> 1:0.10.8-4)
[PACMAN] upgraded vlc (2.0.8-1 -> 2.0.8.a-1)

And now whatever the issue was, is resolved.

Last edited by Kilzool (2013-08-02 13:43:56)

Offline

Board footer

Powered by FluxBB