You are not logged in.

#1 2014-03-08 08:30:24

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

[kde-unstable] KDE SC 4.13

Hi all,
it's again time for a new major release of KDE Software Compilation.

The first beta of the 4.13 series has been released.
As usual, you find the packages in the [kde-unstable] repo, which only contains beta/rc releases.
Read install instruction from here.

NOTE: It requires [testing] enabled.

The following packages have been added:
* kfilemetadata
* baloo
* baloo-widgets
* kdeedu-artikulate
* kqtquickcharts

KDE is migrating from Nepomuk to Baloo, because of this, I built KDE without Nepomuk support.
Dolphin, KDEPIM and Gwenview have already been ported to Baloo. It seems that KActivities will not be ported away from Nepomuk in those 4.x releases.
Amarok, KDE-Telepathy, Digikam and more still use Nepomuk, but future releases will not. You can take a look to this list.

Please report any packaging bug to our bug tracker.

KDE bugs go in the upstream bug tracker.
Have a nice update and testing!

Watch the list of known issues.

Offline

#2 2014-03-08 11:52:34

Box0
Member
From: Italy
Registered: 2011-09-21
Posts: 218

Re: [kde-unstable] KDE SC 4.13

Does kdelibs still needs Soprano?

edit: also, does anybody know how you configure Baloo? In SystemSettings I only have this:

http://i60.tinypic.com/2cp2m1g.png

where are the options to enable the email body search and similar stuff?




-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by Box0 (2014-03-08 13:05:05)

Offline

#3 2014-03-08 12:47:58

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE SC 4.13

Box0 wrote:

Does kdelibs still needs Soprano?

No, luckily it doesn't anymore.

I'm rebuilding packages right now.

Offline

#4 2014-03-08 20:10:53

Prometheus1
Member
Registered: 2014-03-08
Posts: 3

Re: [kde-unstable] KDE SC 4.13

There is a way to keep using Dolphin, Gwenview, Amarok etc.. at the latest version without having Baloo installed?

Offline

#5 2014-03-08 20:19:09

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE SC 4.13

Prometheus1 wrote:

There is a way to keep using Dolphin, Gwenview, Amarok etc.. at the latest version without having Baloo installed?

You couldn't do that with nepomuk, you can't do that with baloo. just disable it.

Offline

#6 2014-03-08 20:20:02

Prometheus1
Member
Registered: 2014-03-08
Posts: 3

Re: [kde-unstable] KDE SC 4.13

I know how to disable Nepomuk but not Baloo, can you give me an hint please?

Offline

#7 2014-03-08 21:14:42

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,093

Re: [kde-unstable] KDE SC 4.13

Prometheus1 wrote:

I know how to disable Nepomuk but not Baloo, can you give me an hint please?

Add your home folder to the list of not indexed folders in the Desktop Search KCM

Offline

#8 2014-03-08 21:32:02

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,093

Re: [kde-unstable] KDE SC 4.13

It looks like Calligra still needs soprano

> calligrawords 
calligrawords: error while loading shared libraries: libsoprano.so.4: cannot open shared object file: No such file or directory

Offline

#9 2014-03-08 22:24:12

Prometheus1
Member
Registered: 2014-03-08
Posts: 3

Re: [kde-unstable] KDE SC 4.13

arojas wrote:
Prometheus1 wrote:

I know how to disable Nepomuk but not Baloo, can you give me an hint please?

Add your home folder to the list of not indexed folders in the Desktop Search KCM

Thank you smile

Offline

#10 2014-03-09 09:17:14

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: [kde-unstable] KDE SC 4.13

arojas wrote:
Prometheus1 wrote:

I know how to disable Nepomuk but not Baloo, can you give me an hint please?

Add your home folder to the list of not indexed folders in the Desktop Search KCM

Or:

$ cp /usr/share/autostart/baloo_file.desktop ~/.kde4/share/autostart/
$ echo "Hidden=True" >> ~/.kde4/share/autostart/baloo_file.desktop
arojas wrote:

It looks like Calligra still needs soprano

Oh, thanks. I'm on it.

Offline

#11 2014-03-12 09:54:31

trapanator
Member
From: Italy
Registered: 2009-08-10
Posts: 137

Re: [kde-unstable] KDE SC 4.13

yeeeeesss! Nepomuk, the most hated and disabled (according to many users) KDE thing, is gone!

Offline

#12 2014-03-12 23:41:51

flying sheep
Member
Registered: 2012-02-29
Posts: 78

Re: [kde-unstable] KDE SC 4.13

but there’s nepomuk 2: electric baloo!

(sorry, couldn’t resist)

Offline

#13 2014-03-14 13:27:19

hussam
Member
Registered: 2006-03-26
Posts: 520
Website

Re: [kde-unstable] KDE SC 4.13

flying sheep wrote:

but there’s nepomuk 2: electric baloo!

(sorry, couldn’t resist)

nepomuk1 is built into kdelibs (will be removed in KF5).
nepomuk2 = nepomuk-core.

baloo is a new backend. think of it as a third iteration.

Offline

#14 2014-03-19 20:19:37

z0id
Member
From: Romania
Registered: 2010-02-02
Posts: 121

Re: [kde-unstable] KDE SC 4.13

I have a really weird bug, I think. When I use Skype to talk to someone, when I speak the mic volume gets lower or higher as I speak. If I don't speak, it stays constant. Anyone else encounter it?

Last edited by z0id (2014-03-19 20:25:54)


/usr/bin/drinking

Offline

#15 2014-03-19 20:43:01

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: [kde-unstable] KDE SC 4.13

@z0id,
Maybe this ?

Skype options -> Sound Devices --> Allow Skype to automatically adjust my mixer levels

Offline

#16 2014-03-21 00:34:10

hussam
Member
Registered: 2006-03-26
Posts: 520
Website

Re: [kde-unstable] KDE SC 4.13

I am itching to try this. How stable is it compared to 4.12.3?
4.12.3 is rock solid right now.

Offline

#17 2014-03-21 17:28:37

haagch
Member
Registered: 2013-08-17
Posts: 199

Re: [kde-unstable] KDE SC 4.13

Until recently veromix worked fine but now it doesn't. I think this is the problem:

  File "/usr/share/apps/plasma_scriptengine_python/pyappletscript.py", line 22, in <module>
    from PyKDE4.plasma import Plasma
RuntimeError: the sip module implements API v11.0 but the PyKDE4.plasma module requires API v10.1

According to their changelog they changed it for their sip v4.15.5 release http://www.riverbankcomputing.com/stati … /ChangeLog

Downgrading sip, python2-sip and python-sip to [extra] brings this:

  File "/usr/share/apps/plasma_scriptengine_python/pyappletscript.py", line 20, in <module>
    from PyQt4.QtCore import *
RuntimeError: the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v11.0

so I guess PyKDE is just lagging behind and everyone else is already using the new thing?

edit: Maybe they made a mistake with their release tarball? I have not tested it, but I got the PKGBUILD from here: https://projects.archlinux.org/svntogit … e/PKGBUILD and made it build from the kde 4.13 branch of their git repository and it works: http://pastebin.com/raw.php?i=rdjEJ9tU

Well, except for

Error connecting to veromix-service:
org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.veromix.pulseaudio.qt exited with status 1

But maybe that solves itself after the next kde restart.

edit2: It didn't.
For some reason it doesn't launch some dbus service foobar.

python2 /usr/share/apps/plasma/plasmoids/veromix-plasmoid/dbus-service/veromix-service-qt.py

Then it works.

Also, in the last kde update the former issue with pykde got solved I think.

Last edited by haagch (2014-03-25 17:19:33)

Offline

#18 2014-03-28 14:46:48

hussam
Member
Registered: 2006-03-26
Posts: 520
Website

Re: [kde-unstable] KDE SC 4.13

Is strigi support in kdelibs still needed?

Edit: I installed beta 3. Everything works great apart from having to clear the akonadi database. baloo wouldn't index old files until I did that.

Last edited by hussam (2014-03-28 20:47:49)

Offline

#19 2014-03-28 17:30:13

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: [kde-unstable] KDE SC 4.13


Excuse my poor English.

Offline

#20 2014-03-29 13:19:13

hussam
Member
Registered: 2006-03-26
Posts: 520
Website

Re: [kde-unstable] KDE SC 4.13

I reported a nice problem in new akonadi https://bugs.kde.org/show_bug.cgi?id=332777

Offline

#21 2014-04-08 10:45:53

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 336

Re: [kde-unstable] KDE SC 4.13

On my system (KDE 4.12.97), I have both Baloo (4.12.97-1) and Nepomuk-core (4.12.4-1). I read that there's an automatic migration tool (or switch) and I don't see Nepomuk running in htop. Is it safe to uninstall Nepomuk? Or are you waiting for one of us brave souls to remove it and post back?

BTW, I'm uninstalling it now and will reboot and run dolphin and kontact. Will post back/edit if I run into issues...

Offline

#22 2014-04-08 11:07:53

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,093

Re: [kde-unstable] KDE SC 4.13

Buddlespit wrote:

On my system (KDE 4.12.97), I have both Baloo (4.12.97-1) and Nepomuk-core (4.12.4-1). I read that there's an automatic migration tool (or switch) and I don't see Nepomuk running in htop. Is it safe to uninstall Nepomuk? Or are you waiting for one of us brave souls to remove it and post back?

The nepomuk migration tool is in nepomuk-core 4.13, which is not provided in the repo. So you can safely remove nepomuk, but your tags and ratings will not be migrated

Offline

#23 2014-04-08 14:26:45

trapanator
Member
From: Italy
Registered: 2009-08-10
Posts: 137

Re: [kde-unstable] KDE SC 4.13

arojas wrote:

So you can safely remove nepomuk

tell me that's true! We users are waiting it since KDE 4.0! Right 30 minutes ago Nepomuk + virtuoso-t ate my CPU for minutes...

Last edited by trapanator (2014-04-08 14:27:23)

Offline

#24 2014-04-08 22:15:07

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 336

Re: [kde-unstable] KDE SC 4.13

trapanator wrote:
arojas wrote:

So you can safely remove nepomuk

tell me that's true! We users are waiting it since KDE 4.0! Right 30 minutes ago Nepomuk + virtuoso-t ate my CPU for minutes...

Well, after 3-4 reboots and about 12hrs later, I don't see any adverse effects from removing Nepomuk. Only time will tell me if I made a mistake, but as of right now, I really do think it's safe to remove... ;D

Offline

#25 2014-04-09 09:14:07

Box0
Member
From: Italy
Registered: 2011-09-21
Posts: 218

Re: [kde-unstable] KDE SC 4.13

Looks like akonadi 1.12.1 from extra wants soprano & Co. again, should we wait for a new version of akonadi in unstable or the dependency has been reintroduced upstream?

Also for those happy about neponuk dismissal, unfortunately I have exactly the same bug (lots of baloo_file_extractor core dump that fill up journald) with baloo, which is sad because I find it useful sad

Offline

Board footer

Powered by FluxBB