You are not logged in.

#1 2006-02-21 07:15:53

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Mouse Not Working / Not Turned On

Hello,

This week I decided to up my Linux experience. I was using Ubuntu Linux before, and I decided to step-up to something a little less... handed-to-you. Enter Arch Linux, and enter problems! I've been in the IRC all day trying to get X running (apprently, I decided to install Arch Linux on the wrong day, as the new X7 package just entered the Arch Repo). Well, I got it running, and I can log into GNOME...

...but from there, I'm stuck.

My mouse (A Logitech MX510) not only does not work in Gnome... it doesn't work anywhere in Arch! The laser does not turn on when I select Arch VIA GRUB... once selected, the thing turns off and stays off.

I was suggested to use gpm; however, that did not work, and would throw up lines of error whenever I rebooted. Then, I read to install xf86-input-mouse... but I already have that!

What am I to do! It was suggested that is was not a problem in X... to veer away from the X 7.0 malarkey that's ensueing in the forums and IRC room.

Thanks for any help. Other than not being able to do anything, Arch Linux is great! Damn fast.


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#2 2006-02-21 08:51:09

syd
Member
From: Auckland, NZ
Registered: 2006-01-22
Posts: 155

Re: Mouse Not Working / Not Turned On

Welcome to Arch

If you are using udev.
Try running `hwd -e` in a terminal.

If your mouse works you might have to put the module in the modules() section of your rc.conf.

MODULES=(!usbserial !ide-scsi sk98lin usblp fglrx usbhid)

Syd


But To Die Is Gain

Offline

#3 2006-02-22 02:49:52

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Thanks for the speedy reply!

hwd returned uhci_hcd (Device model?), plugged into /dev/psaux

However, this did not work. Adding either usbhid or uhci_hcd to rc.conf did nothing.


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#4 2006-02-22 04:30:08

syd
Member
From: Auckland, NZ
Registered: 2006-01-22
Posts: 155

Re: Mouse Not Working / Not Turned On

Maybe you xorg.conf isnt setup correctly.

This is what i got from hwd.

--------------cut-------------------------------
USB Human Interface Devices
  usbhid          : Microsoft Corp.|IntelliMouse Optical [/dev/input/mice]
USB Printer
  usblp           : Epson Corp.|USB Printer
USB Hub
  hub             : Virtual|Hub
  hub             : Virtual|Hub
USB Vendor Specific Class
  unknown         : Streamzap Remote Control
Mouse
  msintellips/2   : PS/2 Mouse port [/dev/psaux]


When i setup xorg i didnt use the /dev/psaux i used the one above /dev/input/mice.
Theres also other forum topics on how to get all the buttons working.


But To Die Is Gain

Offline

#5 2006-02-22 04:40:03

syd
Member
From: Auckland, NZ
Registered: 2006-01-22
Posts: 155

Re: Mouse Not Working / Not Turned On

Sorry just reread your post and you said that the mouse doesnt even come on when you boot.

Are you using hwd or lshwd in the daemons line of your rc.conf?

Also if it works only when you are root you just need to add yourself to the permissions.


But To Die Is Gain

Offline

#6 2006-02-23 00:19:53

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

syd wrote:

...Are you using hwd or lshwd in the daemons line of your rc.conf?...

I added hwd to my daemon line... didn't do anything diffrent. I tried using lshwd instead; showd the same information as you:

Mouse
---|--- msintellips/2 : PS/2 Mouse port [/dev/psaux]

Since my mouse is USB, maybe I should change it to PS/2?


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#7 2006-02-23 06:32:07

syd
Member
From: Auckland, NZ
Registered: 2006-01-22
Posts: 155

Re: Mouse Not Working / Not Turned On

What does you line like this say?

usbhid : Microsoft Corp.|IntelliMouse Optical [/dev/input/mice]


But To Die Is Gain

Offline

#8 2006-02-24 02:27:16

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Either it does not show up (yes, I added usbhid to the start up modules) or it is off the screen. can i somehow go a page up in the command line? or something?


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#9 2006-02-24 03:54:15

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Mouse Not Working / Not Turned On

To go a page up/down in your terminal: Shift+PgUp/PgDn

You shouldn't need to have either hwd or lshwd in your DAEMONS line. Having MOD_AUTOLOAD="yes" in your rc.conf should autoload all modules you need.  Make sure that the evdev module is loaded.  You can add it to your MODULES array in rc.conf.  And update your system (pacman -Syu) if you haven't done it yet.

Offline

#10 2006-02-27 01:48:00

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Well, I got it working. I used my PS/2 port instead of USB; an idea I orignally suggested. However, I would eventually like to find a solution. Can I get 800 DPI with a PS/2 port?


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#11 2006-03-02 09:34:04

orjanp
Member
From: Tromsoe, Norway
Registered: 2004-07-03
Posts: 337

Re: Mouse Not Working / Not Turned On

Try this.

First, install xf86-input-evdev

# pacman -S xf86-input-evdev

My MX518 use /dev/input/event4. Do a

# cat /proc/bus/input/devices

I: Bus=0003 Vendor=046d Product=c01e Version=2200
N: Name="Logitech USB-PS/2 Optical Mouse"
P: Phys=usb-0000:00:1d.1-2/input0
S: Sysfs=/class/input/input4
H: Handlers=mouse2 event4 <--- This is the one you want
B: EV=7
B: KEY=ff0000 0 0 0 0 0 0 0 0
B: REL=103

Put the eventhandler in your xorg.conf

This is a part of my /etc/X11/xorg,conf

Section "Inputdevice"

# Logitech MX 510/518

    Identifier    "EvdevMouse"
    Driver        "evdev"
    Option        "Device"    "/dev/input/event4" # <------ Put the eventhandler here.

EndSection

Section "ServerLayout"

# The Identifier line must be present
    Identifier  "Laptop"
    Screen "Laptop single"
    Inputdevice    "EvdevMouse"    "CorePointer"  # Mouse
    InputDevice "Mouse2"        "SendCoreEvents" # Touchpad
    InputDevice "Keyboard1"        "CoreKeyboard"

EndSection

And part of my /etc/rc.conf

# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes" # <----- You should set this to yes

# Module Blacklist - modules in this list will never be loaded by hwdetect
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to disable it
#
MODULES=(!usbserial evdev e100) # <----- Put evdev here.

Reboot. And try the mouse.

Orjanp


Ørjan Pettersen

Offline

#12 2006-03-03 01:18:29

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Hello, I got my mouse to work VIA PS/2, but for sure I will try this this weekend. After having Arch for a while, I think I've pin-pointed my problem; the USB slots aren't working?

Well, my phone (which plugs into USB) does not charge, and my MP3 Player turns on... but freezes. It says it charges, but I do not think it does. And of course my mouse did not turn on.

Will evdev do me a solution, here?


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#13 2006-03-03 05:39:28

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Mouse Not Working / Not Turned On

Unless I'm wrong, evdev is only used to configure mouses.

Are your usb modules loaded? Check with lsmod. I have the following loaded:

usb_storage
usbhid
ohci_hcd
ehci_hcd
uhci_hcd

Offline

#14 2006-03-05 07:18:00

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Snowman wrote:

Unless I'm wrong, evdev is only used to configure mouses.

Are your usb modules loaded? Check with lsmod. I have the following loaded:

usb_storage
usbhid
ohci_hcd
ehci_hcd
uhci_hcd

They are not! What do I need to do? I also noticed that, while Arch does detect a CD drive, does not detect the media within them. So if I put a DVD in, totem does not recognize that there is a movie in the DVD drive.


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#15 2006-03-05 23:43:51

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Mouse Not Working / Not Turned On

Add them to the MODULES array of rc.conf

For the totem problem, do you want totem to automatically start playing the CD/DVD in the drive or you can't play them at all?  In both case, it's probably a configuration issue. Try to look in the options menu. I don't use totem so I can't be more specific.

Did you add your user to the optical group? If not,
# gpasswd -a username optical

Offline

#16 2006-03-06 05:58:31

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

I added all of those; still don't work sad

I noticed that when I go to preference --> removable drives and media, it doesn't work; says I need hald enabled.


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#17 2006-03-06 06:27:05

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Mouse Not Working / Not Turned On

Rev. Nathan wrote:

I added all of those; still don't work sad

I forgot to mention that you need to reboot to enable the changes in rc.conf.  If you don't want to reboot, you can load them with modprobe, e.g.
# modprobe usb_storage

Rev. Nathan wrote:

I noticed that when I go to preference --> removable drives and media, it doesn't work; says I need hald enabled.

Start the dbus and hal daemon:
# /etc/rc.d/dbus start
# /etc/rc.d/hal start

To make them start on boot up, add them to the daemon array of rc.conf (in that order: dbus hal)

Offline

#18 2006-03-06 06:38:08

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

OK! Now we are getting somewhere!

My CD drive - Found! Gnome recognizes a CD within the drive, and even autoplays.

Problem -- doesn't know where my CD drive is? Its /dev/hdc, however, in totem for example, I get this: Failed to open device /dev/hdc for reading: Permission denied

In mPlayer, I get could not find /dev/dvd (or for a CD, /dev/cdrom). Something mentioned fstab once... do I really need to add my media drives to fstab?

Still, USB is not working?

Within device manager, it sees my USB hardware:
Screenshot-Device%20Manager.png

I'm guess #2, #3, and #4 are my other 3 ports, although I do have two front ones. Lemme know if you need more information.

(And yes, I'm aware I have an ECS mobo yikes
I will get another when the cashflow is more ample)


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#19 2006-03-06 08:37:29

orjanp
Member
From: Tromsoe, Norway
Registered: 2004-07-03
Posts: 337

Re: Mouse Not Working / Not Turned On

Post rc.conf


Ørjan Pettersen

Offline

#20 2006-03-06 15:38:46

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/unimaps
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE=
HARDWARECLOCK="localtime"
TIMEZONE="America/Los_Angeles"
KEYMAP=us
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by hwdetect
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to disable it
#
MODULES=(evdev usb_storage usbhid ohci_hcd ehci_hcd uhci_hcd)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="backroom"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="dhcp"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond dbus hal httpd openntpd gdm alsa)


# End of file


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#21 2006-03-06 20:45:56

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Mouse Not Working / Not Turned On

Rev. Nathan wrote:

Problem -- doesn't know where my CD drive is? Its /dev/hdc, however, in totem for example, I get this: Failed to open device /dev/hdc for reading: Permission denied

Is your user in the optical group? See my post above. You might also want to add your user to the audio and video group.

Rev. Nathan wrote:

In mPlayer, I get could not find /dev/dvd (or for a CD, /dev/cdrom). Something mentioned fstab once... do I really need to add my media drives to fstab?

Unless I'm wrong, hal should automatically add the entry for the CD drive to fstab. The /dev/dvd and /dev/cdrom symlinks  (check if they exist) are added by udev.  BTW, is your system up-to-date?

Rev. Nathan wrote:

Still, USB is not working?

I don't know what's the problem with the USB ports. I find it strange that udev can't automatically load the modules.  USB ports is very common hardware and has been there for quite a while.  When you tested your USB devices, did you tried all the ports?
You could try this:
Install  usbutils. Plug your mouse in the usb port and/or plug other usb devices. then run lsusb
It should list the usb devices. In my case, usb mouse and keyboard:

$ lsusb
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 002: ID 046d:c00e Logitech, Inc. Optical Mouse
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 0d62:001c Darfon Electronics Corp. 
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 001: ID 0000:0000

Offline

#22 2006-03-08 05:51:32

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Added myself to audio and video; had already add myself to optical before.

My fstab seems to be correct?

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0

/dev/cdrom             /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/dvd               /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/fd0               /mnt/fl   vfat      user,noauto             0      0

/dev/sda2 swap swap defaults 0 0
/dev/sda3 / reiserfs defaults 0 0

Perchance I need to change /dev/cdrom and /dev/dvd to /dev/hdc? PS I don't have a floppy drive... should I remove that from fstab?

My system is up-to-date indeed; I run sudo pacman -Syu almost every night.

Whenever I do lsusb... nothing generates!

[nathan@backroom ~]$ sudo lsusb
[nathan@backroom ~]$

This is with a printer, a scanner, and a few other devices in the USB port.

I noticed something; when I reboot from Windows, my phone remains charging. However, if I were to plug in my phone to Arch, it would not charge at all.


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#23 2006-03-08 17:04:52

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Mouse Not Working / Not Turned On

Rev. Nathan wrote:

Added myself to audio and video; had already add myself to optical before.

My fstab seems to be correct?

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0

/dev/cdrom             /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/dvd               /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/fd0               /mnt/fl   vfat      user,noauto             0      0

/dev/sda2 swap swap defaults 0 0
/dev/sda3 / reiserfs defaults 0 0

Perchance I need to change /dev/cdrom and /dev/dvd to /dev/hdc? PS I don't have a floppy drive... should I remove that from fstab?

Yes, try changing /dev/cdrom and /dev/dvd to /dev/hdc.  That's what I have in my fstab. I think it will solve your totem problem. 

You can remove (or comment)  the floppy line from your fstab.  Or you can leave it there as it doesn't cause any harm.

For the usb problem, I'm out of idea sad . It seems like it doesn't detect your usb ports.

Offline

#24 2006-03-08 23:39:34

Rev. Nathan
Member
From: West Hills, Los Angeles, Calif
Registered: 2006-02-21
Posts: 35
Website

Re: Mouse Not Working / Not Turned On

Snowman wrote:
Rev. Nathan wrote:

Added myself to audio and video; had already add myself to optical before.

My fstab seems to be correct?

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0

/dev/cdrom             /mnt/cd   iso9660   ro,user,noauto,unhide   0      0
/dev/dvd               /mnt/dvd  udf       ro,user,noauto,unhide   0      0
/dev/fd0               /mnt/fl   vfat      user,noauto             0      0

/dev/sda2 swap swap defaults 0 0
/dev/sda3 / reiserfs defaults 0 0

Perchance I need to change /dev/cdrom and /dev/dvd to /dev/hdc? PS I don't have a floppy drive... should I remove that from fstab?

Yes, try changing /dev/cdrom and /dev/dvd to /dev/hdc.  That's what I have in my fstab. I think it will solve your totem problem. 

You can remove (or comment)  the floppy line from your fstab.  Or you can leave it there as it doesn't cause any harm.

For the usb problem, I'm out of idea sad . It seems like it doesn't detect your usb ports.

Well, its saddening, but I'm almost willing to pay to have my problem fixed. As in, if I were to buy one of those PCI cards with 4+ USB 2.0 slots, would this solve my problem? And if so, is there a brand/model known to work?


"All the world's indeed a stage, And we are merely players.
Each another's audience, Outside the gilded cage.
"

Offline

#25 2006-03-08 23:47:52

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,243

Re: Mouse Not Working / Not Turned On

I have a no-name USB2 card in my pc that works flawlessly

This is the relevant part of hwd output :

USB Controller
  ehci-hcd        : VIA Technologies Inc.|VT8235 USB Enhanced Controller


One word of caution : My Mobo has a VIA chipset also. I have seen some reports that Via USB2 cards don't work very well with Intel chipsets.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB