You are not logged in.

#1 2015-04-13 00:39:37

madscience
Member
From: Ontario, Canada
Registered: 2014-02-11
Posts: 74
Website

[SOLVED] XFCE 4.12 - laptop lid ignores power-manager settings

I just fresh installed Arch w/ XFCE 4.12

In power manager, I set the lid switch to suspend on battery, lock on ac.  The setting worked initially, but after the first suspend, or a reboot, the lid switch triggers suspend no matter what.

I tried setting HandleLidSwitch=ignore in /etc/systemd/logind.conf, as suggested in numerous online sources, but it didn't help
I tried rm -rf .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml, which makes it work temporarily again, until a suspend or a reboot

Does anyone know of a fix for this?  It's not a deal-breaker but it's a pain in the ass.

Last edited by madscience (2015-04-13 03:10:33)

Offline

#2 2015-04-13 02:03:32

toz
Member
Registered: 2011-10-28
Posts: 415

Re: [SOLVED] XFCE 4.12 - laptop lid ignores power-manager settings

Here are a couple of suggestions of things to try to troubleshoot:

1. Delete the power manager xml file again. Then login, set up the power manager to work in the way that you want, and check the results of:

xfconf-query -c xfce4-power-manager -lv

...before and after suspend on battery. Look for differences in the results to make sure that no settings were changed.

2. pkill the xfce4-power-manager process then run it as:

xfce4-power-manager --no-daemon --debug

...in a terminal window and run through the suspend process. Review the debug printout in the terminal window to see if there are any errors/warnings or output that doesn't seem right (e.g. not recognizing battery/ac status properly).

Offline

#3 2015-04-13 02:37:22

madscience
Member
From: Ontario, Canada
Registered: 2014-02-11
Posts: 74
Website

Re: [SOLVED] XFCE 4.12 - laptop lid ignores power-manager settings

I may have solved it.

I edited the xml file directly and set <property name="logind-handle-lid-switch" type="bool" value="false"/>

Now the options seem to work as intended.  I also noticed that if you launch the settings applet, it changes that key back to true every time it's opened.  The change can also be made through the settings editor.

I'll test for 24 hours and mark as solved if it works.

EDIT:

That didn't work permanently, I'm back to suspending on lid close on AC.  I'm using TLP with battery thresholds enabled, and I'm starting to wonder if xfce-power-manager is reading the charge state of the battery instead of the power source directly.  When my battery is below the start charging threshold and is actually charging, it seems to be working as intended.  If my laptop is on AC but the battery is not actually charging, it acts like it's on battery.  I might be wrong, it's just a theory.

Last edited by madscience (2015-04-13 02:44:48)

Offline

#4 2015-04-13 02:53:25

madscience
Member
From: Ontario, Canada
Registered: 2014-02-11
Posts: 74
Website

Re: [SOLVED] XFCE 4.12 - laptop lid ignores power-manager settings

I ran with --no-daemon --debug, and got

TRACE[xfpm-manager.c:439] xfpm_manager_lid_changed_cb(): LID close event: ((XfpmLidTriggerAction) LID_TRIGGER_LOCK_SCREEN)

but it's still suspending

I'm using lightdm and light-locker, if that makes a difference

Offline

#5 2015-04-13 03:11:01

madscience
Member
From: Ontario, Canada
Registered: 2014-02-11
Posts: 74
Website

Re: [SOLVED] XFCE 4.12 - laptop lid ignores power-manager settings

It's a bug in light-locker.  No issue with slock

Offline

Board footer

Powered by FluxBB