You are not logged in.

#1 2006-05-20 21:17:19

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Getting ISA sound working in Arch

I have a Dell Inspiron 3200 laptop with internal PnP ISA sound.  The card is a Cirrus Logic Crystal 4237B, and I know for a fact that the cs4236 module is appropriate, but from what I've heard, it's not quite as simple as loading the module and calling it a go.  So I thought I'd post here about it ... what can I do to get my sound working properly?  I perfer to use ALSA over OSS, btw.  Thanks all!


Touch my kernel

Offline

#2 2006-05-21 07:25:30

dojo
Member
Registered: 2005-11-02
Posts: 96

Re: Getting ISA sound working in Arch

Try "alsaconf" from the alsa-utils package to configure your soundcard.

Greets

dojo

Offline

#3 2006-05-21 11:07:05

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

I ran alsaconf ... no luck.  It sure seems to be getting far though.  The first time I ran it, it didn't detect my sound card immediately as I had planned, but when it asked what other ISA cards it should probe, I selected only cs4236 (and to find all DMA/interrupt settings).  I heard a lot of pops from the speakers, so I thought it was going to finish well, but at the very end of the configurator, I saw it flash a couple [FAILED] messages, then it cleared the terminal and left me with the "use a mixer to configure settings" message.  After the failues happened, I haven't been able to get them to happen again, so all I could see from the message was that the soundcard was not found.

alsaconf got a lot further than debian ever did though smile  What else could I try?


Touch my kernel

Offline

#4 2006-05-21 15:34:35

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

lsmod also shows a lot of oss modules loaded ... is this bad?


Touch my kernel

Offline

#5 2006-05-21 21:40:14

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Is isapnp bult into the arch 0.7.1 kernel?


Touch my kernel

Offline

#6 2006-05-21 22:49:06

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: Getting ISA sound working in Arch

from /boot/kconfig26

#
# Plug and Play support
#
CONFIG_PNP=y
# CONFIG_PNP_DEBUG is not set

#
# Protocols
#
CONFIG_ISAPNP=y
# CONFIG_PNPBIOS is not set
CONFIG_PNPACPI=y

lsmod |grep oss

snd_seq_oss            31716  0
snd_seq_midi_event      6400  1 snd_seq_oss
snd_seq                49996  4 snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            38176  0
snd_mixer_oss          16384  1 snd_pcm_oss
snd_pcm                78084  2 snd_pcm_oss,snd_cmipci
snd_seq_device          6924  4 snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
snd                    46432  14 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device

looks like ISAPNP is included, and oss modules are normal.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2006-05-22 22:38:33

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

That's good.  Is there a way I can "replace" OSS with ALSA?


Touch my kernel

Offline

#8 2006-05-23 19:33:10

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: Getting ISA sound working in Arch

I don't know why the oss moudles are there, but i can tell you i AM running ALSA.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#9 2006-05-23 23:03:48

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Any ideas on how to get my sound to work?


Touch my kernel

Offline

#10 2006-05-24 19:37:03

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: Getting ISA sound working in Arch

Run as root

hwdetect --show-sound

and compare the output with lsmod.

It's possible not all modules needed for your soundcard are loaded automagically.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#11 2006-05-24 23:11:18

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

hwdetect --show-sound verboses nothing.  lsmod doesn't show anything but OSS modules.  If I modprobe snd-cs4236, it says "No such device," but when I do a modprobe snd-4232, it seems to probe fine and I hear a bunch of pops from the speaker.  Very interesting indeed, although the sound still doesn't work correctly.


Touch my kernel

Offline

#12 2006-05-25 11:27:58

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: Getting ISA sound working in Arch

That suggests there's something very wrong with your setup.

please post your /etc/rc.conf.

The kernel you're using, and the brand/model of your motherboard would also be useful info.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#13 2006-05-25 13:19:15

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Thank you for your continued support!  I really appreciate it big_smile

Here is my rc.conf:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/unimaps
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE=
HARDWARECLOCK="localtime"
TIMEZONE=Canada/Pacific
KEYMAP=us
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by hwdetect
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to disable it
#
MODULES=(!usbserial)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="myhost"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
eth0="dhcp"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng hotplug pcmcia network netfs crond)


# End of file

I just did a pacman -Su yesterday, so I'm running the latest kernel from the arch repos, 2.6.16-18 I believe.

Here's the spec page for my laptop from Dell.com ...

http://support.dell.com/support/edocs/s … /specs.htm

Let me know if you need to know anything else smile


Touch my kernel

Offline

#14 2006-05-25 22:19:38

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,151

Re: Getting ISA sound working in Arch

This is most likely the problem :

DAEMONS=(syslog-ng hotplug pcmcia network netfs crond)

put exclamation marks before hotplug and pcmcia like this :

DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond)

----------------
those exclamation marks will disable hotplug & pcmcia.

I don't know why they are still in the daemons line, but every rc.conf i've seen has exclamation marks before those 2.

You may wonder (as i did) why the pcmcia daemon should be disabled on a laptop, but i have it disabled and the pcmcia slot on my laptop works fine.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#15 2006-05-25 23:07:21

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

But ... I need those tongue

I'll give it a shot temporarily to see what it does though.


Touch my kernel

Offline

#16 2006-05-25 23:41:34

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: Getting ISA sound working in Arch

synthead wrote:

But ... I need those tongue

I'll give it a shot temporarily to see what it does though.

You don't need those. The corresponding /etc/rc.d files most likely don't exist on your system. Unless of course you use kernel 2.4

Offline

#17 2006-05-25 23:46:44

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

No luck tongue  I also ran alsaconf ... same error message.  Nothing really happens when I modprobe snd-4232 or snd-4236 either, just the pops I've heard before tongue


Touch my kernel

Offline

#18 2006-05-25 23:47:56

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

brain0 wrote:
synthead wrote:

But ... I need those tongue

I'll give it a shot temporarily to see what it does though.

You don't need those. The corresponding /etc/rc.d files most likely don't exist on your system. Unless of course you use kernel 2.4

Ahhh, ok.  Yeah, the rc.d entries for those are blank.  I was kinda curious about that since I saw those options in the ncurses configurator for the kernel (and when I noticed my PCMCIA was still working big_smile).


Touch my kernel

Offline

#19 2006-05-29 00:25:29

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Any ideas?


Touch my kernel

Offline

#20 2006-06-04 00:38:43

phydeaux
Member
Registered: 2005-06-13
Posts: 68

Re: Getting ISA sound working in Arch

I just figured this out on my dell latitude d266xt which has a c4237b sound card like yours.  It was quite a pain in the butt.

First off I had to go into the bios and change the post to "thorough".  This was what the setting was called in my bios any way.  You want it to do a full post, no fast boot, or if it has the option, tell it its a non-pnp aware system.  I also had to set the sound card to half duplex mode while I was in there.

In rc.conf add to MOD_BLACKLIST snd-cs4232.  Udev seems to try to load that for some reason and it messes everything up.  In the modules array add snd-cs4236 and make sure its FIRST.  If the module isn't loaded first it will fail, don't know why, but it will.  Udev will find and try to load snd-cs4236 on its own if you don't list it in modules, but it will fail.  I don't know why, I assume it has something to do with plug and play and something not being setup correctly.  I dunno, its over my head.

Then you need to add the following to /etc/modprobe.conf:

options snd-cs4236 port=0x530 cport=0x210 irq=5 dma1=0 dma2=1 isapnp=0

That may be more info then you need to specify but it works on my system.

That should do it.  Reboot the system, it won't work if you try to modprobe it, and you should have sound. Atleast thats how it went for me, well after several hours of googling and alot of trial and error head banging anyway.

By the way, I can't seem to get dmix to work with this card.  If anyone figures it out let me know.

andy

Resource list:
http://www.alsa-project.org/alsa-doc...
http://hardware.mcse.ms/archive42-2005-1-124574.html
http://kerneltrap.org/node/2386
http://home.nedlinux.nl/~bart/?page=11

Offline

#21 2006-07-02 04:00:44

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Hmm, interesting ... I've tried everything you did to get it to work, and I still just get a pop sound and a "no such device" error when trying to modprobe the driver.  I'm gonna try a few different configurations and settings to see if I can get anywhere with them.

That's really cool that you got it to work though, hopefully I'll be able to get there too eh?

My friend says that not having any sound means you're 1337.  I'm too 1337 to have sound! lawl ...


Touch my kernel

Offline

#22 2006-07-02 11:40:30

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Ah, I can't get anything to work tongue


Touch my kernel

Offline

#23 2006-07-02 13:02:25

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Gah, this is impossible ... I've tried messing around with snd-cs4232, which also seems to do nothing different except for that it doesn't display error messages.  Also, the usual pop heard when trying to modprobe snd-cs4236 sounds more like a short buzz when snd-cs4232 is modprobed.

Also, interestingly enough, alsaconf set my cport to 0xf00, and although there still isn't any sound from my card, it doesn't display error messages.  Also, when I try to play something in xmms, it emits a pop from the speakers.  Sounds like it's close ... but it still doesn't work.

I've tried a few different address/irq/dma settings in the bios too, no luck.  I've heard success stories where people say "I got it working!" then post the usual modprobe snd-cs4236 isapnp=0 port=0x530 etc etc ... but none of the success story combinations I've come across has worked for my card as of yet.


Touch my kernel

Offline

#24 2006-07-02 18:50:07

phydeaux
Member
Registered: 2005-06-13
Posts: 68

Re: Getting ISA sound working in Arch

I do get that pop sound when the module is loaded, but this seem to work after that.  It could be that you card is on a diferent port or something to that nature.  None of the pnp tools I tried were able to find my card, I just happned to luck out that the info others posted worked for my laptop.  You might have to do something extreme and boot windows to see what it thinks the settings are.

Also make sure that teh snd-cs4236 is the first module thats loaded in your modules list.  I don't know why but it seems that if you don't load it first then it just won't work.  I've never been able to get the module to load by modprobing it manually.  The only way it would work for me was from rc.conf as the first module.

andy

Offline

#25 2006-07-03 19:27:01

synthead
Member
From: Seattle
Registered: 2006-05-09
Posts: 1,326

Re: Getting ISA sound working in Arch

Hmm ... I know what the settings are, I can even set it up manually in the BIOS.  I have it in me to try again a little more, I'll see what happens.

By the way, when you said you couldn't get sound to work with modprobe, how did it not work?  Did it pop?  Did it say no such device?  Having to restart to try something every time is kind of a drag tongue


Touch my kernel

Offline

Board footer

Powered by FluxBB