You are not logged in.

#1 2006-06-22 19:36:07

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

The Testing Move has begun

Announcement:
We have begun moving the large mass of packages in testing to current and extra.  News item here: http://archlinux.org/news.php#242

Offline

#2 2006-06-22 19:43:49

neotuli
Lazy Developer
From: San Francisco, CA
Registered: 2004-07-06
Posts: 1,201
Website

Re: The Testing Move has begun

o/


The suggestion box only accepts patches.

Offline

#3 2006-06-22 21:03:52

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: The Testing Move has begun

Targets: glibc-2.4-2 p7zip-4.42-1 gcc-4.1.1-3 pam-0.81-2 coreutils-5.96-1 db-4.4.20-2 perl-5.8.8-4 heimdal-0.7.2-3 initscripts-0.7.2-3 iputils-021109-5 kbd-1.12-5 udev-094-2 vim-7.0.17-2 binutils-2.16.1-3 avahi-0.6.10-3 module-init-tools-3.2.2-3 openssl-0.9.8b-1 ntp-4.2.0a-7 glib2-2.10.3-1 pmount-0.9.11-1 apache-2.2.2-4 libtiff-3.8.2-2 cups-1.2.1-3 python-2.4.3-3 pango-1.12.3-1 arts-1.5.3-2 libtasn1-0.3.4-1 gnutls-1.4.0-1 cyrus-sasl-2.1.21-4 openldap-2.3.21-3 smbclient-3.0.22A-3 gnome-vfs-2.14.2-1 libsoup-2.2.93-1 nspr-4.6.2-1 nss-3.11.1-1 evolution-data-server-1.6.2-2 openssh-4.3p2-2 gnome-desktop-2.14.2-1 gimp-print-4.2.7-5 ghostscript-8.15.2-3 xchat-2.6.2-2 wget-1.10.2-2 links-2.1pre20-2 curl-7.15.1-2 libxmu-1.0.2-1 libgda-1.2.2-5 archlinux-menus-1.1-2 gnome-menus-2.14.0-1 eog-2.14.2-1 bind-9.3.2-3 cmake-2.4.2-2 codecs-20060501-4 ruby-1.8.4-3 neon-0.25.5-3 subversion-1.3.1-4 gnome-panel-2.14.2-1 dnsutils-9.3.2-2 mcpp-2.5-3 gtk2-2.8.18-1 kde-common-3.5.3-3 gaim-1.5.0-5 libxt-1.0.2-1 xulrunner-1.8.0.4-1 libwnck-2.14.2-1 kdeedu-3.5.3-1 mozilla-firefox-1.5.0.4-1 libxau-1.0.1-1 poppler-0.5.3-2 xorg-server-utils-1.0.2-1 kdelibs-3.5.3-3 kdeaccessibility-3.5.3-1 kdebase-3.5.3-3 kdepim-3.5.3-1 xine-lib-1.1.1-3 kdemultimedia-3.5.3-2 kdegames-3.5.3-1 kdeaddons-3.5.3-2 kdeadmin-3.5.3-1 kdeartwork-3.5.3-1 qscintilla-1.6-2 kdebindings-3.5.3-1 kdegraphics-3.5.3-1 openslp-1.2.0-3 rdesktop-1.4.1-3 qca-tls-1.0-3 perl-net-ssleay-1.25-2 kdenetwork-3.5.3-3 kdesdk-3.5.3-2 kdetoys-3.5.3-1 net-snmp-5.2.1-4 kdeutils-3.5.3-2 libxss-1.1.0-1 cvs-1.11.21-3 gnome-media-2.14.2-1 kernel26-2.6.17.1-1 galeon-2.0.1-2 klibc-1.4-1 klibc-extras-1.6-1 klibc-udev-094-2 mkinitcpio-0.4.2-1 gkrellm-2.2.7-3

Yeah, I'd say thats massive. Time to remove kde...

Offline

#4 2006-06-22 21:07:43

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: The Testing Move has begun

eat your branes!


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#5 2006-06-22 21:36:31

whargoul
Member
From: Odense, Denmark
Registered: 2005-04-04
Posts: 546

Re: The Testing Move has begun

Finally, it was time that mkinitcpio was finish 'cause it sure sounds great. smile


Arch - It's something refreshing

Offline

#6 2006-06-23 05:38:47

glad
Member
From: Norway
Registered: 2005-11-01
Posts: 103
Website

Re: The Testing Move has begun

Why do arch use mkinitrd or mkinitcpio it loads all the modules in the arch tree and i dont see the point og having an initrd image??

and why dosent the nvidia nforce modules work with 2.6.17?

Offline

#7 2006-06-23 07:08:43

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: The Testing Move has begun

initrds make life much easier to gain flexibility with kernels.
why nforce doesn't work, i don't know perhaps your module is too old and your mirror was out of sync

Offline

#8 2006-06-23 07:16:04

hussam
Member
Registered: 2006-03-26
Posts: 524
Website

Re: The Testing Move has begun

Any repository mirror is up to sync with the latest changes in current/extra?

Offline

#9 2006-06-23 07:21:44

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: The Testing Move has begun

just be patient wait some hours, i guess in 24h or 48h all should be fine again

Offline

#10 2006-06-23 08:01:43

bogomipz
Member
From: Oslo, Norway
Registered: 2003-11-23
Posts: 169

Re: The Testing Move has begun

I'm about to install my new server. Any idea when it will be safe to do so from ftp? I mean, it would be nice if these important changes to [current] were done by the time I installed.


All of your mips are belong to us!!

Offline

#11 2006-06-23 08:56:01

brain0
Developer
From: Aachen - Germany
Registered: 2005-01-03
Posts: 1,382

Re: The Testing Move has begun

Hey, I just noticed something odd: some mirrors (like hosteurope) have updated, but ftp.archlinux.org (main mirror!!) is still out of sync. Have you turned of syncing for archlinux.org?

Offline

#12 2006-06-23 11:12:37

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: The Testing Move has begun

I had to rebuild sylpheed. Got some libssl.so errors.

Offline

#13 2006-06-23 18:21:03

scottlc
Member
From: St Andrews, Scotland
Registered: 2006-03-31
Posts: 19

Re: The Testing Move has begun

Thanks Arch team. Upgrade went super smooth. Not a hitch.

Offline

#14 2006-06-23 18:52:31

citral
Member
Registered: 2005-05-07
Posts: 87

Re: The Testing Move has begun

I had a lot of ssl problems after upgrading. Like:

wpa_supplicant: error while loading shared libraries: libssl.so.0.9.7: cannot op en shared object file: No such file or directory

Funny because without wpa_supplicant I couldn't get on my uni wireless network to update. smile

I symlinked 0.9.8 to 0.9.7 and magically it worked as temporary solution. After then doing pacman -Syu I got appearently an old mirror because it complained I had 10 packages newer than repo current?

What is the solution for the libssl (openssl) problem? Gnubiff, sylpheed-claws, wpa_supplicant and probably more complained.

[edit] of course compiling from ABS is a solution that works smile [/edit]


One of the main causes of the fall of the Roman Empire was that, lacking zero,
they had no way to indicate successful termination of their C programs.

Offline

#15 2006-06-23 18:55:24

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: The Testing Move has begun

wot's this mean:

:: Replace alsa-driver with kernel26 from "current"? [Y/n] n

replace alsa with the kernel? is that a typo or do i not get something? tongue

Offline

#16 2006-06-23 18:58:43

ingvildr
Member
From: Brighton, England
Registered: 2005-04-19
Posts: 203

Re: The Testing Move has begun

just upgraded on two machines and everything went fine, the switch to mkinitcpio also went without problems great work guys.

@slackhack
http://archlinux.org/news.php#244

Offline

#17 2006-06-23 19:15:55

lessthanjake
Member
From: Norway
Registered: 2005-11-09
Posts: 319
Website

Re: The Testing Move has begun

I do not have kernel26 installed, as I use beyond. But this upgrade tries to installe kernel26, that got to be some wrong dependencies somewhere. I'll just wait this out, until 2.6.17-beyond appears.

Offline

#18 2006-06-23 19:16:47

ivi3
Member
Registered: 2005-10-06
Posts: 62

Re: The Testing Move has begun

The kernel26, ipw2200 and udev again failed to load the firmware.

After rebuilding and installing udev from abs firmware loading worked again.

Is this because the a new udev package isn't uploaded to the servers yet?

Mathias

Offline

#19 2006-06-23 19:22:56

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: The Testing Move has begun

it could be that mirrors are out of sync that is the reason why we posted the news on frontpage.
btw if you don'T want to install kernel26, then just remove alsa-driver by hand

Offline

#20 2006-06-23 19:41:39

ivi3
Member
Registered: 2005-10-06
Posts: 62

Re: The Testing Move has begun

It seems be a udev-094-2 problem!

Building and installing udev-091-6 from an older abs snap loads the firmware just fine. udev-094-2 from repo and builded from abs gives me this dmesg:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, git-1.1.1
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ACPI: PCI Interrupt 0000:02:02.0[A] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 11
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
ipw2200: Unable to load firmware: -2
ipw2200: failed to register network device
ipw2200: probe of 0000:02:02.0 failed with error -5

The problems with ipw/firmware loading really often appear after arch updates and are a little bit annoying.

But don't understand this as reprehension because I think you devs are really doing a great job on arch. Just say be a little more accurate on the ipw's cause many people are using this chip/cards I think. wink

Mathias

Offline

#21 2006-06-23 19:46:48

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: The Testing Move has begun

i strongly guess, that your problem is due to modifing udev rules by yourself.
move udev.rules file to a save place and let pacman install the new udev.rules file. the firmwareloader has changed since 091.
I can't test the firmware stuff so it's up to the users to report problems about firmware loading, it was quite a long time in testing and noone reported a problem, so i assume it's working.

Offline

#22 2006-06-23 20:11:19

Skyscraper
Member
Registered: 2005-06-20
Posts: 72

Re: The Testing Move has begun

Whole upgrade (about 500MB) went quite fine smile but:

- i think there should be an informations to keep old modeprobe.conf with:

#
# /etc/modprobe.conf (for v2.6 kernels)
#
install nvidia modprobe -i nvidia ; /etc/udev/scripts/create-nvidia-nodes.sh ; true

with new, empty modprobe.conf xorg cannot use nvidia driver -> no "/proc/nvidia"

- OpenNTPD from community repository should be prepared for the new libcrypt - I recompiled it through abs but I shouldn't smile

ok, let's make some more tests...
Great job Devs!! smile

Offline

#23 2006-06-23 20:18:41

ivi3
Member
Registered: 2005-10-06
Posts: 62

Re: The Testing Move has begun

Ok, sorry for my problem report. It really was the udev.rules.pacnew. roll
After cp udev.rules.pacnew udev.rules everything works fine again.

So I can say all updates are working great. Amazing job from the devs!  smile

Mathias

Offline

#24 2006-06-23 20:24:08

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: The Testing Move has begun

smooth as silk here. another great job from the arch team! big_smile

Offline

#25 2006-06-23 20:30:49

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: The Testing Move has begun

install nvidia modprobe -i nvidia ; /etc/udev/scripts/create-nvidia-nodes.sh ; true
this entry is done by nvidia-legacy and is only needed for legacy drivers.
so modprobe.conf is fine when legacy package is installed

Offline

Board footer

Powered by FluxBB