You are not logged in.

#1 2019-03-20 18:34:11

frabjous
Member
Registered: 2010-07-13
Posts: 332

[SOLVED] kitty terminal transparency causes text not to render...

Until recently, the kitty terminal was working fine with background transparency. But now when I open kitty with background_opacity set to something other than 1, fonts are not displayed correctly. Most characters are not displayed at all, and the few that are are sometimes displayed wrongly, such as backwards. Sometimes there are strange artifacts on the screen.

Kitty works fine without background transprancy, as far as I can tell.

To test, I removed ~/.config/kitty/kitty.conf. With no special user configuration file, then:

kitty

works fine, but:

kitty -o background_opacity=0.8

creates the problems (for any value other than 1).

I'm using compton as my compositor; it's working fine with other apps.

I'm using bspwm, but I see the same behavior in i3.

This is kitty version 0.13.3.

I figured this had to have something to do with freetype2, since that's the only thing that seems relevant that's been updated recently, but downgrading (from the recent 2.10) to 2.9.1 didn't seem to help.

Any clue would be most appreciated.

Last edited by frabjous (2019-04-25 16:35:55)

Offline

#2 2019-03-20 19:29:09

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,908

Re: [SOLVED] kitty terminal transparency causes text not to render...

Offline

#3 2019-03-20 19:37:41

frabjous
Member
Registered: 2010-07-13
Posts: 332

Re: [SOLVED] kitty terminal transparency causes text not to render...

Thanks, V1del, that appears to be it -- downgrading mesa does seem to help. I really should have thought to check kitty's bugtracker. I'll mark it as solved if mesa 19.1 addresses the issue.

Offline

#4 2019-04-25 16:35:32

frabjous
Member
Registered: 2010-07-13
Posts: 332

Re: [SOLVED] kitty terminal transparency causes text not to render...

Fixed with mesa 19.0.3

Offline

Board footer

Powered by FluxBB