You are not logged in.

#1 2019-04-20 18:26:56

aumars
Member
Registered: 2018-01-08
Posts: 9

[SOLVED] SAPPHIRE PULSE Vega 56 fans inoperative on kernel 5.0.7

I've recently installed a SAPPHIRE PULSE Vega 56 running kernel 5.0.7 and the fans don't work at all, even when running graphically-demanding games. When I run those games, I get the expected performance of 55-60 fps at a "high" quality modeset, so the drivers work fine. I'm using a MSI B450 Tomahawk motherboard which has 'Gaming Boost' ability, which sets all the fans (CPU and GPU) to high and boosts the CPU frequency by 450 MHz. This allows the GPU fans to run but only during the BIOS and until a module gets loaded during boot. I'm unable to deduce what is actually causing it though. I've posted my boot log and my machine's specifications below.

$ dmesg
[    0.676936] ACPI: Power Button [PWRB]
[    0.676965] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input1
[    0.677895] ACPI: Power Button [PWRF]
[    0.678535] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    0.699577] 00:04: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
[    0.700587] usbcore: registered new interface driver usbserial_generic
[    0.700590] usbserial: USB Serial support registered for generic
[    0.700614] rtc_cmos 00:01: RTC can wake from S4
[    0.700855] rtc_cmos 00:01: registered as rtc0
[    0.700866] rtc_cmos 00:01: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[    0.700965] ledtrig-cpu: registered to indicate activity on CPUs
[    0.701124] NET: Registered protocol family 10
[    0.704325] Segment Routing with IPv6
[    0.704336] NET: Registered protocol family 17
[    0.704832] RAS: Correctable Errors collector initialized.
[    0.704853] microcode: CPU0: patch_level=0x0800820b
[    0.704856] microcode: CPU1: patch_level=0x0800820b
[    0.704858] microcode: CPU2: patch_level=0x0800820b
[    0.704860] microcode: CPU3: patch_level=0x0800820b
[    0.704864] microcode: CPU4: patch_level=0x0800820b
[    0.704867] microcode: CPU5: patch_level=0x0800820b
[    0.704872] microcode: CPU6: patch_level=0x0800820b
[    0.704876] microcode: CPU7: patch_level=0x0800820b
[    0.704881] microcode: CPU8: patch_level=0x0800820b
[    0.704884] microcode: CPU9: patch_level=0x0800820b
[    0.704888] microcode: CPU10: patch_level=0x0800820b
[    0.704892] microcode: CPU11: patch_level=0x0800820b
[    0.704914] microcode: Microcode Update Driver: v2.2.
[    0.704922] sched_clock: Marking stable (728236976, -23326332)->(812664689, -107754045)
[    0.705106] registered taskstats version 1
[    0.705111] Loading compiled-in X.509 certificates
[    0.707056] Loaded X.509 cert 'Build time autogenerated kernel key: 89546a39deaf547f25e84b2ed55afaec0c8c176e'
[    0.707076] zswap: loaded using pool lzo/zbud
[    0.710235] Key type big_key registered
[    0.710506]   Magic number: 15:464:140
[    0.710547] acpi device:11: hash matches
[    0.710629] rtc_cmos 00:01: setting system clock to 2019-04-20T18:07:42 UTC (1555783662)
[    0.711454] Freeing unused decrypted memory: 2040K
[    0.711668] Freeing unused kernel image memory: 1536K
[    0.741245] Write protecting the kernel read-only data: 18432k
[    0.741595] Freeing unused kernel image memory: 2016K
[    0.741668] Freeing unused kernel image memory: 376K
[    0.748023] x86/mm: Checked W+X mappings: passed, no W+X pages found.
[    0.748027] Run /init as init process
[    0.751806] fbcon: Taking over console
[    0.751855] Console: switching to colour frame buffer device 240x75
[    0.814786] i8042: PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
[    0.814787] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
[    0.815402] serio: i8042 KBD port at 0x60,0x64 irq 1
[    0.819935] SCSI subsystem initialized
[    0.819988] xhci_hcd 0000:03:00.0: xHCI Host Controller
[    0.819994] xhci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 1
[    0.825790] libata version 3.00 loaded.
[    0.827819] ahci 0000:03:00.1: version 3.0
[    0.827920] ahci 0000:03:00.1: SSS flag set, parallel bus scan disabled
[    0.827957] ahci 0000:03:00.1: AHCI 0001.0301 32 slots 8 ports 6 Gbps 0x33 impl SATA mode
[    0.827959] ahci 0000:03:00.1: flags: 64bit ncq sntf stag pm led clo only pmp pio slum part sxs deso sadm sds apst 
[    0.828498] scsi host0: ahci
[    0.828605] scsi host1: ahci
[    0.828680] scsi host2: ahci
[    0.831271] scsi host3: ahci
[    0.833189] scsi host4: ahci
[    0.834606] scsi host5: ahci
[    0.834692] scsi host6: ahci
[    0.835878] scsi host7: ahci
[    0.835923] ata1: SATA max UDMA/133 abar m131072@0xfe880000 port 0xfe880100 irq 40
[    0.835925] ata2: SATA max UDMA/133 abar m131072@0xfe880000 port 0xfe880180 irq 40
[    0.835925] ata3: DUMMY
[    0.835926] ata4: DUMMY
[    0.835927] ata5: SATA max UDMA/133 abar m131072@0xfe880000 port 0xfe880300 irq 40
[    0.835928] ata6: SATA max UDMA/133 abar m131072@0xfe880000 port 0xfe880380 irq 40
[    0.835929] ata7: DUMMY
[    0.835929] ata8: DUMMY
[    0.836048] ahci 0000:20:00.2: AHCI 0001.0301 32 slots 1 ports 6 Gbps 0x1 impl SATA mode
[    0.836050] ahci 0000:20:00.2: flags: 64bit ncq sntf ilck led clo only pmp fbs pio 
[    0.836163] scsi host8: ahci
[    0.836206] ata9: SATA max UDMA/133 abar m4096@0xfe908000 port 0xfe908100 irq 42
[    0.850841] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2
[    0.875103] xhci_hcd 0000:03:00.0: hcc params 0x0200ef81 hci version 0x110 quirks 0x0000000000000410
[    0.875400] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.00
[    0.875401] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.875402] usb usb1: Product: xHCI Host Controller
[    0.875403] usb usb1: Manufacturer: Linux 5.0.7-arch1-1-ARCH xhci-hcd
[    0.875403] usb usb1: SerialNumber: 0000:03:00.0
[    0.875486] hub 1-0:1.0: USB hub found
[    0.875497] hub 1-0:1.0: 10 ports detected
[    0.875829] xhci_hcd 0000:03:00.0: xHCI Host Controller
[    0.875831] xhci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 2
[    0.875834] xhci_hcd 0000:03:00.0: Host supports USB 3.10 Enhanced SuperSpeed
[    0.875867] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    0.875880] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.00
[    0.875881] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.875882] usb usb2: Product: xHCI Host Controller
[    0.875882] usb usb2: Manufacturer: Linux 5.0.7-arch1-1-ARCH xhci-hcd
[    0.875883] usb usb2: SerialNumber: 0000:03:00.0
[    0.875933] hub 2-0:1.0: USB hub found
[    0.875940] hub 2-0:1.0: 4 ports detected
[    0.876172] xhci_hcd 0000:1f:00.3: xHCI Host Controller
[    0.876175] xhci_hcd 0000:1f:00.3: new USB bus registered, assigned bus number 3
[    0.876264] xhci_hcd 0000:1f:00.3: hcc params 0x0270f665 hci version 0x100 quirks 0x0000000000000410
[    0.876503] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.00
[    0.876504] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.876505] usb usb3: Product: xHCI Host Controller
[    0.876506] usb usb3: Manufacturer: Linux 5.0.7-arch1-1-ARCH xhci-hcd
[    0.876506] usb usb3: SerialNumber: 0000:1f:00.3
[    0.876559] hub 3-0:1.0: USB hub found
[    0.876564] hub 3-0:1.0: 4 ports detected
[    0.876688] xhci_hcd 0000:1f:00.3: xHCI Host Controller
[    0.876690] xhci_hcd 0000:1f:00.3: new USB bus registered, assigned bus number 4
[    0.876691] xhci_hcd 0000:1f:00.3: Host supports USB 3.0  SuperSpeed
[    0.876700] usb usb4: We don't know the algorithms for LPM for this host, disabling LPM.
[    0.876713] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.00
[    0.876714] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.876714] usb usb4: Product: xHCI Host Controller
[    0.876715] usb usb4: Manufacturer: Linux 5.0.7-arch1-1-ARCH xhci-hcd
[    0.876716] usb usb4: SerialNumber: 0000:1f:00.3
[    0.876764] hub 4-0:1.0: USB hub found
[    0.876769] hub 4-0:1.0: 4 ports detected
[    1.151316] ata9: SATA link down (SStatus 0 SControl 300)
[    1.207019] usb 1-9: new low-speed USB device number 2 using xhci_hcd
[    1.310328] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    1.311604] ata1.00: ATA-8: ST9500420AS, 0006HPM1, max UDMA/100
[    1.311606] ata1.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 32), AA
[    1.312640] ata1.00: configured for UDMA/100
[    1.312788] scsi 0:0:0:0: Direct-Access     ATA      ST9500420AS      HPM1 PQ: 0 ANSI: 5
[    1.314547] sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/466 GiB)
[    1.314556] sd 0:0:0:0: [sda] Write Protect is off
[    1.314557] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.314571] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.389268]  sda: sda1 sda2 < sda5 >
[    1.389681] sd 0:0:0:0: [sda] Attached SCSI disk
[    1.455433] usb 1-9: New USB device found, idVendor=1bcf, idProduct=0053, bcdDevice= 0.72
[    1.455435] usb 1-9: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    1.455437] usb 1-9: Product: USB Optical Mouse 
[    1.462947] hidraw: raw HID events driver (C) Jiri Kosina
[    1.483885] usbcore: registered new interface driver usbhid
[    1.483886] usbhid: USB HID core driver
[    1.485009] input: USB Optical Mouse  Keyboard as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-9/1-9:1.0/0003:1BCF:0053.0001/input/input3
[    1.540097] input: USB Optical Mouse  Mouse as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-9/1-9:1.0/0003:1BCF:0053.0001/input/input4
[    1.540124] input: USB Optical Mouse  Consumer Control as /devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-9/1-9:1.0/0003:1BCF:0053.0001/input/input5
[    1.540197] hid-generic 0003:1BCF:0053.0001: input,hidraw0: USB HID v1.10 Keyboard [USB Optical Mouse ] on usb-0000:03:00.0-9/input0
[    1.624644] ata2: SATA link down (SStatus 0 SControl 300)
[    1.656975] tsc: Refined TSC clocksource calibration: 4049.995 MHz
[    1.656986] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x3a60d85d266, max_idle_ns: 440795219360 ns
[    1.657016] clocksource: Switched to clocksource tsc
[    1.936369] ata5: SATA link down (SStatus 0 SControl 330)
[    2.249668] ata6: SATA link down (SStatus 0 SControl 330)
[    2.928131] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[    3.117796] random: fast init done
[    4.851537] systemd[1]: systemd 241.93-1-arch running in system mode. (+PAM +AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=hybrid)
[    4.867054] systemd[1]: Detected architecture x86-64.
[    4.890693] systemd[1]: Set hostname to <archlinux>.
[    5.128486] random: crng init done
[    6.550394] systemd[1]: Reached target Remote File Systems.
[    6.550694] systemd[1]: Listening on Journal Socket (/dev/log).
[    6.557663] systemd[1]: Listening on LVM2 poll daemon socket.
[    6.558011] systemd[1]: Reached target Login Prompts.
[    6.558221] systemd[1]: Listening on Journal Socket.
[    6.559674] systemd[1]: Mounting Huge Pages File System...
[    6.559857] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[    6.650156] EXT4-fs (sda1): re-mounted. Opts: (null)
[    7.165912] audit: type=1130 audit(1555783668.949:2): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lvm2-lvmetad comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    7.174230] audit: type=1130 audit(1555783668.959:3): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-journald comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    7.183570] audit: type=1130 audit(1555783668.969:4): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-udev-trigger comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    7.191484] audit: type=1130 audit(1555783668.976:5): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-sysctl comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    7.304260] systemd-journald[380]: Received request to flush runtime journal from PID 1
[    7.364856] audit: type=1130 audit(1555783669.149:6): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-random-seed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    7.808545] audit: type=1130 audit(1555783669.596:7): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-sysusers comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    8.337276] audit: type=1130 audit(1555783670.123:8): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-setup-dev comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    9.427698] audit: type=1130 audit(1555783671.213:9): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-udevd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[    9.821520] input: PC Speaker as /devices/platform/pcspkr/input/input6
[    9.850690] cryptd: max_cpu_qlen set to 1000
[   10.219654] AVX2 version of gcm_enc/dec engaged.
[   10.219655] AES CTR mode by8 optimization enabled
[   10.737484] piix4_smbus 0000:00:14.0: SMBus Host Controller at 0xb00, revision 0
[   10.737485] piix4_smbus 0000:00:14.0: Using register 0x02 for SMBus port selection
[   10.746928] ccp 0000:1f:00.2: ccp enabled
[   10.746947] ccp 0000:1f:00.2: psp initialization failed
[   10.746948] ccp 0000:1f:00.2: enabled
[   10.761777] mousedev: PS/2 mouse device common for all mice
[   10.788055] sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver
[   10.788133] sp5100-tco sp5100-tco: Using 0xfed80b00 for watchdog MMIO address
[   10.788143] sp5100-tco sp5100-tco: Watchdog hardware is disabled
[   10.881324] libphy: r8169: probed
[   10.881658] r8169 0000:18:00.0 eth0: RTL8168h/8111h, 00:d8:61:38:c5:ff, XID 541, IRQ 63
[   10.881660] r8169 0000:18:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   10.976221] Linux agpgart interface v0.103
[   10.984049] kvm: disabled by bios
[   11.040427] kvm: disabled by bios
[   11.110632] MCE: In-kernel MCE decoding enabled.
[   11.153501] EDAC amd64: Node 0: DRAM ECC disabled.
[   11.153503] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                (Note that use of the override may cause unknown side effects.)
[   11.213823] r8169 0000:18:00.0 enp24s0: renamed from eth0
[   11.272186] AMD-Vi: AMD IOMMUv2 driver by Joerg Roedel <jroedel@suse.de>
[   11.357878] snd_hda_intel 0000:1e:00.1: Handle vga_switcheroo audio client
[   11.379315] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.1/0000:1c:00.0/0000:1d:00.0/0000:1e:00.1/sound/card0/input7
[   11.379350] input: HD-Audio Generic HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.1/0000:1c:00.0/0000:1d:00.0/0000:1e:00.1/sound/card0/input8
[   11.379379] input: HD-Audio Generic HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.1/0000:1c:00.0/0000:1d:00.0/0000:1e:00.1/sound/card0/input9
[   11.379409] input: HD-Audio Generic HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.1/0000:1c:00.0/0000:1d:00.0/0000:1e:00.1/sound/card0/input10
[   11.379440] input: HD-Audio Generic HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.1/0000:1c:00.0/0000:1d:00.0/0000:1e:00.1/sound/card0/input11
[   11.379471] input: HD-Audio Generic HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:03.1/0000:1c:00.0/0000:1d:00.0/0000:1e:00.1/sound/card0/input12
[   11.506389] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[   11.506392] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   11.506393] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   11.506394] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   11.506394] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   11.506396] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[   11.506397] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[   11.506397] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[   11.521830] input: HD-Audio Generic Front Mic as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input13
[   11.521882] input: HD-Audio Generic Rear Mic as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input14
[   11.521927] input: HD-Audio Generic Line as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input15
[   11.521970] input: HD-Audio Generic Line Out Front as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input16
[   11.522013] input: HD-Audio Generic Line Out Surround as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input17
[   11.522060] input: HD-Audio Generic Line Out CLFE as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input18
[   11.522143] input: HD-Audio Generic Line Out Side as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input19
[   11.522214] input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:08.1/0000:20:00.3/sound/card1/input20
[   11.570636] [drm] amdgpu kernel modesetting enabled.
[   11.570698] Parsing CRAT table with 1 nodes
[   11.570701] Ignoring ACPI CRAT on non-APU system
[   11.570703] Virtual CRAT table created for CPU
[   11.570703] Parsing CRAT table with 1 nodes
[   11.570704] Creating topology SYSFS entries
[   11.570710] Topology: Add CPU node
[   11.570710] Finished initializing topology
[   11.570788] checking generic (e0000000 8d0000) vs hw (e0000000 10000000)
[   11.570789] fb0: switching to amdgpudrmfb from VESA VGA
[   11.570805] Console: switching to colour dummy device 80x25
[   11.571018] [drm] initializing kernel modesetting (VEGA10 0x1002:0x687F 0x1DA2:0xE376 0xC3).
[   11.571031] [drm] register mmio base: 0xFE500000
[   11.571032] [drm] register mmio size: 524288
[   11.571038] [drm] add ip block number 0 <soc15_common>
[   11.571038] [drm] add ip block number 1 <gmc_v9_0>
[   11.571039] [drm] add ip block number 2 <vega10_ih>
[   11.571039] [drm] add ip block number 3 <psp>
[   11.571040] [drm] add ip block number 4 <gfx_v9_0>
[   11.571041] [drm] add ip block number 5 <sdma_v4_0>
[   11.571041] [drm] add ip block number 6 <powerplay>
[   11.571042] [drm] add ip block number 7 <dm>
[   11.571042] [drm] add ip block number 8 <uvd_v7_0>
[   11.571043] [drm] add ip block number 9 <vce_v4_0>
[   11.808551] [drm] UVD(0) is enabled in VM mode
[   11.808552] [drm] UVD(0) ENC is enabled in VM mode
[   11.808553] [drm] VCE enabled in VM mode
[   11.808596] amdgpu 0000:1e:00.0: No more image in the PCI ROM
[   11.808615] ATOM BIOS: 113-376XL-UO2
[   11.808643] [drm] vm size is 262144 GB, 4 levels, block size is 9-bit, fragment size is 9-bit
[   11.808651] amdgpu 0000:1e:00.0: VRAM: 8176M 0x000000F400000000 - 0x000000F5FEFFFFFF (8176M used)
[   11.808652] amdgpu 0000:1e:00.0: GART: 512M 0x0000000000000000 - 0x000000001FFFFFFF
[   11.808653] amdgpu 0000:1e:00.0: AGP: 267419648M 0x000000F800000000 - 0x0000FFFFFFFFFFFF
[   11.808656] [drm] Detected VRAM RAM=8176M, BAR=256M
[   11.808657] [drm] RAM width 2048bits HBM
[   11.808716] [TTM] Zone  kernel: Available graphics memory: 8219578 kiB
[   11.808716] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[   11.808717] [TTM] Initializing pool allocator
[   11.808719] [TTM] Initializing DMA pool allocator
[   11.808743] [drm] amdgpu: 8176M of VRAM memory ready
[   11.808744] [drm] amdgpu: 8176M of GTT memory ready.
[   11.808762] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   11.808869] [drm] PCIE GART of 512M enabled (table at 0x000000F400900000).
[   12.053000] [drm] use_doorbell being set to: [true]
[   12.053062] [drm] use_doorbell being set to: [true]
[   12.164999] [drm] Found UVD firmware Version: 1.87 Family ID: 17
[   12.165003] [drm] PSP loading UVD firmware
[   12.268678] [drm] Found VCE firmware Version: 55.3 Binary ID: 4
[   12.268691] [drm] PSP loading VCE firmware
[   12.416694] [drm] reserve 0x400000 from 0xf400d00000 for PSP TMR SIZE
[   12.603410] [drm] Display Core initialized with v3.2.08!
[   12.628485] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   12.628486] [drm] Driver supports precise vblank timestamp query.
[   12.650007] [drm] UVD and UVD ENC initialized successfully.
[   12.750409] [drm] VCE initialized successfully.
[   12.751021] kfd kfd: Allocated 3969056 bytes on gart
[   12.751042] Virtual CRAT table created for GPU
[   12.751043] Parsing CRAT table with 1 nodes
[   12.751051] Creating topology SYSFS entries
[   12.751125] Topology: Add dGPU node [0x687f:0x1002]
[   12.751183] kfd kfd: added device 1002:687f
[   12.752155] [drm] fb mappable at 0xE1100000
[   12.752156] [drm] vram apper at 0xE0000000
[   12.752156] [drm] size 9216000
[   12.752157] [drm] fb depth is 24
[   12.752158] [drm]    pitch is 7680
[   12.752190] fbcon: amdgpudrmfb (fb0) is primary device
[   12.786072] Console: switching to colour frame buffer device 240x75
[   12.805849] amdgpu 0000:1e:00.0: fb0: amdgpudrmfb frame buffer device
[   12.830393] amdgpu 0000:1e:00.0: ring gfx uses VM inv eng 0 on hub 0
[   12.830394] amdgpu 0000:1e:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[   12.830395] amdgpu 0000:1e:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[   12.830396] amdgpu 0000:1e:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[   12.830397] amdgpu 0000:1e:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[   12.830398] amdgpu 0000:1e:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[   12.830399] amdgpu 0000:1e:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[   12.830400] amdgpu 0000:1e:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[   12.830400] amdgpu 0000:1e:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[   12.830401] amdgpu 0000:1e:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[   12.830402] amdgpu 0000:1e:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[   12.830403] amdgpu 0000:1e:00.0: ring sdma1 uses VM inv eng 1 on hub 1
[   12.830404] amdgpu 0000:1e:00.0: ring uvd_0 uses VM inv eng 4 on hub 1
[   12.830405] amdgpu 0000:1e:00.0: ring uvd_enc_0.0 uses VM inv eng 5 on hub 1
[   12.830407] amdgpu 0000:1e:00.0: ring uvd_enc_0.1 uses VM inv eng 6 on hub 1
[   12.830408] amdgpu 0000:1e:00.0: ring vce0 uses VM inv eng 7 on hub 1
[   12.830409] amdgpu 0000:1e:00.0: ring vce1 uses VM inv eng 8 on hub 1
[   12.830410] amdgpu 0000:1e:00.0: ring vce2 uses VM inv eng 9 on hub 1
[   12.830495] [drm] ECC is not present.
[   12.831350] [drm] Initialized amdgpu 3.27.0 20150101 for 0000:1e:00.0 on minor 0
[   13.017744] audit: type=1130 audit(1555783674.803:10): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lvm2-monitor comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   13.018010] Adding 8385532k swap on /dev/sda5.  Priority:-2 extents:1 across:8385532k FS
[   16.039173] audit: type=1130 audit(1555783677.823:11): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-journal-flush comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.581120] audit: type=1130 audit(1555783678.369:12): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=ldconfig comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.619048] audit: type=1130 audit(1555783678.403:13): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-tmpfiles-setup comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.633328] audit: type=1127 audit(1555783678.416:14): pid=608 uid=0 auid=4294967295 ses=4294967295 msg=' comm="systemd-update-utmp" exe="/usr/lib/systemd/systemd-update-utmp" hostname=? addr=? terminal=? res=success'
[   16.717105] audit: type=1130 audit(1555783678.503:15): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-journal-catalog-update comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.722019] audit: type=1130 audit(1555783678.506:16): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-update-done comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   16.737206] audit: type=1130 audit(1555783678.523:17): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-update-utmp comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   17.002349] audit: type=1130 audit(1555783678.786:18): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-timesyncd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   17.005139] audit: type=1130 audit(1555783678.789:19): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   17.292805] 8021q: 802.1Q VLAN Support v1.8
[   17.390755] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[   17.392785] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[   17.392806] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[   17.392806] cfg80211: failed to load regulatory.db
[   17.686276] Generic PHY r8169-1800:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=r8169-1800:00, irq=IGNORE)
[   17.796378] r8169 0000:18:00.0 enp24s0: Link is Down
[   18.431454] kauditd_printk_skb: 3 callbacks suppressed
[   18.431455] audit: type=1130 audit(1555783680.216:23): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-logind comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   18.558550] audit: type=1130 audit(1555783680.343:24): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   20.956756] r8169 0000:18:00.0 enp24s0: Link is Up - 1Gbps/Full - flow control rx/tx
[   20.956768] IPv6: ADDRCONF(NETDEV_CHANGE): enp24s0: link becomes ready
[   21.766247] audit: type=1130 audit(1555783683.549:25): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=polkit comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   21.766958] audit: type=1130 audit(1555783683.553:26): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=accounts-daemon comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   26.199470] audit: type=1130 audit(1555783687.983:27): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user-runtime-dir@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   26.219189] audit: type=1006 audit(1555783688.003:28): pid=706 uid=0 old-auid=4294967295 auid=620 tty=(none) old-ses=4294967295 ses=1 res=1
[   26.457176] audit: type=1130 audit(1555783688.243:29): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   28.188182] fuse init (API version 7.28)
[   39.410517] audit: type=1006 audit(1555783701.196:30): pid=797 uid=0 old-auid=4294967295 auid=1000 tty=(none) old-ses=4294967295 ses=2 res=1
[   39.419567] audit: type=1130 audit(1555783701.203:31): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user-runtime-dir@1000 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   39.423085] audit: type=1006 audit(1555783701.206:32): pid=804 uid=0 old-auid=4294967295 auid=1000 tty=(none) old-ses=4294967295 ses=3 res=1
[   39.446589] audit: type=1130 audit(1555783701.229:33): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user@1000 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   39.587329] audit: type=1112 audit(1555783701.373:34): pid=797 uid=0 auid=1000 ses=2 msg='op=login id=1000 exe="/usr/bin/lightdm" hostname=archlinux addr=? terminal=/dev/tty7 res=success'
[   49.478439] audit: type=1131 audit(1555783711.240:35): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   49.482868] audit: type=1131 audit(1555783711.247:36): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=user-runtime-dir@620 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   57.840905] audit: type=1130 audit(1555783719.521:37): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=upower comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   58.000094] audit: type=1130 audit(1555783719.680:38): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=rtkit-daemon comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   58.377246] audit: type=1130 audit(1555783720.054:39): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=colord comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[   59.028762] audit: type=1130 audit(1555783720.705:40): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=udisks2 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
$ inxi -F
System:    Host: archlinux Kernel: 5.0.7-arch1-1-ARCH x86_64 bits: 64 Desktop: Cinnamon 4.0.10 Distro: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK (MS-7C02) v: 1.0 serial: <root required> 
           UEFI [Legacy]: American Megatrends v: 1.40 date: 12/19/2018 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP L2 cache: 3072 KiB 
           Speed: 3253 MHz min/max: N/A Core speeds (MHz): 1: 3253 2: 3238 3: 3790 4: 4030 5: 3253 6: 3666 7: 3245 8: 3505 
           9: 3248 10: 3551 11: 3393 12: 3115 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.4 driver: amdgpu unloaded: modesetting,vesa resolution: 1920x1200~60Hz 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.27.0 5.0.7-arch1-1-ARCH LLVM 8.0.0) v: 4.5 Mesa 19.0.2 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.0.7-arch1-1-ARCH 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp24s0 state: up speed: 1000 Mbps duplex: full mac: 00:d8:61:38:c5:ff 
Drives:    Local Storage: total: 465.76 GiB used: 192.79 GiB (41.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST9500420AS size: 465.76 GiB 
Partition: ID-1: / size: 449.58 GiB used: 192.79 GiB (42.9%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 39.6 C mobo: N/A gpu: amdgpu temp: 29 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 1353 
Info:      Processes: 268 Uptime: 13m Memory: 15.68 GiB used: 2.00 GiB (12.7%) Shell: bash inxi: 3.0.32 

Last edited by aumars (2019-04-23 14:18:18)

Offline

#2 2019-04-22 14:25:20

aumars
Member
Registered: 2018-01-08
Posts: 9

Re: [SOLVED] SAPPHIRE PULSE Vega 56 fans inoperative on kernel 5.0.7

I didn't read the wiki because I'm an idiot.

https://wiki.archlinux.org/index.php/Fa … an_control

Last edited by aumars (2019-04-23 14:18:28)

Offline

Board footer

Powered by FluxBB