You are not logged in.

#1 2004-05-15 00:55:19

slyski
Member
From: Cheese Head Land
Registered: 2004-01-11
Posts: 60

waiting for udev

I see that hotplug package has been updated.

But I was wondering what is the use for it without udev installed.
Does it really work with devfs (deprecated in kernel-2.6.x)?

I've been using udev for about a month now without any troubles and I am quite satisfied with the results. I realize that it is in testing and not quite complete but it works better for me than devfs.

My main question is:
Is anyone working on a udev and sysfsutils package?

If so I will wait alittle longer.
If not I will attempt to actually use the makepkg program and try building the packages for myself.

Thanks in advance for any responses  wink

slyski


Joey: If a cow passes away from natural causes can I eat it.
Pheobe: Not if I get there first.

Offline

#2 2004-05-15 02:09:45

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Offline

#3 2004-05-15 02:18:11

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: waiting for udev

I have packages to migrate to udev right now.  I have submitted to Judd the patches needed for the init scripts.  We hope to give the user the option for 0.7.

BTW - hotplug works great without udev.  Amazingly it was created to hotplug devices and that's exactly what it does.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#4 2004-05-15 02:56:50

slyski
Member
From: Cheese Head Land
Registered: 2004-01-11
Posts: 60

Re: waiting for udev

COOOOL!! smile

I'll sit tight

thanx,
slyski


Joey: If a cow passes away from natural causes can I eat it.
Pheobe: Not if I get there first.

Offline

#5 2004-05-26 08:22:27

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: waiting for udev

I want it. I'll test it. Would burn my laptop to proof it.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#6 2004-05-26 16:01:56

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: waiting for udev

http://xentac.net/~jchu/udev/

There are notes and stuff included for a reason.

Oh yeah, the patch for rc.conf might not work with the newer initscripts.  I'll have to update it by hand...fixed.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#7 2004-05-26 21:24:25

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: waiting for udev

Thank you, Xentac, for package and scripts. smile
It took me five minutes to switch to udev. Ja!
Beneath the hints, you kindly written down in the notes.txt, I want to mention

· no extra kernel is necessary. You have to edit the boot loader config, as the device names will change, so add an 'append devfs=nomount' option to discriminate devfs.
Example (notice '/dev/sdd1' instead of '/dev/discs/disc3/part1):

--- grub menu.lst ---
# (0) Arch Linux
title  Arch Linux udev [/boot/vmlinuz26]
root   (hd0,0)
kernel /vmlinuz26 root=/dev/sdd1 ro vga=773 devfs=nomount

· Don't forget to edit your /etc/fstab, udev uses static dev syntax by default, like /dev/hda1, /dev/hdb1 or /dev/sr0, /dev/sda1 - just to give an example.
· nvidia users may add

mknod /dev/nvidia0 c 195 0
mknod /dev/nvidiactl c 195 255

to a boot up script, and need to add nvidia to the modules section at /etc/rc..conf. I did a quick shot, and added the mknod lines to rc.sysinit, as there is a case select wether to run devfsd or udev. It may be better to use rc.local - if I find udev stable enough not to use devfs anymore, I will move it there.


By the way, the rc.conf.patch worked on my tower, but not on my laptop, but both where up to date arch installations  :?  - fortunately, the changes are easily made by hand.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#8 2004-05-27 00:25:05

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: waiting for udev

Pink Chick wrote:

By the way, the rc.conf.patch worked on my tower, but not on my laptop, but both where up to date arch installations  :?  - fortunately, the changes are easily made by hand.

You haven't migrated the /etc/rc.conf.pacnew changes into /etc/rc.conf (specifically the LVM lines).  The patch is relative to the most recent version of initscripts.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#9 2004-06-05 08:44:31

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: waiting for udev

True, I have not migrated  a rc.conf.pacnew - I installed arch not so long ago, and already had the LVM entry. Nevertheless, udev is doing good.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#10 2004-06-14 22:59:22

slyski
Member
From: Cheese Head Land
Registered: 2004-01-11
Posts: 60

Re: waiting for udev

Xentac,

Do you have a PKGBUILD made up for this.

I am building new packages for use on my AMD-k6 (i586) machine and like to use and test the udev package you have made.

thanx,
slyski


Joey: If a cow passes away from natural causes can I eat it.
Pheobe: Not if I get there first.

Offline

#11 2004-06-15 00:32:25

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: waiting for udev

Yeah sure... send me an email about it or something, I don't have time to upload it right now.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#12 2004-06-23 21:16:16

Lefungus
Member
Registered: 2004-03-28
Posts: 26

Re: waiting for udev

Works great here. Very good combined with hotplug. Thanks a lot for your package xentac !

One thing to not forget though, is to correctly set permissions for audio in /etc/udev/permissions.d/udev.permissions

Offline

#13 2004-06-25 15:22:59

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,443

Re: waiting for udev

There are minor hotplug issues, in power management, f.e., that do not really work well. But I noticed hotplug complaining a lot while using devfs, too, so it may be a hotplug theme.

To mention other topics, you shoud carefully fetch information about udev if you want to start it up, to know about nvidia devices, permissions and so on.

But in the end, udev seems to be rather simple to be configured. By the way, it does very well in matching several usb devices to explicit nodes, no matter when and in which order they are plugged in.

Udev is ready for arch 0.7, as far as I am concerned.


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#14 2004-06-25 15:52:49

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: waiting for udev

Pink Chick wrote:

But in the end, udev seems to be rather simple to be configured. By the way, it does very well in matching several usb devices to explicit nodes, no matter when and in which order they are plugged in.

That is one of its design decisions, if it didn't do that well, then there would be a place to complain.

Udev is ready for arch 0.7, as far as I am concerned.

The question is whether or not Arch is ready for udev.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#15 2004-07-01 21:43:16

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: waiting for udev

xerxes is ready for udev! Thank you Xentac. big_smile


arch + gentoo + initng + python = enlisy

Offline

#16 2004-07-04 20:55:00

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: waiting for udev

Arch has now official udev support and the announcement can be found on the front page.
All of you that have used Xentacs package should be able to upgrade to the current udev package without problem, just edit your permissions.

This list should not be used anymore!!!!!

Migrate to udev for dummies.

1. Download the packages here. http://xentac.net/~jchu/udev/
Udev is in current repo now so you don't need this ABS package anymore.

2. Install udev. $ pacman -S udev

3. Create udev devices. $ /sbin/migrate-udev

4. Edit /etc/rc.conf with rc.conf.patch

--- /etc/rc.conf.orig    2004-05-10 23:18:41.000000000 -0700
+++ /etc/rc.conf    2004-05-11 00:07:43.000000000 -0700
@@ -17,6 +17,8 @@
 CONSOLEFONT=
 USECOLOR="yes"
 
+DEVFS="no"
+UDEV="yes"
 
 # Scan for LVM volume groups at startup, required if you use LVM
 USELVM="no"

5. Edit /etc/rc.sysinit with rc.sysinit.patch

--- /etc/rc.sysinit.orig    2004-05-10 23:17:58.000000000 -0700
+++ /etc/rc.sysinit    2004-05-10 16:53:40.000000000 -0700
@@ -19,8 +19,20 @@
 # anything more serious than KERN_WARNING goes to the console
 /bin/dmesg -n 3
 
-if [ -e /dev/.devfsd -a -x /sbin/devfsd ]; then
-    status "Starting DevFS Daemon" /sbin/devfsd /dev
+if [ "$DEVFS" = "YES" -o "$DEVFS" = "yes" ]; then
+    if [ -e /dev/.devfsd -a -x /sbin/devfsd ]; then
+        status "Starting DevFS Daemon" /sbin/devfsd /dev
+    fi
+fi
+
+if [ "$UDEV" = "YES" -o "$UDEV" = "yes" ]; then
+    if [ -x /etc/start_udev ]; then
+        mount -n -t sysfs none /sys
+        mount -n -t proc none /proc
+        status "Starting UDev Daemon" /etc/start_udev
+        umount /sys
+        umount /proc
+    fi
 fi
 
 if [ -f /etc/lvmtab -a -x /sbin/vgchange ]; then

6. Edit /etc/fstab. Comment out devfs and rename your drives to /dev/hd*.

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /proc         proc      defaults            0      0
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
tmpfs                  /tmp          tmpfs     defaults            0      0
sysfs                  /sys          sysfs     defaults            0      0
#usbdevfs               /proc/bus/usb usbdevfs  defaults            0      0

/dev/hdb     /mnt/dvd  udf       ro,user,noauto,unhide   0      0

/dev/hda5 swap swap defaults 0 0
/dev/hda3 / ext3 defaults 0 1
/dev/hda1 /boot ext2 defaults 0 1
/dev/hda6 /home ext3 defaults 0 1

7. Edit bootmanager. a) grub , b) lilo

a)  /boot/grub/menu.lst. Rename your root to /dev/hd* and put in "devfs=nomount".

--- grub menu.lst ---
# (0) Arch Linux
title  Arch Linux udev [/boot/vmlinuz26]
root   (hd0,2)
kernel (hd0,0)/vmlinuz26 root=/dev/hda3 ro devfs=nomount 

b) /etc/lilo.conf.  Rename your root to /dev/hd* and put in "devfs=nomount".

image=/boot/vmlinuz26
        label=arch
#        root=/dev/discs/disc1/part3
        root=/dev/hdb3
        read-only
        append="acpi=force devfs=nomount"
        vga=10 

8. Edit /etc/udev/permissions.d/udev.permissions.

a) sound: snd/*:root:users:666
b) nvidia graphics: nvidia*:root:users:666

9. Make sure that you havn't forget anything.

10. Reboot.

Disclaimer: This list is "very" unofficial. big_smile It worked for me, thanks again Xentac.

Edit: I'm glad that it worked for you guys. Xentac and the kernelhackers did the hard work, I just made a list. I forgot nr3 on my laptop and was pretty pissed.
I add a lilo point and a nvidia permissions.
Can you submit your working lilo.conf fbidwell?
What do you mean mattux? can you explain exactly so I don't mess up. big_smile


arch + gentoo + initng + python = enlisy

Offline

#17 2004-07-05 18:37:30

fbidwell
Member
From: Atlanta, GA (USA)
Registered: 2004-05-09
Posts: 32

Re: waiting for udev

Great xerxes2!!!

I followed your instructions on my "test box" and udev seems to be working great.

I had to re-install my nvidia drivers to get x to work, there may be an easier way, but reinstalling seemed to work.

I also had to update my device settings in some applications.

I use lilo and not grub, but  following the same naming conventions in lilo worked.

All in all took about 10 minutes. I patched my config files by hand, so I could put comments in them and so I could understand what was happening.

I'm going to run udev on my test box for a week or so and see if I have problems, if not... I'll switch my main workstation over to udev.

I think xerxes2's instructions should be added to the wiki.

Offline

#18 2004-07-05 19:18:35

mattux
Member
Registered: 2004-04-22
Posts: 81

Re: waiting for udev

great work...
but only one thing you should know
if you have nvidia drivers you should run
"for i in 0 1 2 3 4 5 6 7; do
      node="/dev/nvidia$i"
      rm -f $node
      mknod $node c 195 $i
      chmod 0666 $node   
done
  node="/dev/nvidiactl"
  rm -f $node       
  mknod $node c 195 255
  chmod 0666 $node"
every boot....(for me it work´s) wink

mattux

Offline

#19 2004-07-05 20:05:39

fbidwell
Member
From: Atlanta, GA (USA)
Registered: 2004-05-09
Posts: 32

Re: waiting for udev

Mattux,

Which NVIDIA drivers are you using? I'm using the 1.0-6106 drivers and I seem to get /dev/nvidia0 and /dev/nvidiactl created at boot up.

I then added

nvidia*:root:users:666

to /etc/udev/permissions.d/udev.permissions

Offline

#20 2004-07-05 20:14:30

mattux
Member
Registered: 2004-04-22
Posts: 81

Re: waiting for udev

yes 1.0.6106
oh yes this works ,too....thx


mattux

Offline

#21 2004-07-05 21:50:02

fbidwell
Member
From: Atlanta, GA (USA)
Registered: 2004-05-09
Posts: 32

Re: waiting for udev

Here is my working lilo.conf.

I have a dual boot.  Windows use the whole first harddrive.  Arch on the second.

partitions are :
/boot   hdb1 ext2
/swap  hdb2 swap
/         hdb3 ext3

I'm also using Dusty's boot splash.bmp.

#
# /etc/lilo.conf
#

# boot=/dev/discs/disc0/disc
boot=/dev/hda

# This line often fixes L40 errors on bootup
# disk=/dev/discs/disc0/disc bios=0x80

#Graphical Boot Loader stuff
bitmap=/boot/arch-lilo.bmp
bmp-colors=1,0,8,3,8,1
bmp-table=250p,150p,1,18

default=arch
timeout=50
lba32
prompt

image=/boot/vmlinuz26
        label=arch
#        root=/dev/discs/disc1/part3
        root=/dev/hdb3
        read-only
        append="acpi=force devfs=nomount"
        vga=10

other=/dev/hda1
        label=Windows98

# End of file

Offline

#22 2004-07-05 21:59:10

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: waiting for udev

is it called /etc/lilo.conf and was it just the same two changes as in grub you made? Just to keep it as simple as possible. And what did mattux mean?


arch + gentoo + initng + python = enlisy

Offline

#23 2004-07-05 22:09:52

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: waiting for udev

yep, /etc/lilo.conf.

Yep, please update the udev wiki with your step by step process...

I should have noted somewhere that that bmp was snarffed from the forum and converted to bmp format. I asked the guy for permission to use it and he never got back to me, so I erm.... took that as a yes.

Sounds like mattux was talking about the permissions on nvidia device; fbidwell's solution is somewhat more elegant, if you include it in your howto, use that instead.

Dusty

Offline

#24 2004-07-05 22:20:19

xerxes2
Member
From: Malmoe, Sweden
Registered: 2004-04-23
Posts: 1,249
Website

Re: waiting for udev

oki Dusty , so mattux' code is not necessary at all???


arch + gentoo + initng + python = enlisy

Offline

#25 2004-07-05 23:09:06

Dusty
Schwag Merchant
From: Medicine Hat, Alberta, Canada
Registered: 2004-01-18
Posts: 5,986
Website

Re: waiting for udev

I think so. I haven't tried any of this stuff though, so what would I know?

Dusty

Offline

Board footer

Powered by FluxBB