You are not logged in.

#1 2008-03-26 06:56:12

McLovin
Member
Registered: 2008-03-16
Posts: 30

programs wont run after compiling

not sure what I'm doing wrong here, looked around on the forums for anything, and found nothing regarding this issue.
I have tried to install a few programs now, AWN, and Cairo-Clock, downloaded the tar files, unpacked them, cd to the directory, and run

./configure
make
make install

and then when I try to run the program, i get an error saying the program could not be found, but it is in the menu to run it, what am I doing wrong here?
Sry for all the noob ?s on the first night with Arch, but this is confusing the hell out of me, I get no errors during configuring, or installing, but the program just will not run. Any help would be appreciated.

Last edited by McLovin (2008-03-26 06:56:32)

Offline

#2 2008-03-26 07:28:11

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: programs wont run after compiling

McLovin wrote:

not sure what I'm doing wrong here, looked around on the forums for anything, and found nothing regarding this issue.
I have tried to install a few programs now, AWN, and Cairo-Clock, downloaded the tar files, unpacked them, cd to the directory, and run

./configure
make
make install

and then when I try to run the program, i get an error saying the program could not be found, but it is in the menu to run it, what am I doing wrong here?
Sry for all the noob ?s on the first night with Arch, but this is confusing the hell out of me, I get no errors during configuring, or installing, but the program just will not run. Any help would be appreciated.

My guess you're installing in a prefix which is not in your path (maybe /usr/local ?).  Either add it to your path, or change the prefix when running configure like

./configure --prefix=/usr

On a side note, why don't you use the packages provided in the AUR. If you use those they will get managed by pacman as a bonus wink

Offline

#3 2008-03-26 07:36:47

brebs
Member
Registered: 2007-04-03
Posts: 3,636

Re: programs wont run after compiling

McLovin wrote:

an error saying the program could not be found

It's probably looking in /usr/bin, whereas you've installed into /usr/local/bin wink

Offline

#4 2008-03-26 07:56:18

McLovin
Member
Registered: 2008-03-16
Posts: 30

Re: programs wont run after compiling

brebs wrote:
McLovin wrote:

an error saying the program could not be found

It's probably looking in /usr/bin, whereas you've installed into /usr/local/bin wink

i think that's it, so if I do

./configure --prefix=/usr/bin

it should work? I'll give it a try tomorrow, I started on isntalling Arch at about 4pm this afternoon, and it's been almost 12 hours that I've been working on it, but have gotten alot accomplished I think. got the base isntalled, got gnome installed, got ati drivers installed, got compiz installed, got firefox........
As for why I dont use the ones in the AUR, i try to get them with pacman, and it says package not in package sync,????? Oh well, tomorrows another day.
{singing}Tooomorrow, tomorrow, I love you, tomorrow{singing} lol

Last edited by McLovin (2008-03-26 07:56:47)

Offline

#5 2008-03-26 08:16:31

brebs
Member
Registered: 2007-04-03
Posts: 3,636

Re: programs wont run after compiling

Wrong. See how the zillions of packages do it:

abs
find /var/abs -maxdepth 4 -type f -name PKGBUILD -print0 | xargs -0 grep "prefix="

Offline

#6 2008-03-26 08:35:26

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: programs wont run after compiling

And read about the AUR if you want to use it. Hint: it's not a regular repo, so you cant use pacman on it directly.

Offline

#7 2008-03-26 09:01:53

pressh
Developer/TU
From: Netherlands
Registered: 2005-08-14
Posts: 1,719

Re: programs wont run after compiling

McLovin wrote:

i think that's it, so if I do

./configure --prefix=/usr/bin

please read again what I wrote, the correct syntax is there wink

Offline

#8 2008-03-26 10:18:44

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: programs wont run after compiling

You could also read ./configure --help for more details on this.

Offline

Board footer

Powered by FluxBB