You are not logged in.

#1 2008-12-01 09:53:08

Back2Cali
Member
From: Germany
Registered: 2006-02-26
Posts: 223

Xorg 7.4 Keyboard Problem! Bug?

Hi!

I just updated my XOrg server to version 7.4 and after starting the server I found the following not working: All Arrow Keys as well as the INS, DEL, HOME, etc. keys on the keyboard are no longer working. Also the Alt Gr key does not work correctly (it seems that it behaves like the return key). It doesn't matter if I have an existing xorg.conf file or if I let Xorg automatically detect everything. Nothing seems to really work... :-(

Does anyone have an ide how to fix this since with especially the Alt Gr key not working I'm facing some problems when writing texts etc.!


Thanks a lot!

Offline

#2 2008-12-01 10:19:54

batoo
Member
Registered: 2008-12-01
Posts: 7

Re: Xorg 7.4 Keyboard Problem! Bug?

Same problem here:((

Any ideas?
This problem is after update to new xorg server.

Offline

#3 2008-12-01 10:23:28

cheer
Member
From: Russia, St. Petersburg
Registered: 2006-08-02
Posts: 131

Re: Xorg 7.4 Keyboard Problem! Bug?

Does

Option "AllowEmptyInput" "False"

in ServerFlags section help if you disabled hotplugging?
What is

cat /var/log/Xorg.0.log | grep WW

?

Last edited by cheer (2008-12-01 10:27:25)

Offline

#4 2008-12-01 10:31:51

Nepherte
Member
From: Belgium
Registered: 2008-09-09
Posts: 427
Website

Re: Xorg 7.4 Keyboard Problem! Bug?

Check out http://wiki.archlinux.org/index.php/Xor … otplugging

P.S You don't have to disable hotplugging to get everything to work again.

Offline

#5 2008-12-01 10:32:53

ChemBro
Member
Registered: 2008-10-22
Posts: 675

Re: Xorg 7.4 Keyboard Problem! Bug?

In KDE4, you can use "evdev-managed keyboard" as keyboardlayout. Maybe you find something similiar for you.

Offline

#6 2008-12-01 10:33:39

Back2Cali
Member
From: Germany
Registered: 2006-02-26
Posts: 223

Re: Xorg 7.4 Keyboard Problem! Bug?

Option "AllowEmptyInput" "False" doesn't help. However it seems that while KDM askes me for the password to log in the keys seem to work. After KDE starts it does not work any longer.....

Here's my result from running cat /var/log/Xorg.0.log | grep WW:

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) NV(0): BAR1 is > 256 MB, which is probably wrong.  Clamping to 256 MB.

Offline

#7 2008-12-01 10:36:22

Back2Cali
Member
From: Germany
Registered: 2006-02-26
Posts: 223

Re: Xorg 7.4 Keyboard Problem! Bug?

Thanks, the evdev-managed keyboard did the trick for me!

Offline

#8 2008-12-01 11:13:10

chochem
Member
From: Denmark
Registered: 2008-03-02
Posts: 176
Website

Re: Xorg 7.4 Keyboard Problem! Bug?

I'm getting a US keyboard layout despite having set

<code>Option "AllowEmptyInput" "False"</code>

in the section "ServerFlags"

and xorgconfig added this to the InputDevice section:

<code>
    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc105"
    Option "XkbLayout"    "dk"
</code>

After the upgrade X refused to start so I moved the old xorg.conf to backup and ran xorgconfig to generate a new one from scratch.

Offline

#9 2008-12-01 11:39:39

joeda
Member
Registered: 2008-09-14
Posts: 32

Re: Xorg 7.4 Keyboard Problem! Bug?

I'm stuck in US-Layout, too...

Hope I don't have to hack my xorg.conf everytime I upgrade it!

Offline

#10 2008-12-01 11:44:26

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,293

Re: Xorg 7.4 Keyboard Problem! Bug?

In KDE4, you can use "evdev-managed keyboard" as keyboardlayout. Maybe you find something similiar for you.

Thanks, the evdev-managed keyboard did the trick for me!

Could you be more specific on this one smile ? I can't find the option in my KDE4 keyboard settings.

Offline

#11 2008-12-01 11:45:30

chochem
Member
From: Denmark
Registered: 2008-03-02
Posts: 176
Website

Re: Xorg 7.4 Keyboard Problem! Bug?

I tried using setxkbmap - this is what it spits out>

setxkbmap -v 10 da
Setting verbose level to 10
locale is C
Warning! Multiple definitions of keyboard layout
         Using command line, ignoring X server
Applied rules from base:
model:      evdev
layout:     da
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+da+inet(evdev)
geometry:   pc(pc104)
Error loading new keyboard description

Offline

#12 2008-12-01 12:51:16

KimTjik
Member
From: Sweden
Registered: 2007-08-22
Posts: 715

Re: Xorg 7.4 Keyboard Problem! Bug?

chochem wrote:

I'm getting a US keyboard layout despite having set

<code>Option "AllowEmptyInput" "False"</code>

in the section "ServerFlags"

It's maybe a bit annoying that it suddenly has to be done differently, but it wasn't to hard to fix. As shown in the link http://wiki.archlinux.org/index.php/Xor … otplugging you can make the same settings in "/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi". In that file you have a similar line as in "old" xorg.conf:

<merge key="input.xkb.layout" type="string">se,us,ru</merge>

That's my settings giving me Swedish, US and Russian keyboard. Thus there's no need disable the hotplugging. I use XFCE4 and you have to make the same setting there as in Gnome and KDE, namely to select "evdev" as the handler of the keyboard, to get all keys working.

Offline

#13 2008-12-01 13:19:33

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,293

Re: Xorg 7.4 Keyboard Problem! Bug?

I use XFCE4 and you have to make the same setting there as in Gnome and KDE, namely to select "evdev" as the handler of the keyboard, to get all keys working.

But how am I supposed to 'select "evdev" as the keyboard handler' smile ? (KDE4)

Offline

#14 2008-12-01 13:53:32

esodax
Member
From: Sweden
Registered: 2008-08-10
Posts: 24

Re: Xorg 7.4 Keyboard Problem! Bug?

But how am I supposed to 'select "evdev" as the keyboard handler' smile ? (KDE4)

evdev is set by default.
Try this as superuser:

cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/

Open /etc/hal/fdi/policy/10-keymap.fdi with your text editor.
Change the line <merge key="input.xkb.layout" type="string">us</merge> to <merge key="input.xkb.layout" type="string">ru</merge> or whatever keymap you'll need.

/etc/rc.d/hal restart

(Altough I don't know if KDE does things differently)

Last edited by esodax (2008-12-01 13:58:50)

Offline

#15 2008-12-01 14:05:40

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,293

Re: Xorg 7.4 Keyboard Problem! Bug?

evdev is set by default.

Somehow I doubt it (my old KDE layouts still work (CapsLock for us/ru switch)).

The problem I'm trying to cope with right now is that my service keys (arrows, Home, End, etc.) won't work. evdev handler is a proposed solution; people turn it on and report succes, even in this thread, but I still don't know how smile .

Offline

#16 2008-12-01 14:22:40

Varnsen
Member
Registered: 2008-08-24
Posts: 10

Re: Xorg 7.4 Keyboard Problem! Bug?

I added this

Section "ServerFlags"
     Option "AutoAddDevices" "False"
EndSection

to xorg.conf and it solved it for me.

Offline

#17 2008-12-01 14:23:45

esodax
Member
From: Sweden
Registered: 2008-08-10
Posts: 24

Re: Xorg 7.4 Keyboard Problem! Bug?

Llama wrote:

Somehow I doubt it (my old KDE layouts still work (CapsLock for us/ru switch)).

The problem I'm trying to cope with right now is that my service keys (arrows, Home, End, etc.) won't work. evdev handler is a proposed solution; people turn it on and report succes, even in this thread, but I still don't know how smile .

You are right Llama. This seem to be an keyboard-model problem within KDE, not layout related.
KDE is apparently working differently. I'm sorry, I can't help any further on this one, I'm using Awesome WM myself and had to do the stuff I wrote about in my previous post.

Offline

#18 2008-12-01 14:26:04

zenlord
Member
From: Belgium
Registered: 2006-05-24
Posts: 1,209
Website

Re: Xorg 7.4 Keyboard Problem! Bug?

check /etc/X11/xorg.conf. Every setting that is not set in that file will be handled by xorg/randr and will be set default to evdev for the inputs.

Both the wiki and the forum have the solution to this problem.

Zl.

Offline

#19 2008-12-01 14:35:31

chochem
Member
From: Denmark
Registered: 2008-03-02
Posts: 176
Website

Re: Xorg 7.4 Keyboard Problem! Bug?

Varnsen wrote:

I added this

Section "ServerFlags"
     Option "AutoAddDevices" "False"
EndSection

to xorg.conf and it solved it for me.

Oops, looks like I added the wrong option.... Are my ears red....

Still I'm pretty sure I followed the wiki to the letter regarding implementing the new HAL way and I ended up in X with no keyboard at all. The old way works though. Guess it just goes to show that you should save major upgrades for the weekend or whenever you feel like spending an hour or two getting reacquainted with your GRUB emergency boot options wink

Offline

#20 2008-12-01 14:38:03

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,293

Re: Xorg 7.4 Keyboard Problem! Bug?

Input devices have been commented out of my etc/X11/xorg.conf. Synaptic touchpad works as adveritsed (I've used Wiki), but the keyboard problem (no arrows, no Home, End, etc.) persists. Looks like it's still somehow handled by KDE (setxkbmap?).

Last edited by Llama (2008-12-01 14:40:49)

Offline

#21 2008-12-01 14:57:25

KimTjik
Member
From: Sweden
Registered: 2007-08-22
Posts: 715

Re: Xorg 7.4 Keyboard Problem! Bug?

Llama I don't use KDE but in XFCE4 I was forced to (meaning: if I wanted to use the new autoplugging "feature") add the plugin "Keyboard layouts" and there select "Evdev managed keyboard".

I've seen some other threads here about Gnome and KDE and as I understand it these DE:s override somehow the keyboard settings if not selecting what I described above (somewhere in KDE you've got a control centre of some sort). I don't know if I understood this right:
- evdev is default for xorg
- but if using a DE it also has to be set to comply to letting evdev manage it

Last edited by KimTjik (2008-12-01 15:44:05)

Offline

#22 2008-12-01 15:45:47

elmer_42
Member
From: /na/usa/ca
Registered: 2008-10-11
Posts: 427

Re: Xorg 7.4 Keyboard Problem! Bug?

Varnsen wrote:

I added this

Section "ServerFlags"
     Option "AutoAddDevices" "False"
EndSection

to xorg.conf and it solved it for me.

Thanks, this worked for me.


[ lamy + pilot ] [ arch64 | wmii ] [ ati + amd ]

Offline

#23 2008-12-02 03:39:11

divineant
Member
From: Denmark
Registered: 2007-06-26
Posts: 11

Re: Xorg 7.4 Keyboard Problem! Bug?

I have also solved my problems by disabeling hotplug, but since hal seems to be the future I would like to get it working.
When configuring etc/hal/fdi/policy/10-keymap.fdi it does change my layout, but "up arrow" is mapped to prt scr (wich results in lots of screenshot). Im not sure if thats the only misconfigured key.
My keymap btw is "dk"

Offline

#24 2008-12-02 08:30:23

KimTjik
Member
From: Sweden
Registered: 2007-08-22
Posts: 715

Re: Xorg 7.4 Keyboard Problem! Bug?

divineant@

What DE are you using? If at least using something like Gnome, KDE and XFCE you need to change keyboard layout in the DE to "managed by evdev", otherwise you might loose some keys.

Offline

#25 2008-12-02 09:01:34

Llama
Member
From: St.-Petersburg, Russia
Registered: 2008-03-03
Posts: 1,293

Re: Xorg 7.4 Keyboard Problem! Bug?

I've got almost all of the solution: http://www.kdemod.ath.cx/bbs/viewtopic.php?id=1355

Please, expand smile ...

Offline

Board footer

Powered by FluxBB