You are not logged in.

#1 2004-08-06 20:53:28

slackhack
Member
Registered: 2004-06-30
Posts: 738

fonts still a problem

has anyone found out what's wrong with the arch freetype2/fontconfig/xorg packages to keep giving the crappy fonts? here's a latest shot after trying to pkgbuild the freetype2 package with the prefix set for =/usr/local (where it gets installed by default if you build freetype normally -- why is the arch package set for =/usr?):

http://datadump.homelinux.com/fontconfig/lq-jumbled.png

oy! look at that jumbled mess. it looks like a novelty font!

i tried reinstalling freetype2 with pacman -S, but it just gets really messy, with the diagonals of letters like x, k, and w completely faded out. then i removed freetype, fontconfig, and xorg, and pacmanned them fresh, but no luck.  so now it's time for another complete reinstall -- joy.  sad this font issue is major buzzkill -- i really wish it could be addressed and fixed!

Offline

#2 2004-08-06 22:24:02

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: fonts still a problem

I only had once font problems (some fonts were too big) when I booted into KDE instead of Xfce. I was used with the Xfce 96dpi font setting and it seems KDE had it somehow else (and there was no way of changing it besides editing some .XSomething file - everything got fixed).

Offline

#3 2004-08-06 22:33:45

nggalai
Member
From: Switzerland
Registered: 2004-08-01
Posts: 215
Website

Re: fonts still a problem

Hmm. What TTF fonts do you use, and are they properly installed? Is your X-Server using correct DPI settings for your display?

93,
-Sascha.rb

Offline

#4 2004-08-07 01:06:56

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

nggalai wrote:

Hmm. What TTF fonts do you use, and are they properly installed? Is your X-Server using correct DPI settings for your display?

93,
-Sascha.rb

the TTF fonts don't matter. those are bitstream, believe it or not. but using MS or other TTF fonts looks even worse (see my other posts here).

the DPI is set correctly, thanks. there's a conflict with the newer versions of the software somewhere -- freetype2, fontconfig, glibc, etc. i've been able to fix my system back to "not *as* crappy" by removing the font directories and reinstalling xorg, but i'm just wondering if anyone has figured out (or fixed!) the underlying problem. it sucks having to go back to windows on my laptop so much just to design web pages b/c the fonts are unusable in linux.

Offline

#5 2004-08-07 07:44:18

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,261

Re: fonts still a problem

for fonts make an entry in xorg.conf in fonts section
run
fc-cache -fv
go to the dircetory where you installed the fonts
run
mkfontscale
mkfontdir
and run ln -s /usr/X11R6/lib/X11/fonts/encodings/encodings.dir encodings.dir

be sure that the fonts you have installed are only one time available to X
try an other browser or have a look at it's font usage
EDIT:
And try Display Size option in xorg.conf:
eg:
Section "Monitor"
    Identifier   "Monitor0"
    DisplaySize  305    230

width in mm and height in mm

Offline

#6 2004-08-07 09:12:10

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: fonts still a problem

slackhack wrote:

has anyone found out what's wrong with the arch freetype2/fontconfig/xorg packages to keep giving the crappy fonts? here's a latest shot after trying to pkgbuild the freetype2 package with the prefix set for =/usr/local (where it gets installed by default if you build freetype normally -- why is the arch package set for =/usr?):

http://datadump.homelinux.com/fontconfig/lq-jumbled.png

oy! look at that jumbled mess. it looks like a novelty font!

i tried reinstalling freetype2 with pacman -S, but it just gets really messy, with the diagonals of letters like x, k, and w completely faded out. then i removed freetype, fontconfig, and xorg, and pacmanned them fresh, but no luck.  so now it's time for another complete reinstall -- joy.  sad this font issue is major buzzkill -- i really wish it could be addressed and fixed!

quite everything has set to go per-default to /usr/local, but if you are making pkgs, you should go for /usr

is this strange font-thing only for mozilla or whole X? if only mozilla, check the properties of mozilla for resolution/dpi


The impossible missions are the only ones which succeed.

Offline

#7 2004-08-07 15:28:25

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

no, it's everywhere, but here's something quite peculiar. in nedit, the alt+key combinations never worked for me in arch. pretty frustrating to have the habit of alt+f open, alt+s find/replace, etc. and instead have an f or s or whatever character show up in the text. tongue

after i removed all the font directories yesterday and reinstalled xorg, i noticed this morning that suddenly the nedit menu fonts were true type and not bitmap (or whatever they were before). now the alt+key combinations work! is that bizarre, or what?

Offline

#8 2004-08-07 17:19:12

rex0
Member
Registered: 2004-07-12
Posts: 12

Re: fonts still a problem

I've had simmilar problems after glibc 2.3.3. For me any gtk+2 application the fonts have an extra pixel on the left side(very similar to your screenshots, look at the 'T's.) If part of the character  exists there the pixel is black, if itt doesnt it's grey. Not the best description but there are screenshots in my now defunct thread in desktop enviroments.

I've got xorg(tried xfree aswell) nothing asfar as I know is misconfigured and switching back to glibc 2.3.2 (and all staticly built apps) fixes everything instantly (pacman install 2.3.3, run firefox/evolution/gedit/anything fonts are messed up, insttall 2.3.2 restart any of those applications fonts are fine.) So I'm out of ideas myself. What ever the problem is it seems so isolated, I can't find any one else with these problems on anyother forums or mailing lists. That whole slackware 9.1  -> 10 font thing was similar but as far as I can find they never resolved it.

Offline

#9 2004-08-07 17:44:36

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

hmm, come to think of it, i tried nptl again yesterday after reading your thread, and maybe that's what fixed nedit. glibc must be screwed up since about a year ago, when all my font problems began with the upgrade to slack 9.1. that is starting to seem like the common denominator.

p.s. so who maintains glibc, and how can we bug them to look into making fixes? tongue

Offline

#10 2004-08-07 21:27:25

rex0
Member
Registered: 2004-07-12
Posts: 12

Re: fonts still a problem

Even non nptl glibc 2.3.3 gives me the same problems.
From what I can tell its something linked to glibc but that's just about everything. To try and narrow it down I've updated to the latest cvs, freetype, font config, atk, glib, gtk, pango, glibc to try and see. I've rebuilt my font dirs, reinstalled them, tried every option fontconfig offers.  With glibc 2.3.2 I can replicate the problem by turning hinting on in fontconfig, or enabling autohinting, even with both of these set to false, It doesn't change the problem in 2.3.3. The other thing I noticed is it only seems to be a problem in gtk2 applicattions, gtk1 applctions such as xmms have no issues. I'm not sure if this is because they dont use freetype/xft (do they? I'm not sure) or if it's because they don't use gtk2/pango.  xterm/aterm isn't effected either.

What this all means I'm not sure. I don't think the problem is with glibc itself but with something that uses it. From there I dont know if the problem is from gtk2/pango or if pango is just passing the problem from freetype to gtk2.  I'm composing something with everything to send to the gtk mailing list to see if someone can  point me in the right direction or can at least help narrow down which component it is. One think I'm going try is building staticlly linked versions of the software then switching to 2.3.3 and use that to narrow down which package is causing the problem

Offline

#11 2004-08-07 22:36:15

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

hmm, it's very interesting.

with slack 9.1, the problem would resolve "like magic" by compiling and installing xfree manually. so that would lead me to believe it's not gtk/gtk+, pango, or fontconfig, but more likely freetype2.

i thought nedit was gtk1, but i just checked the website and it says nedit uses LessTif or Open Motif. so if what happened with nedit is related to this overall problem and either of those toolkits uses freetype2, that might be a clue. or else it's just glibc messing with a bunch of different things. tongue

xmms, aterm/rxvt, etc. are all fine here, too. but k3b has the spindly fonts, so again that makes me think it's more likely a glibc/freetype issue (or rather, if it is gtk2, then it's also qt wink).

:confused:

Offline

#12 2004-08-07 23:14:11

cactus
Taco Eater
From: t͈̫̹ͨa͖͕͎̱͈ͨ͆ć̥̖̝o̫̫̼s͈̭̱̞͍̃!̰
Registered: 2004-05-25
Posts: 4,615
Website

Re: fonts still a problem

i still have wonky fonts, even after trying many of the things on the forums...
good luck in your sleuthing guys!


"Be conservative in what you send; be liberal in what you accept." -- Postel's Law
"tacos" -- Cactus' Law
"t̥͍͎̪̪͗a̴̻̩͈͚ͨc̠o̩̙͈ͫͅs͙͎̙͊ ͔͇̫̜t͎̳̀a̜̞̗ͩc̗͍͚o̲̯̿s̖̣̤̙͌ ̖̜̈ț̰̫͓ạ̪͖̳c̲͎͕̰̯̃̈o͉ͅs̪ͪ ̜̻̖̜͕" -- -̖͚̫̙̓-̺̠͇ͤ̃ ̜̪̜ͯZ͔̗̭̞ͪA̝͈̙͖̩L͉̠̺͓G̙̞̦͖O̳̗͍

Offline

#13 2004-08-08 02:51:11

rex0
Member
Registered: 2004-07-12
Posts: 12

Re: fonts still a problem

hmm k3b works, thats a good point. I dont have a cd burner or anything kde/qt apps on this computer. So maybe It isn't gtk. I tried the latest cvs of freetype2 again and built it static against 2.3.2 and it still exhibited the problem, but  a look with ldd showed that parts of it were still dynamically linked to glibc.

Soo maybe it isn't related to gtk2, probably a bad assumption on my part, I use xfce and my only effected heavy use apps are gtk2. I'm thinking it may come down to x itself or freetype now, aswell.  I don't really want to rebuild xorg since this machine is speedstepped to 600 mhz (still only 750 max), but if that's what it takes....

I thought of perhaps an easier way, I'm going to look for builds(or make them myself) of firefox  with xft disabled and disable gtk2's use of xft (I think exporting GDK_USE_XFT=0 should do this, right?) as my next step, and I guess maybe think of someplace else to ask other then the gtk list, if the problems are happening with qt apps aswell.

ugh firfox with disable-xft disable-freetype2 is building.

Offline

#14 2004-08-08 04:52:43

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

rex0 wrote:

I thought of perhaps an easier way, I'm going to look for builds(or make them myself) of firefox  with xft disabled and disable gtk2's use of xft (I think exporting GDK_USE_XFT=0 should do this, right?) as my next step, and I guess maybe think of someplace else to ask other then the gtk list, if the problems are happening with qt apps aswell.

ugh firfox with disable-xft disable-freetype2 is building.

yes, do export GDK_USE_XFT=0 before you start X, or i guess you could pass it to the startup command or put it in one of the startup scripts. (but i don't think you're going to like the results. tongue)

i've already asked the freetype developers, and they don't seem to have an answer. one of them even worked extensively with me trying everything we could think of, but we still couldn't get it. so i guess we are on our own, unless we can enlist some other gurus who are working on related projects (or just anyone who gives a d@mn about decent fonts!) so far your explanation of it being somehow related to glibc has been the best, i think.

how would one go about building freetype or xorg so that they're statically  linked to glibc? i still have the pkgbuilds right here from my unsuccessful fix attempts, and it would only take a minute or two for freetype, and probably about 45 min to an hour for xorg. i have 2200 mhz ready to go into action, so lmk and i can try it. big_smile

Offline

#15 2004-08-08 06:26:13

rex0
Member
Registered: 2004-07-12
Posts: 12

Re: fonts still a problem

well I've rebuilt firefox without freetype2 or xft support. It does work with the new glibc and I dont have any font problems (well other then the fonts looking terrible because of no freetype2.) So unless my logic is flawed or I'm missing something I guess the problem lays with freetype. As for building freetype statically I was passing enable-static to it in config, but  it wasn't being built completely static. I'm not sure if x will build statically  if it does it will be huge and it may not do anything. As for how I'm not sure but I think I'm going for some sleep first. If you want to give it a shot I'd guess its somewhere in one of the def files, maybe host.def

Of course assuming the problem is with freetype 2, how to fix it is a whole other issue.  I guess tomorrow I'm going to start looking at some changelogs on glibc and see if I can spot anything changed that may be having an impact.

Offline

#16 2004-08-10 06:18:15

rex0
Member
Registered: 2004-07-12
Posts: 12

Re: fonts still a problem

Well I fixed it.

Upon switching to glibc 2.3.3 and using strace on evolution I noticed it was looking for /usr/X11R6/lib/libfreetype.so.6. Which happens to be a link to libfreetypee.so.6.3.3 which is dated Apr 7. It looks like the problem is this old version of freetype that shipped with xorg is what is causing all my problems. After replacing libfreetype.so.6.3.3 with one I built tonight everything works exactly as it did with glibc 2.3.3. I've still got to check to make sure its not a random occurance or if I messed something up in my  various builds as I've assembled about 10 packages of freetype all with different options. Switching back to the stock freetype 2.1.7 and replacing libfreetype.so.6.3.3 with libfreetype.so.6.3.5 in the freetype 2.1.7 package seems to have corrected the problem as well.

I've still got more stability testing but so far so good.

Offline

#17 2004-08-10 13:51:03

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

my xorg has always seemed to install libfreetype.so.6.3.5, with no trace of 6.3.3. you must have had that lying around from an earlier build and it got "orphaned." (btw, the new ones are going to  /usr/lib/libfreetype* and not /usr/local/lib/libfreetype*, or /usr/X11/lib/ right?)

i guess it's back to the drawing board for me. maybe i'll try statically building an earlier freetype that has 6.3.3, see if i notice any changes.  post a screenshot or two if you get the chance, a "before and after" so we can see the difference.

cheers (& congratulations big_smile)

Offline

#18 2004-08-10 16:26:15

rex0
Member
Registered: 2004-07-12
Posts: 12

Re: fonts still a problem

Nuts; I was hoping this would fix everything. I'm not sure where that  other libfreetype came from. Yes, all of my new ones were getting installed to /usr/lib but all the applications were/still are looking for them in /usr/X11R6/lib

here's an after screenshot. -> link
This before screenshot probably illustrates my problem best. All of the charaters are much too heavy and they all have an extra black or gray pixel on the left side of the stroke.

I've manually turned anti-alias off as I  like my fonts a little crisper. The fonts I've got picked in firefox are Serif, sans-serif and monospace which are alised to Verdana, Times New Roman, and Andale Mono.

I've also noticed after wasting all that time building firefox in about:config under fonts.  you can control all of the font options without rebuilding.

My current freetype, the arch standard 2.17 package, is dynamically linked to glibc. For me anyways it looks like theproblem was infact glibc but the problem had to do with it linking to the old freetype library.

Offline

#19 2004-08-19 12:34:38

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

Hi there. I'm new to arch linux (not to linux entirely) and one of the very few problems (perhaps the biggest and more annoying one) i've had so far is this one with fonts.

I'll try to illustrate it.

The font in question as you can see is Bitstream Vera Sans, and it's really crappy on xfontsel and on that root-tail i'm running on the bottom of the desktop.

However, the same font is being used on the Beep Media Player playlist and it's perfect ! Pixel fonts like the one on the terminal or on gkrellm don't have any problems.

In Firefox, the fonts don't look so crappy because they are antialiased, but if i look from under the screen i can see they're still crappy (since i'm running this on a laptop, i can notice it very easily from a different angle).

This has nothing to do with dpi settings or anything else. I ran slackware 10 before and everything was perfect (and my xorg config is exactly the same), so i'm reverted to the same problem as you guys.

The fact that in BMP fonts look good, probably means that this is related to dynamic links or apps looking for the freetype lib on the wrong place.

I've read the last topics carefully and i'm gonna try some stuff now.

What i've found so far is the following:
libfreetype.so.6 is in fact linked to libfreetype.so.6.3.5, so i guess no problem there too.

I'm gonna try and symlink that libfreetype into /usr/X11R6/lib to see if it the apps now look for it over there.

@rex0: you said you dynamically linked freetype to glibc. What did you exactly do ?! i'm kinda confused now  :?

By the way, another screenshot i took while writing this down.

Notice the K's on that line that says "...got to check to make sure...".

Offline

#20 2004-08-19 12:41:51

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

By the way, no luck with the symlinking...i'm completely lost now. I noticed that you guys haven't posted anything for some days since your last posts. Any luck since then ?

Offline

#21 2004-08-19 15:19:20

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: fonts still a problem

Here's my xfontsel right above yours.

I don't pretend to know a lot about fonts in linux, but have you done things like loaded the freetype module in your X config?


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#22 2004-08-19 15:43:31

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

# This loads the Type1 and FreeType font modules
    Load        "type1"
    Load        "speedo"
    Load        "freetype"
    Load        "xtt"

There it is. I read somewhere on the forums that i shouldn't enable freetype and xtt at the same time, but i never had any problem related to that with other distros and if i disable xtt most of the fonts are gone.

Anyway, would you mind showing me your x config file ? and you have evrything up to date with arch current (freetype, xorg and related packages) ?!

Offline

#23 2004-08-19 15:48:39

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: fonts still a problem

# XFree86 4.0 configuration generated by Xconfigurator

Section "ServerLayout"
    Identifier "XFree86 Configured"
    Screen      0  "Screen0" 0 0
#    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Mouse1" "SendCoreEvents"
    InputDevice    "Keyboard0" "CoreKeyboard"
#   InputDevice    "stylus" "SendCoreEvents"
    Option "BlankTime" "5"
    Option "StandbyTime" "10"
    Option "SuspendTime" "20"
    Option "OffTime" "30"
EndSection

# By default, Red Hat Linux 6.0 and later use xfs

Section "Files"
#    FontPath "unix/:7100"
# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath    "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath    "/usr/X11R6/lib/X11/fonts/local/"
    FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath    "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath    "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath    "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath    "/usr/X11R6/lib/X11/fonts/ttf-ms-fonts/"

# ModulePath can be used to set a search path for the X server modules.
# The default path is shown here.

#    ModulePath    "/usr/X11R6/lib/modules"
EndSection

# Module loading section

Section "Module"
    Load  "dbe"        # Double-buffering
    Load  "GLcore"        # OpenGL support
    Load  "dri"        # Direct rendering infrastructure
    Load  "glx"        # OpenGL X protocol interface
    Load  "extmod"        # Misc. required extensions
    Load  "v4l"        # Video4Linux
    # Load  "pex5"        # PHIGS for X 3D environment (obsolete)
    # Load  "record"    # X event recorder
    # Load  "xie"        # X Image Extension (obsolete)
    # You only need the following two modules if you do not use xfs.
    Load  "freetype"     # TrueType font handler
    # Load  "type1"        # Adobe Type 1 font handler
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "keyboard"
    Option      "XkbLayout"    "dvorak"
    Option      "XkbModel"  "pc104"
    Option      "AutoRepeat" "500 30"
EndSection

Section "InputDevice"
    Identifier    "Mouse0"
    # Modified by mouseconfig
    Driver        "mouse"
#    Option        "Device"        "/dev/mouse"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "PS/2"
#    Option        "Emulate3Buttons"    "yes"
    Option        "ZAxisMapping"        "4 5"
EndSection

Section "InputDevice"
    Identifier    "Mouse1"
    # Modified by mouseconfig
    Driver        "mouse"
    Option        "Device"        "/dev/input/mice"
#    Option        "Protocol"        "PS/2"
    Option        "Protocol"        "ImPS/2"
#    Option        "Emulate3Buttons"    "yes"
    Option        "ZAxisMapping"        "4 5"
EndSection

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device"        "/dev/input/event0"
    Option        "Type"            "stylus"
    Option        "Mode"            "absolute"
    Option        "USB"            "on"
    Option        "alwayscore"        "on"
#    Option        "debuglevel"        "99"
#    Option        "suppress"        "1"
#    Option        "HistorySize"        "2"
EndSection

Section "Monitor"
    Identifier "Generic Laptop Display Panel 1024x768"
    VendorName "Unknown"
    ModelName  "Unknown"
    HorizSync 28.0-48.5
    VertRefresh 40-70
    Option "DPMS" "true"
EndSection

Section "Monitor"
    Identifier "Monitor1"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
EndSection

Section "Device"
    Identifier "Card0"
    Driver "i810"
    BoardName "Unknown"
#    VideoRam 32768
    BusID "PCI:0:2:0"
EndSection

Section "Device"
    Identifier "Card1"
    Driver "i810"
    BoardName "Unknown"
#    VideoRam 32768
    BusID "PCI:0:2:1"
EndSection

Section "Device"
    Identifier "Linux Frame Buffer"
    Driver "fbdev"
    BoardName "Unknown"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Generic Laptop Display Panel 1024x768"
    DefaultDepth 16
    Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600"
    EndSubSection
    Subsection "Display"
        Depth 8
        Modes "1024x768" "800x600"
    EndSubSection
    Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600"
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device "Card1"
    Monitor "Monitor1"
    DefaultDepth 16
    Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600"
    EndSubSection
    Subsection "Display"
        Depth 8
        Modes "1024x768" "800x600"
    EndSubSection
    Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600"
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#24 2004-08-19 16:08:51

s3pHiRoTh
Member
From: Portugal
Registered: 2004-08-19
Posts: 12

Re: fonts still a problem

the only difference from my config file is that you're not loading the type 1 module. i disabled it, still the same hmm

Offline

#25 2004-08-19 18:14:25

slackhack
Member
Registered: 2004-06-30
Posts: 738

Re: fonts still a problem

s3pHiRoTh wrote:

By the way, another screenshot i took while writing this down.

Notice the K's on that line that says "...got to check to make sure...".

another victim, sorry to hear (see) it. you can also see it's the same on your lower case x, and basically anything that has a diagonal (check out the upper case R characters in your bookmark menubar, for example).

fyi, it's not a configuration problem, so don't waste your time changing all your config files to try to fix it. i've had good fonts and the bad fonts with exactly the same configuration. it's something in X/freetype and how it "talks" or is linked to something else, glibc, for example. i know this because i always had the bad fonts in slackware 9.1 until i recompiled X manually. then the fonts would be fixed without doing anything else. that doesn't work with slack 10, though, and i haven't had the time to figure out how to recompile xorg yet in arch to see if it would work. but the point is it has nothing to do with your XFree86 or xorg config file, your local.conf, your dpi settings, etc. it's something deeper that no one understands yet.

so gl, and if you find an answer, please post it!

Offline

Board footer

Powered by FluxBB