You are not logged in.

#1 2008-12-31 16:12:21

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Framebuffer on boot stopped working all of a sudden :S

Just like the title says.
I am using vga=0x0369 in the kernel boot line.


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#2 2009-01-01 04:47:43

okplayer02
Member
From: Denver, Colorado
Registered: 2008-11-24
Posts: 84

Re: Framebuffer on boot stopped working all of a sudden :S

well i was looking i seen perhaps u try instead of vga=   try video=

with the above value u have on ur kernel boot line had u made any changes to your kernel or video drivers


Say what is good or keep silent  --Prophet Muhammad (SAW)

Offline

#3 2009-01-01 05:17:58

Statix
Member
From: Hangzhou, China
Registered: 2008-02-16
Posts: 240

Re: Framebuffer on boot stopped working all of a sudden :S

Well when something stops working all of a sudden you have to ask yourself what you changed. That's not really a question we can answer for you.

Did you recently update your system? Did you change anything hardware wise? Did you install anything, remove anything?

Last edited by Statix (2009-01-01 05:18:58)


Madly in love with Arch64, Openbox, DotA, and of course... penguins!
Happy to help if you're not a Help Vampire. Use your wonderful resources like ArchWiki, Google, and our wonderful search page.

Offline

#4 2009-01-01 05:31:50

dmz
Member
From: Sweden
Registered: 2008-08-27
Posts: 876
Website

Re: Framebuffer on boot stopped working all of a sudden :S

After 2.26.28, my 1680x1050 framebuffer also stopped working...

Offline

#5 2009-01-01 17:01:31

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

I updated to 2.26.28, everything worked fine. Just reinstalled nvidia driver. Then I downgraded and installed nvidia again and everything stopped working!


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#6 2009-01-01 18:04:32

okplayer02
Member
From: Denver, Colorado
Registered: 2008-11-24
Posts: 84

Re: Framebuffer on boot stopped working all of a sudden :S

so which kernel are u using now and where did u install the nvidia driver from


Say what is good or keep silent  --Prophet Muhammad (SAW)

Offline

#7 2009-01-01 20:24:14

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

2.26.27 latest recompiled from stock
Nvidia driver from website


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#8 2009-01-02 22:06:44

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

So anything?


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#9 2009-01-03 10:56:50

mips1
Member
Registered: 2008-01-02
Posts: 99

Re: Framebuffer on boot stopped working all of a sudden :S

You're not alone. Mine does not work on a fresh install of which I don't even have a desktop yet.

Last edited by mips1 (2009-01-03 10:57:27)

Offline

#10 2009-01-03 11:09:22

The Orange Peanut
Member
Registered: 2008-01-06
Posts: 152

Re: Framebuffer on boot stopped working all of a sudden :S

Mine doesn't work either.  Latest updates (pacman -Syu) with Nvidia 5200 video card, using 173 drivers.

Offline

#11 2009-01-03 22:19:14

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Hmmm... So I am not the only one getting this....
Did it stop all of a sudden for you guys?


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#12 2009-01-05 21:14:35

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Gah! This is really bothering me. I am using v86d and uvesa but i put 1680x1050 and it looks horrible :S


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#13 2009-03-12 21:57:55

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Bump....


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#14 2009-03-14 21:00:08

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

This is really frustrating!


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#15 2009-03-14 22:22:38

dmz
Member
From: Sweden
Registered: 2008-08-27
Posts: 876
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Indeed...

Offline

#16 2009-03-14 22:39:45

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Lol, never mind. Sorry, I made a mistake.

Last edited by haxit (2009-03-14 22:40:17)


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#17 2009-03-14 23:37:33

Ranguvar
Member
From: Our collective subconscious
Registered: 2008-08-12
Posts: 2,515
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Try uninstalling the NVIDIA driver and then installing it with pacman. Try different video modes, and vga=ask. Try old kernels, try old drivers. Try another monitor.

Offline

#18 2009-03-15 00:02:48

dmz
Member
From: Sweden
Registered: 2008-08-27
Posts: 876
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Ranguvar wrote:

Try uninstalling the NVIDIA driver and then installing it with pacman. Try different video modes, and vga=ask. Try old kernels, try old drivers. Try another monitor.

I did everything except old kernel which ain't an option.

Offline

#19 2009-03-15 00:06:07

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Ranguvar wrote:

Try uninstalling the NVIDIA driver and then installing it with pacman. Try different video modes, and vga=ask. Try old kernels, try old drivers. Try another monitor.

I did everything except old kernel also, which also to me isn't an option. Monitor, I will never change... I have tried the nvidia driver from the nv site and also the arch drivier. Still don't work.


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#20 2009-04-03 21:03:26

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Will this ever work again? I even tried it with new kernel, in testing.


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#21 2009-04-08 19:10:32

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Doesn't work with new beta driver either.


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#22 2009-04-08 21:08:17

Odysseus
Member
Registered: 2009-02-15
Posts: 127

Re: Framebuffer on boot stopped working all of a sudden :S

I don't see what the nvidia driver has to do with the framebuffer resolution.  I figured it only affects X.

I followed this to get 1200x800: http://wiki.archlinux.org/index.php/GRU … ant_to_use


I'm the type to fling myself headlong through the magical wardrobe, and then incinerate the ornate mahogany portal behind me with a Molotov cocktail.

Offline

#23 2009-04-08 21:13:06

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

Odysseus wrote:

I don't see what the nvidia driver has to do with the framebuffer resolution.  I figured it only affects X.

I followed this to get 1200x800: http://wiki.archlinux.org/index.php/GRU … ant_to_use

Tried that also. Still doesn't work.


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

#24 2009-04-15 20:38:27

JoshuaK
Member
From: Ohio, USA
Registered: 2008-09-13
Posts: 66
Website

Re: Framebuffer on boot stopped working all of a sudden :S

I also have this issue. I got pwettyful colors and font in term on FIRST BOOT. Heck, I even got Arch logos at the top of the screen at boot time. Install nVidia = bye bye framebuffer. Its toasted completely. Im stuck at the default, and vga=792 = FAIL. So now no purtifulness, which is quite useless to me. I like small fonts and the pwetty images, LOL (I like pwetty more than pretty, see?)


Meh has new account! This one left behind for history's sake...

Offline

#25 2009-04-15 20:40:37

haxit
Member
From: /home/haxit
Registered: 2008-03-04
Posts: 1,247
Website

Re: Framebuffer on boot stopped working all of a sudden :S

JoshuaK wrote:

I also have this issue. I got pwettyful colors and font in term on FIRST BOOT. Heck, I even got Arch logos at the top of the screen at boot time. Install nVidia = bye bye framebuffer. Its toasted completely. Im stuck at the default, and vga=792 = FAIL. So now no purtifulness, which is quite useless to me. I like small fonts and the pwetty images, LOL (I like pwetty more than pretty, see?)

Same thing goes for me. I need the nice images and small, crisp fonts.


Archi686 User | Old Screenshots | Old .Configs
Vi veri universum vivus vici.

Offline

Board footer

Powered by FluxBB