You are not logged in.

#1 2009-07-02 10:31:39

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I have KDE 4.3 RC installed, and, as I read here, we have to have libjpeg from [testing] installed. But after I installed it, jpg images, mainly in forums, become too ... big in Konqueror, they aren't shrinked properly neutral

Has anyone else seen such an issue ?

Offline

#2 2009-07-02 10:37:39

arkham
Member
From: Stockholm
Registered: 2008-10-26
Posts: 516
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

libjpeg hasn't been updated for a long time and a lot of programs need to be compiled against it. Try recompiling konqueror from abs or downgrading libjpeg.


"I'm Winston Wolfe. I solve problems."

~ Need moar games? [arch-games] ~ [aurcheck] AUR haz updates? ~

Offline

#3 2009-07-02 10:41:28

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,409
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I don't think the [kde-unstable] packages have been updated to the libjpeg version yet (well, you results suggest they have not).   I did warn people not to upgrade to [testing] for a couple of days unless the liked broken stuff...

Offline

#4 2009-07-02 10:55:04

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

So, I should downgrade to the stable one I suppose ?

--------

I think Konqueror (so... kdebase) is rebuilt with the new libjpeg, since after I downgraded to the stable libjpeg, a pop-error window appeared that requested the new .so provided by the latest libjpeg.

Last edited by flamelab (2009-07-02 10:59:06)

Offline

#5 2009-07-02 11:06:13

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

For x86_64 you should use the new libjpeg; i686 should follow soon.

Offline

#6 2009-07-02 11:08:00

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Yes, I have a x86_64 system. But that problem (with jpeg images that aren't shrinking and become large) exists neutral (KDE 4.3 RC + the [testing] libjpeg).

Offline

#7 2009-07-02 11:28:02

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

OK, I see. Lokks like KDE is not compatible with new libjpeg. Seems like they don't only changed the ABI; so a rebuild did not help.

Offline

#8 2009-07-02 11:37:54

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Someone ought to inform them upstream, so that they will be informed (if they aren't aware of this issue already).

Offline

#9 2009-07-02 11:46:10

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,409
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Pierre wrote:

OK, I see. Lokks like KDE is not compatible with new libjpeg. Seems like they don't only changed the ABI; so a rebuild did not help.

libjpeg7 is _supposed_ API compatible so this is a bit weird...   I'd be interested to know what is causing the breakage.

Offline

#10 2009-07-03 06:48:34

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I'd propose that you should fall back to the stable libjpeg for most packages, since the new one *breaks* a lot of things. Even svn versions of some programs (amarok), kde or not, can't just be rebuilt with the new libjpeg in order to (just) work. Amarok crashes for example.

If you won't find a patch or something till the day KDE 4.3 arrives in [extra], I think that you should build it with the current libjpeg, and not the testing one, because a lot of users (all those that use KDE, and will update to 4.3), will face problems.

---

Some programs won't work with new libjpeg (for example: filezilla, which I use a lot). Symlinking is TOO messy (and not standard), but I did it in order to have it work, since it can't be built with the new libjpeg.

Last edited by flamelab (2009-07-03 06:58:10)

Offline

#11 2009-07-03 07:11:32

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,409
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

filezilla is not even on the list of packages that need rebuilt and runs fine here.  Are you sure that amarok from svn not building is from libjpeg?  The API did not change, just the ABI so that seems wrong...

Offline

#12 2009-07-03 07:26:49

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 196

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

filezila doesn't work for me.

so did amsn, but i compiled it using abs PKGBUILD and now runs fine.

up to now im rebuilding filezilla, also from abs, in order to see if it works.

Last edited by mechmg93 (2009-07-03 07:31:49)


Mikes on AUR

Offline

#13 2009-07-03 07:32:07

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Allan wrote:

filezilla is not even on the list of packages that need rebuilt and runs fine here.  Are you sure that amarok from svn not building is from libjpeg?  The API did not change, just the ABI so that seems wrong...

Nope, it's not working. It can't be built with the new libjpeg, can't work with the new libjpeg. If you have already installed filezilla, you have to make *dirty* symlinks, which is too wrong, in my opinion.

Amarok-svn can be built with new libjpeg (even though I 'll try to rebuild it with VERBOSE=1, so that I find out if there are any hidden errors during compiling), and if try to open it, it crashes and in the error window, I find libjpeg errors.

I strongly propose: please don't rebuild packages with the newest libjpeg, since many of them aren't newest-libjpeg aware, even if they are built with it.

Offline

#14 2009-07-03 07:38:38

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 196

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

i had no problems building amarok2-svn from aur with the new libjpeg.


Mikes on AUR

Offline

#15 2009-07-03 07:40:29

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Can you run amarok ?

Application: Amarok (amarok), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000001dcd9e1 in ?? ()
#6  0x00007fff1ada8480 in ?? ()
#7  0x00007f246dddb9b5 in jpeg_CreateDecompress () from /usr/lib/libjpeg.so.7
#8  0x00007f24684cf7ff in ?? () from /usr/lib/qt/plugins/imageformats/libqjpeg.so
#9  0x00007f2477446a83 in QImageReader::read () from /usr/lib/libQtGui.so.4
#10 0x00007f2477446fec in QImageReader::read () from /usr/lib/libQtGui.so.4
#11 0x00007f24774563f1 in QPixmap::load () from /usr/lib/libQtGui.so.4
#12 0x00007f2477456b37 in QPixmap::QPixmap () from /usr/lib/libQtGui.so.4
#13 0x00007f24783788f6 in App::App () from /usr/lib/libamaroklib.so.1
#14 0x000000000040404d in _start ()

I have only libjpeg from [testing] installed, nothing else. If there is any package that I should install, please tell me, I'd be grateful.

Last edited by flamelab (2009-07-03 07:41:46)

Offline

#16 2009-07-03 07:43:36

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 196

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

i also have qt from testing. maybe this is your problem but i am not sure.


Mikes on AUR

Offline

#17 2009-07-03 07:44:14

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I'll try it, thank you.

-----

OK, amarok runs OK now. I hoped that this jpeg issue on Konqueror would be solved with this Qt, but it persists. sad

Last edited by flamelab (2009-07-03 07:48:21)

Offline

#18 2009-07-03 07:55:48

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I'll try to upgrade to [testing], in order to check if these problems persist.

________

It does hmm . Filezilla now works, since I think that it needed wxgtk from testing.

Last edited by flamelab (2009-07-03 08:09:29)

Offline

#19 2009-07-03 08:15:25

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 196

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

flamelab wrote:

I'll try to upgrade to [testing], in order to check if these problems persist.

________

It does hmm . Filezilla now works, since I think that it needed wxgtk from testing.

*mikes is testing the wxgtk thing....


It seems that most of the problems are solved with testing packages. I also needed xulrunner from testing in order to make firefox work..


edit:

filezilla also runs fine here with wxgtk from testing.

Last edited by mechmg93 (2009-07-03 08:16:00)


Mikes on AUR

Offline

#20 2009-07-03 09:09:29

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,409
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

*$^#%^&....   don't complain if you are not fully updated or mixing and matching from [testing].  That is not how [testing] works.  It is an all or none situation.

Offline

#21 2009-07-03 09:13:04

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 196

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Allan wrote:

*$^#%^&....   don't complain if you are not fully updated or mixing and matching from [testing].  That is not how [testing] works.  It is an all or none situation.

Allan, i am not complaining at all. Choosing to use kde-unstable, means that i know what i am doing, and that its normal to have problems as the above.

The one i'm trying to do is not have testing always enabled, but just install whatever is needed from testing repo, so that i do not have any problems with kde-unstable.


Mikes on AUR

Offline

#22 2009-07-03 10:01:05

Allan
Developer
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,409
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

@mechmg93: That post was not directed at you, but the post above your...

Offline

#23 2009-07-03 11:04:49

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Allan, check this out yourself. Kdebase is a very crucial system package that will enter extra very soon. This issue occurs mainly in forums where jpeg images exist in signatures, avatars ...

If you want, I can post screenshots.

Last edited by flamelab (2009-07-03 11:06:27)

Offline

#24 2009-07-03 12:22:35

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

I have created a bug report: https://bugs.kde.org/show_bug.cgi?id=198779

Offline

#25 2009-07-09 21:02:44

szym
Member
Registered: 2007-11-16
Posts: 14

Re: LibJpeg and... errors with jpg images [ KDE 4.3 RC from kde-unstable]

Speaking of libjpeg, testing/digikam (0.10.0-3) has unreasonable requirements:

$ ldd `which digikam` | grep libjpeg
        libjpeg.so.62 => not found
        libjpeg.so.7 => /usr/lib/libjpeg.so.7 (0x00007f57013a8000)

Any ideas how to make it happy?

Also, some stuff in kdemod-core still needs libjpeg.so.62 to run (most notably gwenview, konqueror and desktop wallpaper). Sigh.

Offline

Board footer

Powered by FluxBB