You are not logged in.

#1 2009-11-15 00:24:47

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

[testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

netcfg v2.5rc1

This is easily the biggest release since 2.0. Many new features and some significant changes under the hood. There are also a few features which have had changed options and this needs to be noted. The most notable is that net-auto has been removed in favour of the net auto wireless setup.

Move to new auto-wireless
The new automatic connection has proper roaming support and will prove more reliable than the old setup - particularly with more complicated wireless configurations.
To migrate to the new automatic wireless setup:
1. pacman -S testing/wpa_actiond
2. Set WIRELESS_INTERFACE="" to your wireless interface in /etc/rc.conf. For example WIRELESS_INTERFACE="wlan0"
3. Add net-auto-wireless to your DAEMONS=() array.

wpa-config profiles do not work with this, convert to wpa-configsection


New features:
- net-auto-wireless/wpa_actiond - Real wireless roaming/auto connection. Based on same principle as autowifi. Requires optional dependency: wpa_actiond
- net-auto-wired - automatic ethernet configuration. Requires optional dependency: ifplugd
- Interface configurations - set options for all profiles using an interface
- Radio Kill switch awareness - requires enabling, see wiki.
- Output hooks
- Significant internal cleanup & improvement

Internal changes:
- Uses wpa_supplicant for all wireless configuration by default, including wep/none security. This adds improves support for most and should improve reliability.
  - Uses iproute by default for all static configuration. net_tools which contains ifconfig is effectively obsolete and hasnt seen a release for over 8 years. The 'ethernet-iproute' and 'ethernet' connection types have been merged together to simply 'ethernet'. All options are still supported and existing configurations will continue to work for both types. A symlink has been made to ensure that profiles using 'ethernet-iproute' will continue to function.
 
Changes in configuration syntax
- net-auto and AUTO_NETWORKS is now deprecated in favour of net-auto-wireless/net-auto-wired.
- wireless: If you were previously specifying the wpa_supplicant driver in WPA_OPTS, you now need to specify it in WPA_DRIVER.
- wireless: iwconfig based configuration for wep/none can be used by changing to wep-old or none-old. This should not be necessary and is left in place only for the possibility of very old drivers that do not support wpa_supplicant.
- ethernet-iproute: Now that 'ethernet' is iproute based, those using 'ethernet-iproute' can change the name back. There is a symlink in place however, so existing configurations of either name will continue to function regardless.
- wireless-dbus: This idea didn't really go anywhere and is now unsupported. The wpa_supplicant dbus interface is a huge pain and it doesn't fit well into the netcfg codebase. It is no longer included, however netcfg will automatically use 'wireless' for any 'wireless-dbus' configurations as the supported options are effectively the same.


Download:
netcfg 2.5rc1 is in [testing]. The source is on the Arch Linux ftp and latest PKGBUILD in svn.
ftp://ftp.archlinux.org/other/netcfg/ne … rc1.tar.gz

Documentation:
The wiki has been updated to reflect this release. For 2.5, the documentation can be found at:
http://wiki.archlinux.org/index.php/Net … evelopment

When it is released this will be moved to the Network Profiles page. There's also some updated documentation of the supported options for 'wireless' and 'ethernet' here:
http://www.rayner.id.au/netcfg/
Keep in mind that wireless supports all the options of 'ethernet'. If options are not documented, then it's a bug and they should be (or it's deprecated, but should be mentioned anyway for completeness).

Contributors:
I had a few big contributors to this release:
Jim Pryor: Many internal changes and improvements
Thomas Bächler: wpa_actiond based auto roaming/connection
Thanks guys!

Bugs
On the bug tracker as always.

Last edited by iphitus (2009-12-31 11:47:52)

Offline

#2 2009-11-15 00:32:06

Misfit138
Misfit Emeritus
From: USA
Registered: 2006-11-27
Posts: 4,170

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Great job you guys.
This thing is a monster!

Offline

#3 2009-11-15 13:06:11

SnorreSelmer
Member
Registered: 2009-11-15
Posts: 3

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Nice work, looking forward to seeing the finished product in the repo.

Offline

#4 2009-11-15 16:22:44

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

bug report, here : http://bugs.archlinux.org/task/17147

anyway, great work... yet, another issue, which comes from a long time ago, which i expected to be fixed here is that during reboot, net-auto-wireless (or the old net-auto) dont setup the network.

Offline

#5 2009-11-15 16:46:56

mcover
Member
From: Germany
Registered: 2007-01-25
Posts: 133

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Thank you, great job! Finally getting rid of net_tools.

I couldn't wait and installed rc1, and no problems so far. Using net-auto-wireless, wpa and dhcp.

Offline

#6 2009-11-15 17:49:52

djszapi
Member
From: Cambridge, United Kingdom
Registered: 2009-06-14
Posts: 1,439
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Has netcfg actually dropped all dbus-based code paths due to their lack of usefulness ?

Offline

#7 2009-11-16 16:46:19

P3808
Member
From: Austria
Registered: 2009-11-02
Posts: 28

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

can anyone post a correct rc.conf file with netcfg and dhcp connection?
thx

Offline

#8 2009-11-16 16:49:50

Nepherte
Member
From: Belgium
Registered: 2008-09-09
Posts: 427
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Here's my rc.conf:

NETWORKS=(groenveld)
DAEMONS=(!network syslog-ng hal net-profiles <some more unrelevant items>)

and /etc/network.d/groenveld is just a copy from the example dhcp connection:

CONNECTION="ethernet"
DESCRIPTION="A basic dhcp ethernet connection using iproute"
INTERFACE="eth0"
IP="dhcp"

Offline

#9 2009-11-18 05:41:12

cwjiof
Member
From: Taichung, TW
Registered: 2008-01-27
Posts: 131

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Well, can anyone post a correct rc.conf file using net-auto-wireless or net-auto-wired, and an "appropriate profiles" in /etc/network.d/ ?

Should I delete the line:
NETWORKS=(...)
and remove "net-profiles" from the original DAEMONS?

Thanks.

Last edited by cwjiof (2009-11-18 05:42:23)

Offline

#10 2009-11-18 08:59:23

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

I have not been able to get roaming to work yet.
The relevant snips from my rc.conf:

WIRELESS_INTERFACE="wlan0"
DAEMONS=(syslog-ng @hal @crond @cups @alsa !network net-auto-wireless @laptop-mode)

net-auto-wireless states that it is done during boot. However, it does not connect to a network.
Here is a profile:

CONNECTION="wireless"
ESSID="WippiesHome"
DESCRIPTION="Himmerlandsgade"
INTERFACE="wlan0"
SECURITY="wpa-config"
WPA_CONF="/etc/wpa_supplicant.conf"
IP="dhcp" 
DNS=("208.67.220.220" "208.67.222.222")
TIMEOUT="45"
POST_UP="/home/rasmus/.scripts/hjemme-on"
PRE_DOWN="/home/rasmus/.scripts/hjemme-off"

Arch x64 on Thinkpad X200s/W530

Offline

#11 2009-11-18 12:43:04

Tyriel
Member
From: Melbourne, Australia
Registered: 2009-01-20
Posts: 161
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

netcfg is one of those awesome tools I can no longer live without and you have just made it even better.  Keep up the great work smile


The software required Windows XP or better, so I installed archlinux.

Offline

#12 2009-11-18 13:42:52

Runiq
Member
From: Germany
Registered: 2008-10-29
Posts: 1,053

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Tyriel wrote:

netcfg is one of those awesome tools I can no longer live without and you have just made it even better.  Keep up the great work smile

QFT.

Also, I don't quite see the difference between net-auto/AUTO_NETWORKS and net-auto-wireless/WIRELESS_INTERFACES - both seem to connect the specified interface to available networks automatically. In what way are they different beneath the surface?

Offline

#13 2009-11-18 16:46:02

Finkregh
Member
From: Germany/Hannover
Registered: 2007-12-04
Posts: 44

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

and another feature-request (including patch) here: http://bugs.archlinux.org/task/15661

Offline

#14 2009-11-18 19:29:21

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Pank wrote:

I have not been able to get roaming to work yet.
The relevant snips from my rc.conf:

WIRELESS_INTERFACE="wlan0"
DAEMONS=(syslog-ng @hal @crond @cups @alsa !network net-auto-wireless @laptop-mode)

net-auto-wireless states that it is done during boot. However, it does not connect to a network.
Here is a profile:

CONNECTION="wireless"
ESSID="WippiesHome"
DESCRIPTION="Himmerlandsgade"
INTERFACE="wlan0"
SECURITY="wpa-config"
WPA_CONF="/etc/wpa_supplicant.conf"
IP="dhcp" 
DNS=("208.67.220.220" "208.67.222.222")
TIMEOUT="45"
POST_UP="/home/rasmus/.scripts/hjemme-on"
PRE_DOWN="/home/rasmus/.scripts/hjemme-off"

When I run netcfg-actiond I get the following output:

╰─[20:22:58]> sudo netcfg-wpa_actiond wlan0
aau
hjemme
njl
Line 6: WPA-PSK accepted for key management, but no PSK configured.
Line 6: failed to parse network block.
Failed to read or parse configuration '/tmp/wpa.wlan0/wpa.conf'.

This refers to the following snip from my wpa_supplicant

network={
    ssid="WippiesHome"
    psk="PASSWORD"
    priority=5
}

It works with netcfg PROFILE.

Can somebody enlighten me . . .

--Rasmus


Arch x64 on Thinkpad X200s/W530

Offline

#15 2009-11-27 21:35:04

mcover
Member
From: Germany
Registered: 2007-01-25
Posts: 133

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Quick question: Is it intentional that when my network is connected to via net-auto-wireless I can no longer use "netcfg -a" to bring it/them all down, but instead have to use "/etc/rc.d/net-auto-wireless stop"?

Offline

#16 2009-11-30 09:44:19

Zariel
Member
Registered: 2008-10-07
Posts: 446

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Im trying to connect to my Uni's wireless using WPA2, They supply a cert and wpa config file which works when I do the following,

wpa_supplicant -B -c /etc/wpa-lboro.conf -iwlan0
wpa_cli identity 0 <user>
wpa_cli password 0 <password>
wpa_cli enable_network 0

But when i try to use wpa_config with the idenity and password put into the config and the config set to not disable the connection netcfg timesout at WPA Auth Failed, but if i manually do iwgetid wlan0 -ra it gives me the AP address, the outof wpa_cli status during this is as follows.

Selected interface 'wlan0'
bssid=00:21:d8:bf:44:0d
ssid=lboro
id=0
pairwise_cipher=CCMP
group_cipher=TKIP
key_mgmt=WPA2/IEEE 802.1X/EAP
wpa_state=ASSOCIATED
Supplicant PAE state=AUTHENTICATING
suppPortStatus=Unauthorized
EAP state=IDLE

Heres the wpa config

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
        ssid="lboro"
        key_mgmt=WPA-EAP
        # Uncomment the following line to FORCE WPA2 only otherwise it will
        # autonegotiate the protocol (and use WPA2 if possible otherwise WPA)
        # proto=WPA2
        eap=PEAP
        anonymous_identity="anonymous@lboro.ac.uk"
        identity="...."
        password="....."
        # Disable the network for now...
        ca_cert="/etc/ca-certificates/lboro-ca.crt"
        priority=0
        phase2="auth=MSCHAPV2"
}

It works fine if I dont fork it to background, I then have to do dhcpcd wlan0 to get an IP.

Last edited by Zariel (2009-11-30 10:21:52)

Offline

#17 2009-12-06 15:01:53

Tyriel
Member
From: Melbourne, Australia
Registered: 2009-01-20
Posts: 161
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Pank wrote:

When I run netcfg-actiond I get the following output:

╰─[20:22:58]> sudo netcfg-wpa_actiond wlan0
aau
hjemme
njl
Line 6: WPA-PSK accepted for key management, but no PSK configured.
Line 6: failed to parse network block.
Failed to read or parse configuration '/tmp/wpa.wlan0/wpa.conf'.

This refers to the following snip from my wpa_supplicant

network={
    ssid="WippiesHome"
    psk="PASSWORD"
    priority=5
}

It works with netcfg PROFILE.

Can somebody enlighten me . . .

--Rasmus

hmm I have the same issue and so far have been unlucky finding a solution.  Perhaps we have not set up wpa_supplicant correctly?


The software required Windows XP or better, so I installed archlinux.

Offline

#18 2009-12-06 22:43:15

alexandrite
Member
Registered: 2009-03-27
Posts: 326

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Tyriel wrote:
Pank wrote:

When I run netcfg-actiond I get the following output:

╰─[20:22:58]> sudo netcfg-wpa_actiond wlan0
aau
hjemme
njl
Line 6: WPA-PSK accepted for key management, but no PSK configured.
Line 6: failed to parse network block.
Failed to read or parse configuration '/tmp/wpa.wlan0/wpa.conf'.

This refers to the following snip from my wpa_supplicant

network={
    ssid="WippiesHome"
    psk="PASSWORD"
    priority=5
}

It works with netcfg PROFILE.

Can somebody enlighten me . . .

--Rasmus

hmm I have the same issue and so far have been unlucky finding a solution.  Perhaps we have not set up wpa_supplicant correctly?

It looks like the way that netcfg builds wpa_supplicant config files for non-secured networks lacks a default value, so if you have any un-encrypted network profiles defined, then wpa_supplicant will barf when it tries to parse the config file netcfg generates.

Try adding

SECURITY="none"

to the end of any nonsecured profile.  This fixed it for me.

Last edited by alexandrite (2009-12-06 22:48:26)

Offline

#19 2009-12-06 23:27:58

Tyriel
Member
From: Melbourne, Australia
Registered: 2009-01-20
Posts: 161
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

alexandrite wrote:
SECURITY="none"

to the end of any nonsecured profile.  This fixed it for me.

Thanks alexandrite, I never would have though of that considering it was my Ethernet config file that was causing the problem.  Now the issue is fixed and net-auto-wireless is working really well and I can help test it properly. smile


The software required Windows XP or better, so I installed archlinux.

Offline

#20 2009-12-07 02:09:21

rson451
Member
From: Annapolis, MD USA
Registered: 2007-04-15
Posts: 1,233
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

I'm having some issues with the latest package in [testing].  I've got a hidden WPA-PSK network set up at home that I've been connecting to for weeks with netcfg 2.2.1-1.  After the upgrade to netcfg 2.5.0rc1-1 netcfg fails saying it WPA association fails.  Complete output with DEBUG_NETCFG=yes below:

# NETCFG_DEBUG=yes netcfg a
DEBUG: Loading profile a
DEBUG: Configuring interface wlan0
:: a up                                                                                                  [BUSY] 
DEBUG: status reported to profile_up as: 
DEBUG: Loading profile a
DEBUG: Configuring interface wlan0
DEBUG: wireless_up stop_wpa wlan0
DEBUG: wireless_up ifup
DEBUG: wireless_up Configuration generated at /tmp/wpa.wlan0/wpa.conf
DEBUG: wireless_up start_wpa wlan0 /tmp/wpa.wlan0/wpa.conf wext 
DEBUG: wireless_up wpa_check

 > WPA Authentication/Association Failed 
DEBUG: profile_up connect failed
                                                                                                          [FAIL]

Interestingly enough, if I run these steps manually after running netcfg and failing, I can connect fine without issue:

# wpa_supplicant -i wlan0 -c /tmp/wpa.wlan0/wpa.conf &
# iwconfig wlan0 essid doubletap
# dhclient wlan0

Complete net profile:

$ cat /etc/network.d/a
CONNECTION='wireless'
DESCRIPTION='doubletap'

INTERFACE='wlan0'

IP='dhcp'

# Standard Wireless Settings
ESSID='doubletap'
SECURITY='wpa' 
KEY='networkkey'
SCAN='no'

netcfg version

netcfg v2.5.0rc1

lsmod:

# lsmod
Module                  Size  Used by
iwl3945                68465  0 
iwlcore                82082  1 iwl3945
mac80211              147565  2 iwl3945,iwlcore
cfg80211              106631  3 iwl3945,iwlcore,mac80211
rfkill                 12320  1 cfg80211
ipv6                  237660  18 
ext2                   56431  1 
snd_seq_dummy           1099  0 
snd_seq_oss            25304  0 
snd_seq_midi_event      4452  1 snd_seq_oss
arc4                    1058  2 
snd_seq                42628  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          4313  3 snd_seq_dummy,snd_seq_oss,snd_seq
ecb                     1545  2 
snd_hda_codec_conexant    19549  1 
uvcvideo               54623  0 
videodev               31763  1 uvcvideo
v4l1_compat            13478  2 uvcvideo,videodev
firewire_ohci          20234  0 
firewire_core          37529  1 firewire_ohci
snd_pcm_oss            33725  0 
snd_hda_intel          18665  0 
snd_hda_codec          56728  2 snd_hda_codec_conexant,snd_hda_intel
sdhci_pci               4910  0 
sdhci                  13921  1 sdhci_pci
joydev                  7768  0 
mmc_core               45164  1 sdhci
snd_hwdep               5102  1 snd_hda_codec
snd_mixer_oss          14810  1 snd_pcm_oss
crc_itu_t               1041  1 firewire_core
wmi                     4083  0 
video                  14871  0 
output                  1404  1 video
battery                 7328  0 
ac                      2255  0 
button                  3638  0 
thermal                 9326  0 
ricoh_mmc               2661  0 
led_class               1933  3 iwl3945,iwlcore,sdhci
uhci_hcd               19092  0 
snd_pcm                57479  3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
iTCO_wdt                6745  0 
iTCO_vendor_support     1453  1 iTCO_wdt
intel_agp              23157  0 
nvidia               8788899  0 
snd_timer              16117  2 snd_seq,snd_pcm
ehci_hcd               31434  0 
psmouse                55619  0 
agpgart                23331  2 intel_agp,nvidia
snd                    43847  11 snd_seq_oss,snd_seq,snd_seq_device,snd_hda_codec_conexant,snd_pcm_oss,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_mixer_oss,snd_pcm,snd_timer
i2c_i801                7122  0 
sg                     20887  0 
evdev                   6970  15 
pcspkr                  1347  0 
usbcore               118825  4 uvcvideo,uhci_hcd,ehci_hcd
soundcore               5007  1 snd
snd_page_alloc          5809  2 snd_hda_intel,snd_pcm
serio_raw               3620  0 
i2c_core               15369  3 videodev,nvidia,i2c_i801
e1000e                112963  0 
cpufreq_conservative     5100  0 
cpufreq_powersave        646  0 
cpufreq_ondemand        6865  0 
acpi_cpufreq            5599  0 
freq_table              1955  2 cpufreq_ondemand,acpi_cpufreq
processor              25790  3 acpi_cpufreq
rtc_cmos                7504  0 
rtc_core               12011  1 rtc_cmos
rtc_lib                 1450  1 rtc_core
ext3                  113015  2 
jbd                    38906  1 ext3
mbcache                 4278  2 ext2,ext3
sr_mod                 13193  0 
cdrom                  31625  1 sr_mod
sd_mod                 24101  4 
ata_piix               17757  0 
ahci                   29290  3 
ata_generic             2235  0 
libata                135162  3 ata_piix,ahci,ata_generic
scsi_mod               78924  4 sg,sr_mod,sd_mod,libata

iwconfig:

# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abg  Mode:Managed  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

Last edited by rson451 (2009-12-07 02:10:28)


archlinux - please read this and this — twice — then ask questions.
--
http://rsontech.net | http://github.com/rson

Offline

#21 2009-12-07 04:21:25

Tyriel
Member
From: Melbourne, Australia
Registered: 2009-01-20
Posts: 161
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Hey rson451, when I was dealing with my issue I remember reading that wpa supplicant has issues with hidden networks.  Considering much of netcfg is based around it now, this could be your problem.  I remember seeing a possible solution to it and will post it if I can find it again.  In the mean time you could try testing if it works in a non-hidden network (if possible).


The software required Windows XP or better, so I installed archlinux.

Offline

#22 2009-12-07 04:25:18

Tyriel
Member
From: Melbourne, Australia
Registered: 2009-01-20
Posts: 161
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

I found the content below in the arch wiki page here: http://wiki.archlinux.org/index.php/WPA_supplicant.  I hope this solves you problem.

Another common problem is No suitable AP found messages. Wpa_supplicant seems to have trouble finding hidden essids. Usually setting scan_ssid=1 in your network block will take care of this.


The software required Windows XP or better, so I installed archlinux.

Offline

#23 2009-12-07 12:43:32

rson451
Member
From: Annapolis, MD USA
Registered: 2007-04-15
Posts: 1,233
Website

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

The issue is that the wpa.conf that netcfg is using is automatically generated by netcfg on the fly.  This auto-generated wpa.conf indeed lets me connect when I use it to start wpa_supplicant manually, I thnk there may be another issue somewhere.

Tyriel wrote:

I found the content below in the arch wiki page here: http://wiki.archlinux.org/index.php/WPA_supplicant.  I hope this solves you problem.

Interestingly enough, broadcasting the ssid and changing SCAN from 'no' to 'yes' allows me to connect with the net profile above.  This is obviously a workaround, but it's an easier workaround than the above for now I suppose.


archlinux - please read this and this — twice — then ask questions.
--
http://rsontech.net | http://github.com/rson

Offline

#24 2009-12-07 21:19:14

Pank
Member
From: IT
Registered: 2009-06-13
Posts: 370

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

alexandrite wrote:

It looks like the way that netcfg builds wpa_supplicant config files for non-secured networks lacks a default value, so if you have any un-encrypted network profiles defined, then wpa_supplicant will barf when it tries to parse the config file netcfg generates.

Try adding

SECURITY="none"

to the end of any nonsecured profile.  This fixed it for me.

Hello,
I tried SECURITY="none" but it didn't seem to work. I have
SECURITY="wpa-config" in my profile (posted above).

This is a WPA-PSK connection.

--Rasmus


Arch x64 on Thinkpad X200s/W530

Offline

#25 2009-12-08 00:49:44

alexandrite
Member
Registered: 2009-03-27
Posts: 326

Re: [testing] netcfg v2.5.0rc1 - note: auto-wireless configuration changed

Pank wrote:
alexandrite wrote:

It looks like the way that netcfg builds wpa_supplicant config files for non-secured networks lacks a default value, so if you have any un-encrypted network profiles defined, then wpa_supplicant will barf when it tries to parse the config file netcfg generates.

Try adding

SECURITY="none"

to the end of any nonsecured profile.  This fixed it for me.

Hello,
I tried SECURITY="none" but it didn't seem to work. I have
SECURITY="wpa-config" in my profile (posted above).

This is a WPA-PSK connection.

--Rasmus

What's the entire auto-generated wpa.conf look like?

Last edited by alexandrite (2009-12-08 01:14:35)

Offline

Board footer

Powered by FluxBB