You are not logged in.

#1 2010-04-09 17:03:58

cl10k
Member
From: Germany
Registered: 2008-12-24
Posts: 92

[SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

Hello,

some minutes ago I tried to update my system. The pacman-update seems to be broken. Every time I try to use pacman (even basics like -Qi) it gives me:

pacman: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory


Here's  the log:

upgraded pacman (3.3.3-1 -> 3.3.3-5)
upgraded gtk2 (2.20.0-1 -> 2.20.0-2)
upgraded openssl (0.9.8n-1 -> 1.0.0-2)
upgraded xorg-server (1.7.5.902-1 -> 1.7.6-3)

I have no idea what to do? No clue how to downgrade without pacman...

Please help

cl10k

PS: I'm NOT using testing...

Last edited by cl10k (2010-04-10 15:59:20)

Offline

#2 2010-04-09 17:09:11

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

First tell us how did you manage to do this? A -Syu shouldn't cause that. Is that really the complete log?

Offline

#3 2010-04-09 17:37:33

smart2128
Member
Registered: 2010-04-09
Posts: 9

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

I can confirm that openssl upgrade caused many issues (firefox flash plugin, yaourt , etc.).
As a workaround, I linked the following libs :

/usr/lib/libssl.so.0.9.8 -> /usr/lib/libssl.so
/usr/lib/libcrypto.so.0.9.8 -> /usr/lib/libcrypto.so

but there is something still broken.

Regards,
Vincenzo

Offline

#4 2010-04-09 17:41:36

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

smart2128 wrote:

I can confirm that openssl upgrade caused many issues (firefox flash plugin, yaourt , etc.).
As a workaround, I linked the following libs :

/usr/lib/libssl.so.0.9.8 -> /usr/lib/libssl.so
/usr/lib/libcrypto.so.0.9.8 -> /usr/lib/libcrypto.so

but there is something still broken.

Regards,
Vincenzo

this workaround should be ignored. anyone else that have this problem, just be sure you are fully update. a simple pacman -Syu should fix your problems.


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#5 2010-04-09 17:53:01

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

hi same here

even with pacman -Syu it is broken

[root@]# pacman -Syu
pacman: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory
[root@#

Serge

Offline

#6 2010-04-09 17:56:29

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

You very likely did something wrong in the first place.

Offline

#7 2010-04-09 18:12:26

csergec
Member
Registered: 2009-09-29
Posts: 62

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

What smart2128 did did not work for me

I did a

ln -sf /usr/lib/libssl.so.1.0.0 /usr/lib/libssl.so.0.9.8
ln -sf /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.0.9.8

and it works now.
I mean I cant do now a pacman -Syu

If something else is broken I do now know right now

Serge

Offline

#8 2010-04-09 18:15:18

windowbreaker
Member
Registered: 2008-06-18
Posts: 46

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

I wonder if this sort of problem could be caused by installing a package without syncing the database, after your database is out of date.  Something like

pacman -S <pkg_name>
pacman -Su

Doing that sort of thing bit me when I started with Arch.

Offline

#9 2010-04-09 18:19:28

smart2128
Member
Registered: 2010-04-09
Posts: 9

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

csergec wrote:

What smart2128 did did not work for me

I did a

ln -sf /usr/lib/libssl.so.1.0.0 /usr/lib/libssl.so.0.9.8
ln -sf /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.0.9.8

and it works now.
I mean I cant do now a pacman -Syu

If something else is broken I do now know right now

Serge

Wonder was right, this isn't the proper way to solve that issue.
I just pointed the attention on the openssl update.
You did exactly what I wrote because /usr/lib/libssl.so.1.0.0 is a symlink to /usr/lib/libssl.so

I solved the problem visiting https://users.archlinux.de/~gerbra/mirrorcheck.html and using the last synced mirror in mirrorlist.

Regards,
Vincenzo

Last edited by smart2128 (2010-04-10 07:35:27)

Offline

#10 2010-04-09 18:30:16

cl10k
Member
From: Germany
Registered: 2008-12-24
Posts: 92

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

STOP! Please :-)

Originally I wanted to make a "pacman -Syu", but when I saw the amount of updates i decided to "pacman -S" only gtk2 and xorg-server.

Right after the upgrade of xorg, pacman refused to work. Here the full log:

[2010-04-09 17:44] synchronizing package lists
[2010-04-09 17:47] upgraded pacman (3.3.3-1 -> 3.3.3-5)
[2010-04-09 18:14] synchronizing package lists
[2010-04-09 18:15] starting full system upgrade
[2010-04-09 18:15] upgraded gtk2 (2.20.0-1 -> 2.20.0-2)
[2010-04-09 18:18] synchronizing package lists
[2010-04-09 18:18] starting full system upgrade
[2010-04-09 18:19] warning: /etc/ssl/openssl.cnf installed as /etc/ssl/openssl.cnf.pacnew
[2010-04-09 18:19] upgraded openssl (0.9.8n-1 -> 1.0.0-2)
[2010-04-09 18:19] upgraded xorg-server (1.7.5.902-1 -> 1.7.6-3)

Last edited by cl10k (2010-04-09 18:31:26)

Offline

#11 2010-04-09 18:36:21

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

and that messed up your system while -Syu would have just worked. pacman -Sy <some app> is always dangerous.

Btw: The maintainer of xorg-server should get punched for using a versioned dep to openssl. (Maybe it's a good idea for real; talking about it and asking them to not use versioned deps doesn't seem to help)

Offline

#12 2010-04-09 18:42:14

fsss
Member
Registered: 2010-04-09
Posts: 11

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

smart2128 wrote:

(firefox flash plugin, yaourt , etc.).

Hi, after today's update flashplugin stopped working for me. It crashes whenever I try to play videos for example on youtube, but flash ads work fine... I have tested on several browsers. Do you think that this is related with openssl? I could try to downgrade openssl, but it has many dependencies (xorg-server). I attach a fragment of /var/log/pacman.log

[2010-04-09 13:35] synchronizing package lists
[2010-04-09 13:41] upgraded pacman (3.3.3-4 -> 3.3.3-5)
[2010-04-09 13:41] synchronizing package lists
[2010-04-09 15:29] synchronizing package lists
[2010-04-09 15:30] starting full system upgrade
[2010-04-09 16:14] warning: /etc/ssl/openssl.cnf installed as /etc/ssl/openssl.cnf.pacnew
[2010-04-09 16:14] upgraded openssl (0.9.8n-1 -> 1.0.0-2)
[2010-04-09 16:14] upgraded aircrack-ng (1.0-2 -> 1.0-3)
[2010-04-09 16:14] upgraded bash (4.1.002-2 -> 4.1.005-1)
[2010-04-09 16:14] Clearing symlinks in /etc/ssl/certs...done.
[2010-04-09 16:14] Updating certificates in /etc/ssl/certs... 141 added, 0 removed; done.
[2010-04-09 16:14] Running hooks in /etc/ca-certificates/update.d....
[2010-04-09 16:14] updating keystore /etc/ssl/certs/java/cacerts...
[2010-04-09 16:14]   added: /etc/ssl/certs/brasil.gov.br.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/cacert.org.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/ca.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/cert_igca_dsa.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/cert_igca_rsa.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/ABAecom_=sub.__Am._Bankers_Assn.=_Root_CA.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/AOL_Time_Warner_Root_Certification_Authority_1.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/AOL_Time_Warner_Root_Certification_Authority_2.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/AddTrust_External_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/AddTrust_Low-Value_Services_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/AddTrust_Public_Services_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/AddTrust_Qualified_Certificates_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/America_Online_Root_Certification_Authority_1.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/America_Online_Root_Certification_Authority_2.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Baltimore_CyberTrust_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/COMODO_Certification_Authority.pem
[2010-04-09 16:14]   ignored import, signature not available: /etc/ssl/certs/COMODO_ECC_Certification_Authority.pem
[2010-04-09 16:14] keytool error: java.security.NoSuchAlgorithmException: SHA384withECDSA Signature not available
[2010-04-09 16:14]   added: /etc/ssl/certs/Camerfirma_Chambers_of_Commerce_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Camerfirma_Global_Chambersign_Root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Certplus_Class_2_Primary_CA.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Certum_Root_CA.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Comodo_AAA_Services_root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Comodo_Secure_Services_root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Comodo_Trusted_Services_root.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/DST_ACES_CA_X6.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/DST_Root_CA_X3.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/DigiCert_Assured_ID_Root_CA.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/DigiCert_Global_Root_CA.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/DigiCert_High_Assurance_EV_Root_CA.pem
[2010-04-09 16:14]   already exists: /etc/ssl/certs/DigiNotar_Root_CA.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Digital_Signature_Trust_Co._Global_CA_1.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Digital_Signature_Trust_Co._Global_CA_2.pem
[2010-04-09 16:14]   added: /etc/ssl/certs/Digital_Signature_Trust_Co._Global_CA_3.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Digital_Signature_Trust_Co._Global_CA_4.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Entrust.net_Global_Secure_Personal_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Entrust.net_Global_Secure_Server_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Entrust.net_Premium_2048_Secure_Server_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Entrust.net_Secure_Personal_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Entrust.net_Secure_Server_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Entrust_Root_Certification_Authority.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Equifax_Secure_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Equifax_Secure_Global_eBusiness_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Equifax_Secure_eBusiness_CA_1.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Equifax_Secure_eBusiness_CA_2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Firmaprofesional_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GTE_CyberTrust_Global_Root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GTE_CyberTrust_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GeoTrust_Global_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GeoTrust_Global_CA_2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GeoTrust_Primary_Certification_Authority.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GeoTrust_Universal_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GeoTrust_Universal_CA_2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GlobalSign_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/GlobalSign_Root_CA_-_R2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Go_Daddy_Class_2_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_CLASE1_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_CLASE3_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_CLASEA1_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_CLASEA3_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_Chained_CAs_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_Servidores_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/IPS_Timestamping_root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/NetLock_Business_=Class_B=_Root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/NetLock_Express_=Class_C=_Root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/NetLock_Notary_=Class_A=_Root.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/NetLock_Qualified_=Class_QA=_Root.pem
[2010-04-09 16:15]   already exists: /etc/ssl/certs/Network_Solutions_Certificate_Authority.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/QuoVadis_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/QuoVadis_Root_CA_2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/QuoVadis_Root_CA_3.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/RSA_Root_Certificate_1.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/RSA_Security_1024_v3.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/RSA_Security_2048_v3.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/SecureTrust_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Secure_Global_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Security_Communication_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Sonera_Class_1_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Sonera_Class_2_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Staat_der_Nederlanden_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Starfield_Class_2_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/StartCom_Certification_Authority.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/StartCom_Ltd..pem
[2010-04-09 16:15]   added: /etc/ssl/certs/SwissSign_Gold_CA_-_G2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/SwissSign_Platinum_CA_-_G2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/SwissSign_Silver_CA_-_G2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Swisscom_Root_CA_1.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/TC_TrustCenter__Germany__Class_2_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/TC_TrustCenter__Germany__Class_3_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/TDC_Internet_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/TDC_OCES_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/TURKTRUST_Certificate_Services_Provider_Root_1.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/TURKTRUST_Certificate_Services_Provider_Root_2.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Taiwan_GRCA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Thawte_Personal_Basic_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Thawte_Personal_Freemail_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Thawte_Personal_Premium_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Thawte_Premium_Server_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Thawte_Server_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/Thawte_Time_Stamping_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/UTN-USER_First-Network_Applications.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/UTN_DATACorp_SGC_Root_CA.pem
[2010-04-09 16:15]   added: /etc/ssl/certs/UTN_USERFirst_Email_Root_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/UTN_USERFirst_Hardware_Root_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/ValiCert_Class_1_VA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/ValiCert_Class_2_VA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/VeriSign_Class_3_Public_Primary_Certification_Authority_-_G5.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_1_Public_Primary_Certification_Authority.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_1_Public_Primary_Certification_Authority_-_G2.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_1_Public_Primary_Certification_Authority_-_G3.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_2_Public_Primary_Certification_Authority.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_2_Public_Primary_Certification_Authority_-_G2.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_2_Public_Primary_Certification_Authority_-_G3.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_3_Public_Primary_Certification_Authority.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_3_Public_Primary_Certification_Authority_-_G2.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_3_Public_Primary_Certification_Authority_-_G3.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_4_Public_Primary_Certification_Authority_-_G2.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Class_4_Public_Primary_Certification_Authority_-_G3.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_RSA_Secure_Server_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Verisign_Time_Stamping_Authority_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Visa_International_Global_Root_2.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Visa_eCommerce_Root.pem
[2010-04-09 16:16]   already exists: /etc/ssl/certs/WellsSecure_Public_Root_Certificate_Authority.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/Wells_Fargo_Root_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/XRamp_Global_CA_Root.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/beTRUSTed_Root_CA-Baltimore_Implementation.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/beTRUSTed_Root_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/beTRUSTed_Root_CA_-_Entrust_Implementation.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/beTRUSTed_Root_CA_-_RSA_Implementation.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/thawte_Primary_Root_CA.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_ca1_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_ca2_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_ca3_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_ocspklasa2_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_ocspklasa3_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_pca2_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_pca3_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_rootca_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/signet_tsa1_pem.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/spi-ca-2003.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/spi-cacert-2008.pem
[2010-04-09 16:16]   added: /etc/ssl/certs/deutsche-telekom-root-ca-2.pem
[2010-04-09 16:16] done.
[2010-04-09 16:16] done.
[2010-04-09 16:16] upgraded ca-certificates (20090814-2 -> 20090814-3)
[2010-04-09 16:16] upgraded qt (4.6.2-2 -> 4.6.2-3)
[2010-04-09 16:16] upgraded attica (0.1.2-1 -> 0.1.3-1)
[2010-04-09 16:16] upgraded curl (7.20.0-1 -> 7.20.0-4)
[2010-04-09 16:16] upgraded cmake (2.8.1-1 -> 2.8.1-2)
[2010-04-09 16:16] upgraded cpio (2.10-1 -> 2.11-2)
[2010-04-09 16:16] upgraded heimdal (1.3.1-3 -> 1.3.2-1)
[2010-04-09 16:16] upgraded libcups (1.4.3-1 -> 1.4.3-2)
[2010-04-09 16:16] upgraded openslp (1.2.1-2 -> 1.2.1-3)
[2010-04-09 16:16] upgraded cups (1.4.3-1 -> 1.4.3-2)
[2010-04-09 16:16] upgraded cvs (1.11.23-4 -> 1.11.23-5)
[2010-04-09 16:16] upgraded dnsutils (9.6.1-2 -> 9.6.1-3)
[2010-04-09 16:16] upgraded icu (4.2.1-1 -> 4.4-1)
[2010-04-09 16:17] upgraded gtk2 (2.20.0-1 -> 2.20.0-2)
[2010-04-09 16:17] upgraded libwebkit (1.1.90-1 -> 1.2.0-1)
[2010-04-09 16:17] upgraded epiphany (2.30.0-1 -> 2.30.2-1)
[2010-04-09 16:17] upgraded evolution-data-server (2.30.0-1 -> 2.30.0-2)
[2010-04-09 16:17] upgraded evolution-exchange (2.30.0-1 -> 2.30.0-2)
[2010-04-09 16:17] upgraded python (2.6.5-2 -> 2.6.5-3)
[2010-04-09 16:17] upgraded exaile (0.3.1.0-1 -> 0.3.1.1-1)
[2010-04-09 16:17] upgraded git (1.7.0.3-1 -> 1.7.0.4-1)
[2010-04-09 16:17] upgraded gkrellm (2.3.4-2 -> 2.3.4-3)
[2010-04-09 16:17] upgraded libldap (2.4.21-1 -> 2.4.21-2)
[2010-04-09 16:17] upgraded smbclient (3.5.1-1 -> 3.5.2-1)
[2010-04-09 16:17] upgraded gnome-vfs (2.24.3-1 -> 2.24.3-2)
[2010-04-09 16:17] upgraded gpac (0.4.5-4 -> 0.4.5-5)
[2010-04-09 16:17] upgraded gstreamer0.10-bad (0.10.18-2 -> 0.10.18-3)
[2010-04-09 16:17] upgraded neon (0.28.6-2 -> 0.28.6-4)
[2010-04-09 16:17] upgraded gstreamer0.10-bad-plugins (0.10.18-2 -> 0.10.18-3)
[2010-04-09 16:17] upgraded gtkmm (2.20.0-1 -> 2.20.1-1)
[2010-04-09 16:17] upgraded net-snmp (5.5-2 -> 5.5-3)
[2010-04-09 16:17] 
[2010-04-09 16:17] NOTE
[2010-04-09 16:17] ----
[2010-04-09 16:17] # If you want to use this driver with sane:
[2010-04-09 16:17] #  echo "hpaio" >> /etc/sane.d/dll.conf
[2010-04-09 16:17] 
[2010-04-09 16:17] 
[2010-04-09 16:17] UPGRADING
[2010-04-09 16:17] ----
[2010-04-09 16:17] # This version no longer uses an init script. You should remove hplip
[2010-04-09 16:17] # from the /etc/rc.conf daemon list.
[2010-04-09 16:17] 
[2010-04-09 16:17] upgraded hplip (3.9.12-5 -> 3.10.2-1)
[2010-04-09 16:17] upgraded kernel26-firmware (2.6.32.10-1 -> 2.6.33.2-1)
[2010-04-09 16:17] warning: directory permissions differ on boot/
filesystem: 555  package: 755
[2010-04-09 16:17] >>> Updating module dependencies. Please wait ...
[2010-04-09 16:17] >>> MKINITCPIO SETUP
[2010-04-09 16:17] >>> ----------------
[2010-04-09 16:17] >>> If you use LVM2, Encrypted root or software RAID,
[2010-04-09 16:17] >>> Ensure you enable support in /etc/mkinitcpio.conf .
[2010-04-09 16:17] >>> More information about mkinitcpio setup can be found here:
[2010-04-09 16:17] >>> http://wiki.archlinux.org/index.php/Mkinitcpio
[2010-04-09 16:17] 
[2010-04-09 16:17] >>> Generating initial ramdisk, using mkinitcpio.  Please wait...
[2010-04-09 16:17] ==> Building image "default"
[2010-04-09 16:17] ==> Running command: /sbin/mkinitcpio -k 2.6.33-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26-30.img
[2010-04-09 16:17] :: Begin build
[2010-04-09 16:17] :: Parsing hook [base]
[2010-04-09 16:17] :: Parsing hook [udev]
[2010-04-09 16:17] :: Parsing hook [autodetect]
[2010-04-09 16:17] :: Parsing hook [pata]
[2010-04-09 16:18] :: Parsing hook [scsi]
[2010-04-09 16:18] :: Parsing hook [sata]
[2010-04-09 16:18] :: Parsing hook [filesystems]
[2010-04-09 16:18] :: Generating module dependencies
[2010-04-09 16:18] :: Generating image '/boot/kernel26-30.img'...SUCCESS
[2010-04-09 16:18] ==> SUCCESS
[2010-04-09 16:18] ==> Building image "fallback"
[2010-04-09 16:18] ==> Running command: /sbin/mkinitcpio -k 2.6.33-ARCH -c /etc/mkinitcpio.conf -g /boot/kernel26-fallback.img -S autodetect
[2010-04-09 16:18] :: Begin build
[2010-04-09 16:18] :: Parsing hook [base]
[2010-04-09 16:18] :: Parsing hook [udev]
[2010-04-09 16:18] :: Parsing hook [pata]
[2010-04-09 16:18] :: Parsing hook [scsi]
[2010-04-09 16:18] :: Parsing hook [sata]
[2010-04-09 16:18] :: Parsing hook [filesystems]
[2010-04-09 16:18] :: Generating module dependencies
[2010-04-09 16:18] :: Generating image '/boot/kernel26-fallback.img'...SUCCESS
[2010-04-09 16:18] ==> SUCCESS
[2010-04-09 16:18] upgraded kernel26 (2.6.32.10-1 -> 2.6.33.2-1)
[2010-04-09 16:18] upgraded kernel26-headers (2.6.32.10-1 -> 2.6.33.2-1)
[2010-04-09 16:18] upgraded lastfm-client (1.5.4.26862-1 -> 1.5.4.26862-2)
[2010-04-09 16:18] upgraded libarchive (2.8.3-1 -> 2.8.3-3)
[2010-04-09 16:18] upgraded libdrm (2.4.18-2 -> 2.4.19-1)
[2010-04-09 16:18] upgraded libfetch (2.30-1 -> 2.30-3)
[2010-04-09 16:18] upgraded libgnomecups (0.2.3-6 -> 0.2.3-7)
[2010-04-09 16:18] upgraded libgnomeprint (2.18.7-1 -> 2.18.7-2)
[2010-04-09 16:18] upgraded libssh (0.4.1-1 -> 0.4.1-3)
[2010-04-09 16:18] upgraded libtorrent (0.12.6-1 -> 0.12.6-2)
[2010-04-09 16:18] upgraded mesa (7.7.1-0.1 -> 7.7.1-1)
[2010-04-09 16:18] if you are running kms in early mode please rebuild your initrd
[2010-04-09 16:18] upgraded nouveau-drm (0.0.15_20100212-1 -> 0.0.16_20100313-1)
[2010-04-09 16:18] warning: directory permissions differ on var/lib/ntop/rrd/
filesystem: 700  package: 755
[2010-04-09 16:18] upgraded ntop (3.3.10-2 -> 3.3.10-3)
[2010-04-09 16:18] upgraded ntp (4.2.6-2 -> 4.2.6-3)
[2010-04-09 16:18] In order to use the new nvidia module, exit Xserver and unload it manually.
[2010-04-09 16:18] upgraded nvidia (195.36.15-1 -> 195.36.15-2)
[2010-04-09 16:19]  * check /etc/profile.d/openoffice.sh, then relogin or "source" the file
[2010-04-09 16:19]  * see http://wiki.archlinux.org/index.php/Openoffice
[2010-04-09 16:19]    how to use extensions, e.g. for spell checking
[2010-04-09 16:19]    see /usr/lib/openoffice/share/extension/install what
[2010-04-09 16:19]    is shipped with this package
[2010-04-09 16:19]  * make sure you have installed a ttf font (ttf-dejavu recommended)
[2010-04-09 16:19] upgraded openoffice-base (3.2.0-1 -> 3.2.0-3)
[2010-04-09 16:19] upgraded openssh (5.4p1-3 -> 5.4p1-4)
[2010-04-09 16:19] upgraded ortp (0.16.1-1 -> 0.16.1-2)
[2010-04-09 16:19] upgraded php (5.3.2-4 -> 5.3.2-6)
[2010-04-09 16:19] upgraded postgresql-libs (8.4.3-1 -> 8.4.3-2)
[2010-04-09 16:19] upgraded proxytunnel (1.9.0-1 -> 1.9.0-2)
[2010-04-09 16:19] upgraded pulseaudio (0.9.21-4 -> 0.9.21-5)
[2010-04-09 16:19] upgraded subversion (1.6.9-2 -> 1.6.9-4)
[2010-04-09 16:19] upgraded syslog-ng (3.0.4-3 -> 3.0.4-4)
[2010-04-09 16:19] upgraded telepathy-glib (0.10.2-1 -> 0.10.3-1)
[2010-04-09 16:19] upgraded testdisk (6.11.3-2 -> 6.11.3-3)
[2010-04-09 16:19] upgraded virtuoso (6.1.0-1 -> 6.1.0-2)
[2010-04-09 16:19] upgraded wget (1.12-1 -> 1.12-2)
[2010-04-09 16:19] upgraded wpa_supplicant (0.6.10-1 -> 0.6.10-2)
[2010-04-09 16:19] upgraded xchat (2.8.6-5 -> 2.8.6-6)
[2010-04-09 16:19] upgraded xf86-video-nouveau (0.0.15_git20100221-1 -> 0.0.15_git20100314-1)
[2010-04-09 16:19] upgraded xf86-video-vesa (2.2.1-1 -> 2.3.0-1)
[2010-04-09 16:19] upgraded xorg-server (1.7.5.902-1 -> 1.7.6-3)

Offline

#13 2010-04-09 18:56:09

cl10k
Member
From: Germany
Registered: 2008-12-24
Posts: 92

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

Could you please be so polite and stop spamming my thread with your problems?!

I would prefer to have my problem sorted here - your free to open your own threads...

Pierre, any ideas how to solve that problem?

Offline

#14 2010-04-09 19:02:21

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,950
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

There are several methods. It might work if you temporary create those symlinks mentioned above and run "pacman -S libarchive libfetch pacman", remove the symlinks again and run pacman -Syu.

If those symlinks wont work you could manually download the libarchive and libfetch package and extract them to / using tar (remove the .PKG* and .INSTALL files in / afterwards). Now run pacman -Sf libarchive libfetch and then pacman -Syu.

Offline

#15 2010-04-09 19:07:17

cl10k
Member
From: Germany
Registered: 2008-12-24
Posts: 92

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

I'm not that experienced with linux/commandline but I think I try the symlinks-way first, it sounds easier to me...

Offline

#16 2010-04-09 19:35:15

cl10k
Member
From: Germany
Registered: 2008-12-24
Posts: 92

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

I think it works now. Thank you Pierre and thank you smart2128/csergec for the symlinks!

A general question about updating:

Usually I just run pacman -Syu daily and and don't fuss with the updates in any other way.
But today there were 48 updates including cups, hplip and texlive which are very important for me. How do you handle big updates with lots of packages? I thought it would be easy to update step by step during the next days and check if one update after another works... What is the savest way to update such a big amount?

Offline

#17 2010-04-09 19:42:05

brisbin33
Member
From: boston, ma
Registered: 2008-07-24
Posts: 1,796
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

My thoughts?

cherry picking packages is always a bad idea (and -Sy <package> should _never_ be done).  update daily and fully.  deal with problems as they arise.  since arch is rolling release, the repos/packages have to be maintained under the assumption that everyone is fully up to date at all times.  if you stay away from [testing] it is very very rare that an update will break anything*.

*two caveats here: aur packages and out of date/half-synced mirrors.  both can be solved with a rebuild or a new-mirror, -Syyu respectively.

Offline

#18 2010-04-09 19:44:31

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,723

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

The safest way is "pacman -Syu"!  Any other way is likely to break something or other.  I just updated 56 packages without an issue.  The problem may be that your mirrors are not in sync or you are using packages from the AUR which have not been updated.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#19 2010-04-09 20:04:13

alphazo
Member
Registered: 2009-10-20
Posts: 155

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

This happened to me when in the middle of this 1.3GB upgrade I hit ctrl+c as I wanted to copy the content of the terminal window sad (I know it's a pretty bad idea). Then I tried to pacman again but it needed openssl-0.9.8. I then created a symlink to new libssl-1.0 and libcrypto-1.0 and was able to continue my upgrade. In the end I removed the temporary symlinks and apparently I'm back on tracks.

cd /usr/lib
ln -s libssl.so.1.0.0 libssl.so.9.8
ln -s libcrypto.so.1.0.0 libcrypto.so.0.9.8

Offline

#20 2010-04-09 20:48:08

BxS
Member
From: Portugal
Registered: 2009-04-05
Posts: 24

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

This is quite funny, some days ago I did:

[bxs@arch03 ~]$ sudo powerpill -S testing/{kernel26{,-firmware,-headers},libdrm,mesa,libgl,ati-dri,xf86-video-ati,xorg-server}

And I found myself in the same situation, I found that the problem was because of xorg-server that installed a new openssl as dependency, the big problem was that pacman also didn't work.

But not a big problem, these days a always have a recent backup of my system (thanks to rsync) I just copied the files of libssl and libcrypt to get pacman functional and with pacman repaired the damaged ;-)

Offline

#21 2010-04-09 21:27:51

renuvio
Member
Registered: 2008-10-25
Posts: 49

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

Oops, i was in the middle of a 'pacman -Syu' as i do every day, and there was a power outage that let me with a similar scenario here, solved with the temporary linking of that two libs.

Thanks to help me to solve this problem too.

Offline

#22 2010-04-10 00:50:57

mrunion
Member
From: Jonesborough, TN
Registered: 2007-01-26
Posts: 1,611
Website

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

As for Flash not working -- if you have libssh2 from AUR you need to rebuild it AFTER you upgrade today's openssl package. That can cause Flash to fail and take Firefox with it! (I got bit by it today!)


Matt

"It is very difficult to educate the educated."

Offline

#23 2010-04-10 00:54:05

pogeymanz
Member
Registered: 2008-03-11
Posts: 1,020

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

Ugh. I guess I broke something good. I did the quick and dirty symlink trick mentioned above and updated again, which didn't update anything important. Then I deleted the symlink, or so I thought...

rm /usr/lib/libssl.so.9.8

But then I realized that was just gonna delete the libssl.so.1.0.0 file. AWESOME.

Does anybody just have the 64bit libssl.so.1.0.0 file they want to send me so I can just drop it into the directory and pray?

Ha. Nevermind. I fixed it by extracting the cached package and just dropping the files into the proper directory after destroying those stupid symlinks.

Even as much as I screw stuff up, I'll never have to reinstall this distro.

Last edited by pogeymanz (2010-04-10 01:46:44)

Offline

#24 2010-04-10 09:42:32

sergi34
Member
Registered: 2010-01-20
Posts: 23

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

wow same problem here but solved using the symbolic links from 1.0.0 to 0.9.8 and then revert to old version with

pacman -U /var/cache/pacman/pkg/openssl-0.9.8n-1-x86_64.pkg.tar.xz

then pacman -Syu and everything ok.

I got to the problem by upgrading just openssl by

pacman -S openssl

that was because i installed Apache and it complained when started that was broken mod_ssl and libssl and it needed openssl-1.0.0

thanks for the symbolic links trick!! wink

Last edited by sergi34 (2010-04-10 09:43:28)

Offline

#25 2010-04-10 11:01:44

fsss
Member
Registered: 2010-04-09
Posts: 11

Re: [SOLVED] pacman: error while loading shared libraries: libssl.so.0.9.8

cl10k wrote:

I would prefer to have my problem sorted here - your free to open your own threads...

You are right, sorry.
But, I just want mention that my problem with flash (with quake live plugin too) was also caused by openssl. I struggled with it since yesterday and I found that package openssl-compatibility (which includes libssl and libcrypto 0.9.8 libs) from AUR fixes it smile

Offline

Board footer

Powered by FluxBB