You are not logged in.

#1 2011-12-19 06:27:57

Vitechy
Member
Registered: 2010-06-29
Posts: 10

[SOLVED] Infinality Font Configuration

I recently installed the Infinality patchsat {freetype2-git-infinality} and the corresponding Windows 7 fonts {ttf-win7-fonts} packet and ever since I have not had any fonts available other than the ones which were installed with the ttf-win7-fonts package.

Passing fc-cache -f -v returns

[zadmin@zlaptop artwiz-fonts]$ fc-cache -f -v
/usr/share/fonts: caching, new cache contents: 0 fonts, 10 dirs
/usr/share/fonts/100dpi: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/75dpi: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/TTF: caching, new cache contents: 130 fonts, 0 dirs
/usr/share/fonts/Type1: caching, new cache contents: 35 fonts, 0 dirs
/usr/share/fonts/artwiz-fonts: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cantarell: caching, new cache contents: 2 fonts, 0 dirs
/usr/share/fonts/cyrillic: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/misc: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/util: caching, new cache contents: 0 fonts, 0 dirs
/home/zadmin/.fonts: skipping, no such directory
/var/cache/fontconfig: not cleaning unwritable cache directory
/home/zadmin/.fontconfig: cleaning cache directory
fc-cache: succeeded

I also don't understand why it is reporting that there are 0 fonts in directories when I know there are fonts. For example, in /usr/share/fonts/artwiz-fonts:

[zadmin@zlaptop ~]$ ls /usr/share/fonts/artwiz-fonts/
anorexia.de.pcf  edges.de.pcf       glisp-bold.pcf     mints-mild.se.pcf
anorexia.pcf     edges.pcf          glisp-bold.se.pcf  mints-strong.de.pcf
anorexia.se.pcf  edges.se.pcf       glisp.de.pcf       mints-strong.pcf
aqui.de.pcf      fkp.de.pcf         glisp.pcf          mints-strong.se.pcf
aqui.pcf         fkp.pcf            glisp.se.pcf       nu.de.pcf
aqui.se.pcf      fkp.se.pcf         kates.de.pcf       nu.pcf
cure.de.pcf      fonts.alias        kates.pcf          nu.se.pcf
cure.pcf         fonts.dir          kates.se.pcf       smoothansi.de.pcf
cure.se.pcf      fonts.scale        lime.de.pcf        smoothansi.pcf
cursor.pcf       gelly.de.pcf       lime.pcf           smoothansi.se.pcf
drift.de.pcf     gelly.pcf          lime.se.pcf        snap.de.pcf
drift.pcf        gelly.se.pcf       mints-mild.de.pcf  snap.pcf
drift.se.pcf     glisp-bold.de.pcf  mints-mild.pcf     snap.se.pcf

As a result any application which was using fonts not found within the Windows 7 font set displays incorrectly.

It seems that /etc/fonts/local.conf is replaced with /etc/fonts/conf.avail/52-infinality.conf and my ~/.Xresources is no longer needed. Could that have anything to do with it?

Last edited by Vitechy (2011-12-20 05:02:24)

Offline

#2 2011-12-19 07:19:30

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: [SOLVED] Infinality Font Configuration

You've probably included a fontconfig rule to ignore bitmap fonts. These are usually ignored because they look rubbish.

Offline

#3 2011-12-19 07:40:47

Vitechy
Member
Registered: 2010-06-29
Posts: 10

Re: [SOLVED] Infinality Font Configuration

I removed the 29-replace-bitmap-fonts.conf symbolic link from /etc/fonts/conf.d and received no change in results.

Do I need to enable the bitmap fonts any other way?

Last edited by Vitechy (2011-12-19 07:41:18)

Offline

#4 2011-12-19 07:53:25

brebs
Member
Registered: 2007-04-03
Posts: 3,456

Re: [SOLVED] Infinality Font Configuration

Nope.

What do you mean when you say "available"? Open e.g. a text editor and look at the list of available fonts in that.

There's also this fontconfig command:

fc-list

Offline

#5 2011-12-19 21:42:08

Vitechy
Member
Registered: 2010-06-29
Posts: 10

Re: [SOLVED] Infinality Font Configuration

When I say unavailable I mean the system cannot identify them.

Fc-list only shows only the fonts which were installed under the Win 7 package, ignoring all of the other fonts I had installed on the system.

[zlatan conf.d]$ fc-list | sed 's,:.*,,' |sort -u
Arial
Calibri
Cambria
Candara
Cantarell
Century Schoolbook L
Comic Sans MS
Consolas
Constantia
Corbel
Courier New
DejaVu LGC Sans
DejaVu LGC Sans,DejaVu LGC Sans Condensed
DejaVu LGC Sans,DejaVu LGC Sans Light
DejaVu LGC Sans Mono
DejaVu LGC Serif
DejaVu LGC Serif,DejaVu LGC Serif Condensed
DejaVu Sans
DejaVu Sans,DejaVu Sans Condensed
DejaVu Sans,DejaVu Sans Light
DejaVu Sans Mono
DejaVu Serif
DejaVu Serif,DejaVu Serif Condensed
Dingbats
DS\-Digital
FreeMono
FreeSans
FreeSerif
Gabriola
Georgia
Impact
Liberation Mono
Liberation Sans
Liberation Sans Narrow
Liberation Serif
Mangal
Nimbus Mono L
Nimbus Roman No9 L
Nimbus Sans L
Standard Symbols L
Times New Roman
Trebuchet MS
URW Bookman L
URW Chancery L
URW Gothic L
URW Palladio L
Verdana
Webdings
Wingdings

Offline

#6 2011-12-20 05:01:54

Vitechy
Member
Registered: 2010-06-29
Posts: 10

Re: [SOLVED] Infinality Font Configuration

It seems that Infinality also disables bitmap fonts in the 52-infinality.conf file. The solution is to edit the following section in /etc/fonts/conf.avail/52-infinality.conf

<!-- Reject bitmap fonts in favour of Truetype, Postscript, etc. -->
	<match target="font" >
		<test name="allow_bitmap_fonts" qual="any" >
			<bool>true</bool>
		</test>
		<test name="rendering_style" qual="any" >
			<string>Infinality</string>
			<string>Windows 7</string>
			<string>Windows XP</string>
			<string>OSX</string>
			<string>OSX2</string>
		</test>
		<selectfont>
			<rejectfont>
				<pattern>
					<patelt name="scalable" >
						<bool>false</bool>
					</patelt>
				</pattern>
			</rejectfont>
		</selectfont>
	</match>

	<!-- Substitute truetype fonts for bitmap ones -->
	<match target="pattern" >
		<test name="allow_bitmap_fonts" qual="any" >
			<bool>true</bool>
		</test>
		<test name="rendering_style" qual="any" >
			<string>Infinality</string>
			<string>Windows 7</string>
			<string>Windows XP</string>
			<string>OSX</string>
			<string>OSX2</string>
		</test>
		<edit name="prefer_outline" >
			<bool>true</bool>
		</edit>
	</match>

Offline

Board footer

Powered by FluxBB