You are not logged in.

#1 2012-02-06 20:52:22

hry218
Member
Registered: 2012-02-06
Posts: 9

[SOLVED] Driver Plugin for HP Printer : Failed to Install

Hello guys, as I stated in the tittle I'm having problem to install driver plugin for my HP P1102. The 'hplip' is from the repo not from HP website. This is the error after I downloaded the plugin "The download of the digital signature file failed." I really don't know what to do and I really hope someone could help me with the solution. BTW, I'm using KDE 4.8. If anyone want me to post any output please let me know because I don't know where to start. Thanks.

Last edited by hry218 (2012-02-09 05:33:40)

Offline

#2 2012-02-06 21:34:50

karol
Archivist
Registered: 2009-05-06
Posts: 25,432

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

Can you install the file with 'pacman -U'?

Is your system up to date? Please post your pacman.conf.

Offline

#3 2012-02-06 23:47:33

hry218
Member
Registered: 2012-02-06
Posts: 9

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

I did not know about 'pacman -U'. Yes my system is up to date. This is my pacman.conf :

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst   = pacman
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#UseDelta
#TotalDownload
CheckSpace
#VerbosePkgLists

# PGP signature checking
# NOTE: None of this will work without running `pacman-key --init` first.
# The compiled in default is equivalent to the following line. This requires
# you to locally sign and trust packager keys using `pacman-key` for them to be
# considered valid.
#SigLevel = Optional TrustedOnly
# If you wish to check signatures but avoid local sign and trust issues, use
# the following line. This will treat any key imported into pacman's keyring as
# trusted.
#SigLevel = Optional TrustAll
# For now, off by default unless you read the above.
SigLevel = Never

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[core]
#SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
#SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#SigLevel = PackageRequired
#Include = /etc/pacman.d/mirrorlist

[community]
#SigLevel = PackageOptional
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

I also tried using Cups in web interface and it looks like Cups doesn't recognized my printer.

Last edited by hry218 (2012-02-10 09:23:25)

Offline

#4 2012-02-08 01:19:59

hry218
Member
Registered: 2012-02-06
Posts: 9

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

Update : Now 'hplip' doesn't recognized my printer at all. This is the output of 'lsusb' :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 002 Device 007: ID 03f0:002a Hewlett-Packard LaserJet P1102
Bus 002 Device 004: ID 0461:4d81 Primax Electronics, Ltd 
Bus 002 Device 005: ID 0411:01d9 BUFFALO INC. (formerly MelCo., Inc.) 

If I run 'hp-setup -g busid:devid' hplip will recognize my printer. I can install using that but after the installation the connection with the printer will fail. This is so strange. Can someone help me with this and why hplip or Cups doesn't recognized my printer?

Last edited by hry218 (2012-02-10 09:24:39)

Offline

#5 2012-02-08 12:56:42

hry218
Member
Registered: 2012-02-06
Posts: 9

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

Update : Now my PC has recognized my printer after I disabled HP Smart Install in Windows. I can install the printer using 'hp-setup' and the driver plugin flawlessly but still I couldn't get the printer to work. It just kept in idle mode. In Cups the error says "/usr/lib/cups/backend/hp failed" and when I read in wiki it simply suggested that I need to make sure dbus and avahi-daemon (optional?) is running. I did that and still no success. Please if you experienced with the same problem please let me know your workaround.

P/s : I also installed foo2zjs and foomatic-db-foo2zjs from AUR.

Error Log from Cups :

D [09/Feb/2012:11:41:26 +0800] cupsdAcceptClient: 14 from localhost:631 (IPv6)
D [09/Feb/2012:11:41:26 +0800] Report: clients=1
D [09/Feb/2012:11:41:26 +0800] Report: jobs=0
D [09/Feb/2012:11:41:26 +0800] Report: jobs-active=0
D [09/Feb/2012:11:41:26 +0800] Report: printers=0
D [09/Feb/2012:11:41:26 +0800] Report: printers-implicit=0
D [09/Feb/2012:11:41:26 +0800] Report: stringpool-string-count=7315
D [09/Feb/2012:11:41:26 +0800] Report: stringpool-alloc-bytes=9728
D [09/Feb/2012:11:41:26 +0800] Report: stringpool-total-bytes=163048
D [09/Feb/2012:11:41:26 +0800] cupsdAcceptClient: 16 from localhost:631 (IPv6)
D [09/Feb/2012:11:41:26 +0800] cupsdAcceptClient: 17 from localhost:631 (IPv6)
D [09/Feb/2012:11:41:27 +0800] cupsdReadClient: 14 GET /admin HTTP/1.1
D [09/Feb/2012:11:41:27 +0800] cupsdSetBusyState: newbusy="Active clients", busy="Not busy"
D [09/Feb/2012:11:41:27 +0800] cupsdAuthorize: Authorized as harry using Basic
D [09/Feb/2012:11:41:27 +0800] [CGI] argv[0] = "/usr/lib/cups/cgi-bin/admin.cgi"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[0] = "CUPS_CACHEDIR=/var/cache/cups"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[1] = "CUPS_DATADIR=/usr/share/cups"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[2] = "CUPS_DOCROOT=/usr/share/cups/doc"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[3] = "CUPS_FONTPATH=/usr/share/cups/fonts"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[4] = "CUPS_REQUESTROOT=/var/spool/cups"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[5] = "CUPS_SERVERBIN=/usr/lib/cups"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[6] = "CUPS_SERVERROOT=/etc/cups"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[7] = "CUPS_STATEDIR=/var/run/cups"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[8] = "HOME=/var/spool/cups/tmp"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[9] = "PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[10] = "SERVER_ADMIN=root@harry.arch"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[11] = "SOFTWARE=CUPS/1.5.2"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[12] = "TMPDIR=/var/spool/cups/tmp"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[13] = "USER=root"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[14] = "CUPS_SERVER=/var/run/cups/cups.sock"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[15] = "CUPS_ENCRYPTION=IfRequested"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[16] = "IPP_PORT=631"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[17] = "AUTH_TYPE=Basic"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[18] = "LANG=en_US.UTF8"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[19] = "REDIRECT_STATUS=1"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[20] = "GATEWAY_INTERFACE=CGI/1.1"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[21] = "SERVER_NAME=localhost"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[22] = "SERVER_PORT=631"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[23] = "REMOTE_ADDR=[v1.::1]"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[24] = "REMOTE_HOST=localhost"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[25] = "SCRIPT_NAME=/admin"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[26] = "SCRIPT_FILENAME=/usr/share/cups/doc/admin"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[27] = "REMOTE_USER=harry"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[28] = "SERVER_PROTOCOL=HTTP/1.1"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[29] = "HTTP_COOKIE=org.cups.sid=c20183d9bfba0979855d4fb6e6bfaa26"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[30] = "HTTP_USER_AGENT=Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[31] = "HTTP_REFERER=http://localhost:631/"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[32] = "REQUEST_METHOD=GET"
D [09/Feb/2012:11:41:27 +0800] [CGI] envp[33] = "QUERY_STRING="
D [09/Feb/2012:11:41:27 +0800] [CGI] Started /usr/lib/cups/cgi-bin/admin.cgi (PID 4310)
I [09/Feb/2012:11:41:27 +0800] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=4310)
D [09/Feb/2012:11:41:27 +0800] cupsdSendCommand: 14 file=19
D [09/Feb/2012:11:41:27 +0800] [CGI] admin.cgi started...
D [09/Feb/2012:11:41:27 +0800] cupsdAcceptClient: 20 from localhost (Domain)
D [09/Feb/2012:11:41:27 +0800] [CGI] http=0xb83d73e0
D [09/Feb/2012:11:41:27 +0800] [CGI] org.cups.sid cookie is "c20183d9bfba0979855d4fb6e6bfaa26"
D [09/Feb/2012:11:41:27 +0800] [CGI] No form data, showing main menu...
D [09/Feb/2012:11:41:27 +0800] [CGI] /usr/share/cups/drivers/pscript5.dll: No such file or directory
D [09/Feb/2012:11:41:27 +0800] cupsdReadClient: 20 POST / HTTP/1.1
D [09/Feb/2012:11:41:27 +0800] cupsdSetBusyState: newbusy="Active clients", busy="Active clients"
D [09/Feb/2012:11:41:27 +0800] cupsdAuthorize: No authentication data provided.
D [09/Feb/2012:11:41:27 +0800] cupsdReadClient: 20 1.1 Get-Subscriptions 1
D [09/Feb/2012:11:41:27 +0800] Get-Subscriptions ipp://localhost/
D [09/Feb/2012:11:41:27 +0800] Returning IPP successful-ok for Get-Subscriptions (ipp://localhost/) from localhost
D [09/Feb/2012:11:41:27 +0800] cupsdSetBusyState: newbusy="Active clients", busy="Active clients"
D [09/Feb/2012:11:41:27 +0800] Script header: Content-Type: text/html;charset=utf-8
D [09/Feb/2012:11:41:27 +0800] Script header: 
D [09/Feb/2012:11:41:27 +0800] cupsdReadClient: 20 WAITING Closing on EOF
D [09/Feb/2012:11:41:27 +0800] cupsdCloseClient: 20
D [09/Feb/2012:11:41:27 +0800] cupsdSetBusyState: newbusy="Active clients", busy="Active clients"
D [09/Feb/2012:11:41:27 +0800] PID 4310 (/usr/lib/cups/cgi-bin/admin.cgi) exited with no errors.
D [09/Feb/2012:11:41:27 +0800] cupsdSetBusyState: newbusy="Not busy", busy="Active clients"
D [09/Feb/2012:11:41:29 +0800] cupsdReadClient: 14 GET /admin/log/error_log? HTTP/1.1
D [09/Feb/2012:11:41:29 +0800] cupsdSetBusyState: newbusy="Active clients", busy="Not busy"
D [09/Feb/2012:11:41:29 +0800] cupsdAuthorize: Authorized as harry using Basic

Last edited by hry218 (2012-02-10 09:23:54)

Offline

#6 2012-02-09 04:00:27

hry218
Member
Registered: 2012-02-06
Posts: 9

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

bump!

Offline

#7 2012-02-09 05:31:37

hry218
Member
Registered: 2012-02-06
Posts: 9

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

The printer is now working after I replaced 'sys' to 'sysgroup' and 'lp' to 'lpadmin' in /etc/cups/cupsd.conf. Restarted Cups and login Cups using root username and password. Then, I added the printer using the specific printer name shown and select the PPD from 'hplip' (with propretary plugin which I installed before). So I can happily say this problem is solved! Thanks!

Last edited by hry218 (2012-02-09 05:32:47)

Offline

#8 2012-02-09 05:38:10

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,435

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

hry218,
Welcome to Arch Linux.  I see you are using quote tags in your posts, but you really should use code tags for long passages.  It provides scroll bars automagically smile


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#9 2012-02-09 05:42:42

hry218
Member
Registered: 2012-02-06
Posts: 9

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

Thanks, lol didn't noticed that. I'll do that next time.

Offline

#10 2012-02-10 03:48:02

bernarcher
Forum Fellow
From: Germany
Registered: 2009-02-17
Posts: 2,273

Re: [SOLVED] Driver Plugin for HP Printer : Failed to Install

hry218 wrote:

Thanks, lol didn't noticed that. I'll do that next time.

You can still do so (and really, you should, even if this was solved already): Please use the Edit button and in every applicable post of yours change the "quote" tags to "code" ones.
Your posts will be so better readable.

And your readers will be so thankful!!!


To know or not to know ...
... the questions remain forever.

Offline

Board footer

Powered by FluxBB