You are not logged in.

#1 2012-03-14 15:21:08

kazimir
Member
Registered: 2012-01-20
Posts: 55

[SOLVED] KDE asks for imap passwords at startup. (akonadi)

Right after login in KDE asks for my imap accounts password, first thing after completing startup.

It ask even before I connect to any network or start kmail which is unexpected to me and quite annoying as I have several imap accounts and the password request windows are on top of other windows. These windows will raise again automatically after I connect to a network. I manage to make this behavior tolerable by having kde wallet manage all my imap accounts passwords, so I only have to put a single password.

I wonder if this is related to nepomuk or akonadi.

KDE session management is set to "start with an empty session", autostart has krunner and plasma-dekstop enabled and that's it.

Let me know what kind of info I should provide to help look into this issue.

Last edited by kazimir (2012-03-14 20:55:56)

Offline

#2 2012-03-14 16:02:52

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,185

Re: [SOLVED] KDE asks for imap passwords at startup. (akonadi)

Akonadi is started by the plasma clock at login. Try unchecking "show events" in the plasma clock configuration to see if it fixes it.

Offline

#3 2012-03-14 19:15:34

kazimir
Member
Registered: 2012-01-20
Posts: 55

Re: [SOLVED] KDE asks for imap passwords at startup. (akonadi)

Interesting thing to know, I tried it and but the password windows still pops up at startup.

I figured out that maybe something else was starting akonadi and that I should have a look at the running processes and sure enough:

ps faux | grep akonadi                                                                                             2012-03-14 19:54:40 user pts/2

user      2251  0.0  0.0   8640  1084 pts/2    S+   19:54   0:00              \_ grep --color=auto akonadi
user      1637  0.1  0.0 124584  5920 ?        Sl   19:49   0:00 /usr/bin/akonadi_control
user      1639  0.1  0.1 2377720 10180 ?       Sl   19:49   0:00  \_ akonadiserver
user      1653  0.3  0.4 2301036 39156 ?       Sl   19:49   0:01  |   \_ /usr/bin/mysqld --defaults-file=/home/user/.local/share/akonadi/mysql.conf --datadir=/home/user/.local/share/akonadi/db_data/ --socket=/home/user/.local/share/akonadi/socket-golem/mysql.socket
user      1697  0.0  0.2 278908 20936 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_akonotes_resource akonadi_akonotes_resource_0
user      1698  0.0  0.2 272476 20220 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_contacts_resource akonadi_contacts_resource_0
user      1699  0.0  0.2 272476 20224 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_contacts_resource akonadi_contacts_resource_1
user      1700  0.0  0.2 277128 21488 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_contacts_resource akonadi_contacts_resource_3
user      1701  0.0  0.2 275048 20468 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_ical_resource akonadi_ical_resource_0
user      1702  0.0  0.2 285816 23264 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_0
user      1703  0.0  0.2 285968 23232 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_1
user      1704  0.0  0.2 285960 23232 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_2
user      1705  0.0  0.2 286100 23436 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_3
user      1706  0.0  0.2 285964 23228 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_4
user      1707  0.0  0.2 285960 23180 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_5
user      1708  0.0  0.2 285940 22920 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_6
user      1709  0.0  0.2 285944 23180 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_7
user      1710  0.0  0.2 285964 22976 ?        S    19:49   0:00  \_ /usr/bin/akonadi_imap_resource --identifier akonadi_imap_resource_8
user      1711  0.0  0.2 291104 22072 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_kalarm_resource akonadi_kalarm_resource_0
user      1712  0.0  0.2 291088 21972 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_kalarm_resource akonadi_kalarm_resource_1
user      1713  0.0  0.2 290944 21652 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_kalarm_resource akonadi_kalarm_resource_2
user      1714  0.0  0.2 278996 20896 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_maildir_resource akonadi_maildir_resource_0
user      1717  0.0  0.2 308300 23340 ?        S    19:49   0:00  \_ /usr/bin/akonadi_maildispatcher_agent --identifier akonadi_maildispatcher_agent
user      1718  0.0  0.4 507424 39596 ?        S    19:49   0:00  \_ /usr/bin/akonadi_mailfilter_agent --identifier akonadi_mailfilter_agent
user      1719  0.0  0.2 340512 22176 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_nepomuk_feeder --identifier akonadi_nepomuk_feeder
user      1720  0.0  0.2 272980 21164 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_vcard_resource akonadi_vcard_resource_0
user      1721  0.0  0.2 272492 20644 ?        Sl   19:49   0:00  \_ /usr/bin/akonadi_agent_launcher akonadi_vcard_resource akonadi_vcard_resource_2

How do I tell akonadi to only ask for passwords once I opened my email client ?
Is this even possible ? Going through akonadi configuration options I couldn't find any setting related to akonadi, it seems to only show the kmail account settings.

I was thinking I could simply turn akonadi off for the imap accounts as a last resort, but I didn't see any option to turn off akonadi monitoring of a specific resource either.

Offline

#4 2012-03-14 20:03:07

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,185

Re: [SOLVED] KDE asks for imap passwords at startup. (akonadi)

You can't "turn off" akonadi for an account, since akonadi is what gets the mails from the server  (if you use kmail).

From the accounts settings dialog in kmail, check "retrieval options" for each account, and make sure "switch offline on kmail shutdown" is checked.

Offline

#5 2012-03-14 20:51:43

kazimir
Member
Registered: 2012-01-20
Posts: 55

Re: [SOLVED] KDE asks for imap passwords at startup. (akonadi)

Sir, you just made my daily use of my computer a lot less frustrating. Thank you very much !

I shall complain about this setting being badly placed and quite counter intuitive. I'd expect a setting affecting akonadi to show up in akonadi configuration and not only in kmail where there is no mention it impact akonadi, but I don't really know where to provide my feedback.

Anyways thanks again for your help, this is solved.

Offline

Board footer

Powered by FluxBB