You are not logged in.

#1 2012-03-25 18:37:42

nixIT
Member
Registered: 2010-01-13
Posts: 396

[SOLVED] NVIDIA and API mismatch

Hello all,

I went to play RIFT and when I ran it through wine, I am now getting this message:

Error: API mismatch: the NVIDIA kernel module has version 295.33,
but this NVIDIA driver component has version 290.10.  Please make
sure that the kernel module and all NVIDIA driver components
have the same version.

I saw a similar post where the user had the same error as me, but he installed the nvidia drivers from nvidia, I always use what's in repos.

I did a pacman -Syu and everything is up to date.  Uninstalled and reinstalled the nvidia drivers, not help

I'm not sure what to check.

--nixIT

Last edited by nixIT (2012-03-28 14:03:43)


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

#2 2012-03-25 18:52:48

KingX
Member
From: Fremont, CA
Registered: 2010-03-24
Posts: 321

Re: [SOLVED] NVIDIA and API mismatch

Did you reboot after updating?

Offline

#3 2012-03-25 18:53:51

nixIT
Member
Registered: 2010-01-13
Posts: 396

Re: [SOLVED] NVIDIA and API mismatch

yup, rebooted after uninstall/reinstall of drivers too.


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

#4 2012-03-25 19:10:06

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: [SOLVED] NVIDIA and API mismatch

You are of course using either:
   a) nvidia with linux packages or
   b) nvidia-lts with linux-lts
and not mismatch them?

What pacman -Qi nvidia returns?

Last edited by masteryod (2012-03-25 19:10:39)

Offline

#5 2012-03-25 21:04:12

nixIT
Member
Registered: 2010-01-13
Posts: 396

Re: [SOLVED] NVIDIA and API mismatch

masteryod wrote:

You are of course using either:
   a) nvidia with linux packages or
   b) nvidia-lts with linux-lts
and not mismatch them?

What pacman -Qi nvidia returns?

thanx for responding...

[root@dugr ~]# pacman -Qi nvidia
Name           : nvidia
Version        : 295.33-1
URL            : http://www.nvidia.com/
Licenses       : custom
Groups         : None
Provides       : None
Depends On     : linux>=3.2  linux<3.3  nvidia-utils=295.33
Optional Deps  : None
Required By    : None
Conflicts With : nvidia-96xx  nvidia-173xx
Replaces       : None
Installed Size : 4812.00 KiB
Packager       : Ionut Biru <ibiru@archlinux.org>
Architecture   : x86_64
Build Date     : Fri 23 Mar 2012 04:01:06 AM EDT
Install Date   : Sun 25 Mar 2012 02:12:41 PM EDT
Install Reason : Explicitly installed
Install Script : Yes
Description    : NVIDIA drivers for linux.

what would I be looking for?

--nixIT


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

#6 2012-03-25 21:46:28

masteryod
Member
Registered: 2010-05-19
Posts: 433

Re: [SOLVED] NVIDIA and API mismatch

nixIT wrote:

what would I be looking for?

I was just curious about version. You are running x86_64 so I guess this is solution: https://bbs.archlinux.org/viewtopic.php?id=64473

If not google this

Offline

#7 2012-03-26 05:41:21

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] NVIDIA and API mismatch

paste pacman -Qs nvidia


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#8 2012-03-28 01:31:32

nixIT
Member
Registered: 2010-01-13
Posts: 396

Re: [SOLVED] NVIDIA and API mismatch

wonder wrote:

paste pacman -Qs nvidia

crud...

# pacman -Qs nvidia
local/lib32-nvidia-utils 290.10-1
    NVIDIA drivers utilities and libraries. (32-bit)
local/libvdpau 0.4.1-2
    Nvidia VDPAU library
local/nvidia 295.33-1
    NVIDIA drivers for linux.
local/nvidia-utils 295.33-1
    NVIDIA drivers utilities and libraries.

lib32-nvidia-utils is behind a versioln

there is a beta in the AUR that matches the same version as the drivers.


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

#9 2012-03-28 04:48:22

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,937
Website

Re: [SOLVED] NVIDIA and API mismatch

nixIT wrote:
wonder wrote:

paste pacman -Qs nvidia

crud...

# pacman -Qs nvidia
local/lib32-nvidia-utils 290.10-1
    NVIDIA drivers utilities and libraries. (32-bit)
local/libvdpau 0.4.1-2
    Nvidia VDPAU library
local/nvidia 295.33-1
    NVIDIA drivers for linux.
local/nvidia-utils 295.33-1
    NVIDIA drivers utilities and libraries.

lib32-nvidia-utils is behind a versioln

there is a beta in the AUR that matches the same version as the drivers.

enable multilib repository from pacman.conf and pacman -Syu. Seems that you either replaced pacman.conf with pacman.conf.pacnew or you manually disabled


Give what you have. To someone, it may be better than you dare to think.
Blog

Offline

#10 2012-03-28 13:09:40

nixIT
Member
Registered: 2010-01-13
Posts: 396

Re: [SOLVED] NVIDIA and API mismatch

wonder wrote:

enable multilib repository from pacman.conf and pacman -Syu. Seems that you either replaced pacman.conf with pacman.conf.pacnew or you manually disabled

Thanx, the multilib section was uncommented but [multilib] was not uncommented, it still had a # in front of it.  Not sure how long that's been there.  smile

Thanx..

--nixIT


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

#11 2012-03-28 13:58:28

Earnestly
Member
Registered: 2011-08-18
Posts: 805

Re: [SOLVED] NVIDIA and API mismatch

Mark thread as [SOLVED] if it has been solved.

Offline

#12 2012-03-28 14:03:27

nixIT
Member
Registered: 2010-01-13
Posts: 396

Re: [SOLVED] NVIDIA and API mismatch

Kaustic wrote:

Mark thread as [SOLVED] if it has been solved.

Was waiting for the update to finish so I could check the versions.  smile


ASRock 970 Extreme4  | AMD FX 8350 | 32GB G.SKILL Ripjaw X  | 180GB Corsair Force Series GS SSD | MSI GeForce GTX 960 GTX Gaming 4G 4GB

Offline

#13 2012-03-31 17:55:19

roguegaston
Member
Registered: 2012-03-13
Posts: 5

Re: [SOLVED] NVIDIA and API mismatch

woops wrong post...

Last edited by roguegaston (2012-03-31 17:57:09)

Offline

Board footer

Powered by FluxBB