You are not logged in.

#1 2012-05-03 18:50:11

cryptkeeper
Member
From: Zurich, Switzerland
Registered: 2011-12-29
Posts: 63

[SOLVED] synclient touchpad settings reset after resume

On my touchpad, I use two-finger-tap for double klick, but I disabled one-finger-tap because I always accidently touch it when typing, so I suddenly end up typing in another line than I actually want to. An[solved] [solved] yway, these are the corresponding settings:

/etc/X11/xorg.conf.d/10-synaptics.conf

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "TapButton1" "0"
        Option "TapButton2" "3"
        Option "TapButton3" "2"
EndSection

~/.bashrc

synclient TapButton1=0
synclient TapButton2=3
synclient TapButton3=2

The problem is: Every time I wake the computer up from sleeping or do something similar, TapButton1 is activated again! Since I have these settings also in the .bashrc (see above), I just have to quickly open a new terminal window when this happens to disable TapButton1 again. This workaround works flawlessly, but it's annoying nevertheless.

I have no idea how to fix this issue, I'm only sure that it's fixable. Any suggestions?

Last edited by cryptkeeper (2012-05-26 16:06:26)

Offline

#2 2012-05-03 21:29:59

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 812

Re: [SOLVED] synclient touchpad settings reset after resume

You can put those line from bashrc in /etc/pm/sleep.d/ while resume | thaw. So you'll workaround this problem without have to open a terminal window.
Or you can use still

syndaemon -t -k -i 2 -d &

as wiki said, to disable touchpad while typing! (do a script with that line and put in your .xinitrc or in your session manager. It must be run after login)

Online

#3 2012-05-06 10:46:30

cryptkeeper
Member
From: Zurich, Switzerland
Registered: 2011-12-29
Posts: 63

Re: [SOLVED] synclient touchpad settings reset after resume

I added the line to /etc/pm/sleep.d/90alsa, but it doesn't work. The file now looks like this:

/etc/pm/sleep.d/90alsa

#!/bin/sh
#
# 90alsa: suspend/wakeup ALSA devices

case "$1" in
hibernate|suspend)
;;
thaw|resume)
aplay -d 1 /dev/zero
synclient TapButton1=0
;;
*) exit $NA
;;
esac

What does this file anyway?

Offline

#4 2012-05-06 11:20:43

sultanoswing
Member
Registered: 2008-07-23
Posts: 297

Re: [SOLVED] synclient touchpad settings reset after resume

nierro wrote:

It must be run after login)

Precisely because of this reason, I added the following to my session startup programs:

synclient TapButton2=0

Use 'gnome-session-properties' from a terminal. The above script disables two finger tap right-click, which kept popping up when I was trying to two finger scroll.


Arch-lts (x86_64) w/Gnome 3.20.2
ASUS P7P55-E-Pro, Geforce GTX460, i5-750, 8GB, Samsung 830 SSD | Intel NUC 5i5RYK | ASUS ux303ua | HP Folio 13

Offline

#5 2012-05-06 12:07:51

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 812

Re: [SOLVED] synclient touchpad settings reset after resume

Yes, follow sultanoswing advice.
And restore 90alsa as it was!
In /etc/pm/sleep.d/ there are files to perform some actions before and after suspend/hibernation, but in this case you have only to put

synclient TapButton2=0

in your session startup programs, as sultanoswing said!

Online

#6 2012-05-26 16:05:31

cryptkeeper
Member
From: Zurich, Switzerland
Registered: 2011-12-29
Posts: 63

Re: [SOLVED] synclient touchpad settings reset after resume

I just found the perfect solution, which is just stopping gnome from touching any mouse settings (found here: https://wiki.archlinux.org/index.php/To … tics#GNOME )!  The problem was that on resuming, gnome overwrote the synaptics settings in /etc/X11/xorg.conf.d/10-synaptics.conf with it's own settings, and these included left-mouse-key clicks with the touchpad.

After disabeling the gnome mouse settings daemon (at leat I think that's what I did wink ) by unchecking active in /org/gnome/settings-daemon/plugins/mouse/ in dconf-editor, I now have all my touchpad- and mouse-related settings in /etc/X11/xorg.conf.d/10-synaptics.conf and gnome doesn't interfere with these anymore. I can still change the settings in the gnome mouse settings window, but that has no effect whatsoever anymore.

Offline

Board footer

Powered by FluxBB