You are not logged in.

#1 2012-07-13 10:44:58

TreeMinds
Member
Registered: 2007-09-01
Posts: 35

[Solved] ns-3 python bindings

Hello,
I have a problem enabling the python bindings in ns-3.14.1

The waf configure output of ns-3 is here:
http://pastebin.com/qnsMdNPB

It can't find the python3 development headers/libraries although python is installed.

Can anyone help?

Thanks in advance.

Last edited by TreeMinds (2012-07-18 09:53:03)

Offline

#2 2012-07-13 11:51:40

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,731

Re: [Solved] ns-3 python bindings

Sure that ns is ported to py3?
Disclaimer: I can't open pastebin.com, so I can't see the output

Last edited by Mr.Elendig (2012-07-13 11:52:31)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#3 2012-07-13 12:29:56

TreeMinds
Member
Registered: 2007-09-01
Posts: 35

Re: [Solved] ns-3 python bindings

The output for python3 configuration:

$ python2 waf configure --enable-examples --enable-tests
Setting top to                           : /mnt/dev/CEID/MyDIP/src/ns-allinone-3.14.1/ns-3.14.1 
Setting out to                           : /mnt/dev/CEID/MyDIP/src/ns-allinone-3.14.1/ns-3.14.1/build 
Checking for 'gcc' (c compiler)          : /usr/bin/gcc 
Checking for 'g++' (c++ compiler)        : /usr/bin/g++ 
Checking for program pkg-config          : /usr/bin/pkg-config 
Checking for compilation flag -Wl,--soname=foo... support : ok 
Checking for program python                               : /usr/bin/python 
python executable '/usr/bin/python' different from sys.executable '/usr/bin/python2'
Checking for python version                               : (3, 2, 3, 'final', 0) 
Checking for library python3.2 in LIBDIR                  : not found 
Checking for library python3.2 in python_LIBPL            : not found 
Checking for library python3.2 in $prefix/libs            : not found 
Checking for library python32 in LIBDIR                   : not found 
Checking for library python32 in python_LIBPL             : not found 
Checking for library python32 in $prefix/libs             : not found 
Checking for program python3.2-config,python-config-3.2,python3.2m-config : /usr/bin/python3.2-config 
Checking for header Python.h                                              : Could not find the python development headers 
Checking for '/usr/bin/python3.2-config'                                  : yes 
Getting the python flags from python-config                               : Could not find the python development headers elsewhere 
Checking for click location                                               : not found 
Checking for pkg-config flags for GTK_CONFIG_STORE                        : ok 
Checking for pkg-config flags for LIBXML2                                 : ok 
Checking for type uint128_t                                               : not found 
Checking for type __uint128_t                                             : yes 
Checking high precision time implementation                               : 128-bit integer 
Checking for header stdint.h                                              : yes 
Checking for header inttypes.h                                            : yes 
Checking for header sys/inttypes.h                                        : not found 
Checking for header sys/types.h                                           : yes 
Checking for header sys/stat.h                                            : yes 
Checking for header dirent.h                                              : yes 
Checking for header stdlib.h                                              : yes 
Checking for header signal.h                                              : yes 
Checking for header pthread.h                                             : yes 
Checking for header stdint.h                                              : yes 
Checking for header inttypes.h                                            : yes 
Checking for header sys/inttypes.h                                        : not found 
Checking for library rt                                                   : yes 
Checking for header netpacket/packet.h                                    : yes 
Checking for NSC location                                                 : ../nsc-0.5.3 (guessed) 
Checking for library dl                                                   : yes 
Checking for NSC supported architecture x86_64                            : ok 
Checking for header sys/socket.h                                          : yes 
Checking for header netinet/in.h                                          : yes 
Checking boost includes                                                   : 1_49 
Checking boost libs                                                       : ok 
Checking for OpenFlow location                                            : not found 
Checking for library sqlite3                                              : yes 
Checking for header linux/if_tun.h                                        : yes 
Checking for program sudo                                                 : /usr/bin/sudo 
Checking for program valgrind                                             : /usr/bin/valgrind 
Checking for pkg-config flags for GSL                                     : ok 
Checking for compilation flag -Wno-error=deprecated-d... support          : ok 
Checking for compilation flag -Wno-error=deprecated-d... support          : ok 
Checking for compilation flag -fstrict-aliasing... support                : ok 
Checking for compilation flag -fstrict-aliasing... support                : ok 
Checking for compilation flag -Wstrict-aliasing... support                : ok 
Checking for compilation flag -Wstrict-aliasing... support                : ok 
Checking for program doxygen                                              : /usr/bin/doxygen 
---- Summary of optional NS-3 features:
Python Bindings               : not enabled (Python library or headers missing)
NS-3 Click Integration        : not enabled (nsclick not enabled (see option --with-nsclick))
GtkConfigStore                : enabled
XmlIo                         : enabled
Threading Primitives          : enabled
Real Time Simulator           : enabled
Emulated Net Device           : enabled
Network Simulation Cradle     : enabled
MPI Support                   : not enabled (option --enable-mpi not selected)
NS-3 OpenFlow Integration     : not enabled (OpenFlow not enabled (see option --with-openflow))
SQlite stats data output      : enabled
Tap Bridge                    : enabled
PyViz visualizer              : not enabled (Python Bindings are needed but not enabled)
Use sudo to set suid bit      : not enabled (option --enable-sudo not selected)
Build tests                   : enabled
Build examples                : enabled
GNU Scientific Library (GSL)  : enabled
'configure' finished successfully (6.518s)

And for python2:

$ python2 waf configure --enable-examples --enable-tests --with-python=python2
Setting top to                           : /mnt/dev/CEID/MyDIP/src/ns-allinone-3.14.1/ns-3.14.1 
Setting out to                           : /mnt/dev/CEID/MyDIP/src/ns-allinone-3.14.1/ns-3.14.1/build 
Checking for 'gcc' (c compiler)          : /usr/bin/gcc 
Checking for 'g++' (c++ compiler)        : /usr/bin/g++ 
Checking for program pkg-config          : /usr/bin/pkg-config 
Checking for compilation flag -Wl,--soname=foo... support : ok 
Checking for program python                               : python2 
python executable 'python2' different from sys.executable '/usr/bin/python2'
Checking for python version                               : (2, 7, 3, 'final', 0) 
Checking for library python2.7 in LIBDIR                  : yes 
Checking for program python2.7-config,python-config-2.7,python2.7m-config : /usr/bin/python2.7-config 
Checking for header Python.h                                              : Could not find the python development headers 
Checking for '/usr/bin/python2.7-config'                                  : yes 
Getting the python flags from python-config                               : Could not find the python development headers elsewhere 
Checking for click location                                               : not found 
Checking for pkg-config flags for GTK_CONFIG_STORE                        : ok 
Checking for pkg-config flags for LIBXML2                                 : ok 
Checking for type uint128_t                                               : not found 
Checking for type __uint128_t                                             : yes 
Checking high precision time implementation                               : 128-bit integer 
Checking for header stdint.h                                              : yes 
Checking for header inttypes.h                                            : yes 
Checking for header sys/inttypes.h                                        : not found 
Checking for header sys/types.h                                           : yes 
Checking for header sys/stat.h                                            : yes 
Checking for header dirent.h                                              : yes 
Checking for header stdlib.h                                              : yes 
Checking for header signal.h                                              : yes 
Checking for header pthread.h                                             : yes 
Checking for header stdint.h                                              : yes 
Checking for header inttypes.h                                            : yes 
Checking for header sys/inttypes.h                                        : not found 
Checking for library rt                                                   : yes 
Checking for header netpacket/packet.h                                    : yes 
Checking for NSC location                                                 : ../nsc-0.5.3 (guessed) 
Checking for library dl                                                   : yes 
Checking for NSC supported architecture x86_64                            : ok 
Checking for header sys/socket.h                                          : yes 
Checking for header netinet/in.h                                          : yes 
Checking boost includes                                                   : 1_49 
Checking boost libs                                                       : ok 
Checking for OpenFlow location                                            : not found 
Checking for library sqlite3                                              : yes 
Checking for header linux/if_tun.h                                        : yes 
Checking for program sudo                                                 : /usr/bin/sudo 
Checking for program valgrind                                             : /usr/bin/valgrind 
Checking for pkg-config flags for GSL                                     : ok 
Checking for compilation flag -Wno-error=deprecated-d... support          : ok 
Checking for compilation flag -Wno-error=deprecated-d... support          : ok 
Checking for compilation flag -fstrict-aliasing... support                : ok 
Checking for compilation flag -fstrict-aliasing... support                : ok 
Checking for compilation flag -Wstrict-aliasing... support                : ok 
Checking for compilation flag -Wstrict-aliasing... support                : ok 
Checking for program doxygen                                              : /usr/bin/doxygen 
---- Summary of optional NS-3 features:
Python Bindings               : not enabled (Python library or headers missing)
NS-3 Click Integration        : not enabled (nsclick not enabled (see option --with-nsclick))
GtkConfigStore                : enabled
XmlIo                         : enabled
Threading Primitives          : enabled
Real Time Simulator           : enabled
Emulated Net Device           : enabled
Network Simulation Cradle     : enabled
MPI Support                   : not enabled (option --enable-mpi not selected)
NS-3 OpenFlow Integration     : not enabled (OpenFlow not enabled (see option --with-openflow))
SQlite stats data output      : enabled
Tap Bridge                    : enabled
PyViz visualizer              : not enabled (Python Bindings are needed but not enabled)
Use sudo to set suid bit      : not enabled (option --enable-sudo not selected)
Build tests                   : enabled
Build examples                : enabled
GNU Scientific Library (GSL)  : enabled
'configure' finished successfully (9.695s)

For python3 it can't find headers and libraries and for python2 it can't find headers.

PS:
Don't know if python3 is supported,
but the issue still remains in python2.

After doing:
$ pacman -Ql python2 | grep Python.h
it returns:
python2 /usr/include/python2.7/Python.h

and after:
$ pacman -Ql python | grep Python.h
it returns:
python /usr/include/python3.2mu/Python.h

Offline

#4 2012-07-18 09:52:23

TreeMinds
Member
Registered: 2007-09-01
Posts: 35

Re: [Solved] ns-3 python bindings

It appears that the python bindings are enabled when building
in release or optimized profile.

And they are disabled when building in debug profile.

Offline

Board footer

Powered by FluxBB