You are not logged in.

#1 2012-10-05 15:24:14

biltong
Member
From: South Africa
Registered: 2011-09-01
Posts: 116

[solved]X starts then exits immediately when using mate

I installed arch a week or 2 ago, installed mate and followed the new install guide and X simply starts successfully then stops instantly. Tried with nouveau and binary Nvidia drivers.

.xinitrc:

exec ck-launch-session dbus_launch mate-session

Xorg.0.log:

[   545.462] 
X.Org X Server 1.12.4
Release Date: 2012-08-27
[   545.471] X Protocol Version 11, Revision 0
[   545.471] Build Operating System: Linux 3.4.8-1-ARCH x86_64 
[   545.471] Current Operating System: Linux logan-arch-pc 3.5.4-1-ARCH #1 SMP PREEMPT Sat Sep 15 08:12:04 CEST 2012 x86_64
[   545.471] Kernel command line: root=UUID=86d3bc1e-eaf4-4298-93d9-182de96f6da2 ro initrd=../initramfs-linux-fallback.img BOOT_IMAGE=../vmlinuz-linux 
[   545.471] Build Date: 27 August 2012  08:04:39AM
[   545.472]  
[   545.472] Current version of pixman: 0.26.2
[   545.472] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   545.472] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   545.473] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Oct  5 19:07:25 2012
[   545.500] (==) Using config file: "/etc/X11/xorg.conf"
[   545.500] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   545.527] (==) ServerLayout "Layout0"
[   545.527] (**) |-->Screen "Screen0" (0)
[   545.527] (**) |   |-->Monitor "Monitor0"
[   545.537] (**) |   |-->Device "Device0"
[   545.537] (**) |-->Input Device "Keyboard0"
[   545.537] (**) |-->Input Device "Mouse0"
[   545.537] (==) Automatically adding devices
[   545.537] (==) Automatically enabling devices
[   545.565] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   545.565] 	Entry deleted from font path.
[   545.583] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   545.583] 	Entry deleted from font path.
[   545.583] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   545.583] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   545.583] 	Entry deleted from font path.
[   545.583] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   545.583] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[   545.583] (==) ModulePath set to "/usr/lib/xorg/modules"
[   545.583] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   545.583] (WW) Disabling Keyboard0
[   545.583] (WW) Disabling Mouse0
[   545.583] (II) Loader magic: 0x7c8b00
[   545.583] (II) Module ABI versions:
[   545.583] 	X.Org ANSI C Emulation: 0.4
[   545.583] 	X.Org Video Driver: 12.1
[   545.583] 	X.Org XInput driver : 16.0
[   545.583] 	X.Org Server Extension : 6.0
[   545.584] (--) PCI:*(0:1:0:0) 10de:0400:1458:3448 rev 161, Mem @ 0xf2000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000c000/128, BIOS @ 0x????????/131072
[   545.584] (II) Open ACPI successful (/var/run/acpid.socket)
[   545.584] (II) LoadModule: "extmod"
[   545.679] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   545.687] (II) Module extmod: vendor="X.Org Foundation"
[   545.687] 	compiled for 1.12.4, module version = 1.0.0
[   545.687] 	Module class: X.Org Server Extension
[   545.687] 	ABI class: X.Org Server Extension, version 6.0
[   545.687] (II) Loading extension MIT-SCREEN-SAVER
[   545.687] (II) Loading extension XFree86-VidModeExtension
[   545.687] (II) Loading extension XFree86-DGA
[   545.687] (II) Loading extension DPMS
[   545.687] (II) Loading extension XVideo
[   545.688] (II) Loading extension XVideo-MotionCompensation
[   545.688] (II) Loading extension X-Resource
[   545.688] (II) LoadModule: "dbe"
[   545.688] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   545.688] (II) Module dbe: vendor="X.Org Foundation"
[   545.688] 	compiled for 1.12.4, module version = 1.0.0
[   545.688] 	Module class: X.Org Server Extension
[   545.688] 	ABI class: X.Org Server Extension, version 6.0
[   545.688] (II) Loading extension DOUBLE-BUFFER
[   545.689] (II) LoadModule: "glx"
[   545.689] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   546.568] (II) Module glx: vendor="NVIDIA Corporation"
[   546.568] 	compiled for 4.0.2, module version = 1.0.0
[   546.568] 	Module class: X.Org Server Extension
[   546.568] (II) NVIDIA GLX Module  304.51  Tue Sep 18 17:38:06 PDT 2012
[   546.568] (II) Loading extension GLX
[   546.568] (II) LoadModule: "record"
[   546.568] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   546.579] (II) Module record: vendor="X.Org Foundation"
[   546.579] 	compiled for 1.12.4, module version = 1.13.0
[   546.579] 	Module class: X.Org Server Extension
[   546.579] 	ABI class: X.Org Server Extension, version 6.0
[   546.579] (II) Loading extension RECORD
[   546.579] (II) LoadModule: "dri"
[   546.579] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   546.587] (II) Module dri: vendor="X.Org Foundation"
[   546.587] 	compiled for 1.12.4, module version = 1.0.0
[   546.587] 	ABI class: X.Org Server Extension, version 6.0
[   546.587] (II) Loading extension XFree86-DRI
[   546.587] (II) LoadModule: "dri2"
[   546.587] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   546.588] (II) Module dri2: vendor="X.Org Foundation"
[   546.588] 	compiled for 1.12.4, module version = 1.2.0
[   546.588] 	ABI class: X.Org Server Extension, version 6.0
[   546.588] (II) Loading extension DRI2
[   546.588] (II) LoadModule: "nvidia"
[   546.588] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[   546.641] (II) Module nvidia: vendor="NVIDIA Corporation"
[   546.641] 	compiled for 4.0.2, module version = 1.0.0
[   546.641] 	Module class: X.Org Video Driver
[   546.664] (II) NVIDIA dlloader X Driver  304.51  Tue Sep 18 17:18:40 PDT 2012
[   546.664] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   546.673] (--) using VT number 7

[   546.682] (II) Loading sub module "fb"
[   546.682] (II) LoadModule: "fb"
[   546.683] (II) Loading /usr/lib/xorg/modules/libfb.so
[   546.692] (II) Module fb: vendor="X.Org Foundation"
[   546.692] 	compiled for 1.12.4, module version = 1.0.0
[   546.692] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   546.692] (II) Loading sub module "wfb"
[   546.692] (II) LoadModule: "wfb"
[   546.692] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   546.702] (II) Module wfb: vendor="X.Org Foundation"
[   546.702] 	compiled for 1.12.4, module version = 1.0.0
[   546.702] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   546.702] (II) Loading sub module "ramdac"
[   546.703] (II) LoadModule: "ramdac"
[   546.703] (II) Module "ramdac" already built-in
[   546.705] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   546.705] (==) NVIDIA(0): RGB weight 888
[   546.705] (==) NVIDIA(0): Default visual is TrueColor
[   546.705] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   546.705] (**) NVIDIA(0): Enabling 2D acceleration
[   548.023] (II) NVIDIA(GPU-0): Display (HP L1908w (CRT-0)) does not support NVIDIA 3D Vision
[   548.023] (II) NVIDIA(GPU-0):     stereo.
[   548.027] (II) NVIDIA(0): NVIDIA GPU GeForce 8600 GTS (G84) at PCI:1:0:0 (GPU-0)
[   548.027] (--) NVIDIA(0): Memory: 262144 kBytes
[   548.027] (--) NVIDIA(0): VideoBIOS: 60.84.5e.00.00
[   548.027] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   548.027] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[   548.037] (--) NVIDIA(0): Valid display device(s) on GeForce 8600 GTS at PCI:1:0:0
[   548.037] (--) NVIDIA(0):     HP L1908w (CRT-0) (connected)
[   548.037] (--) NVIDIA(0):     CRT-1
[   548.037] (--) NVIDIA(0):     TV-0
[   548.037] (--) NVIDIA(0):     DFP-0
[   548.037] (--) NVIDIA(0):     DFP-1
[   548.037] (--) NVIDIA(0): HP L1908w (CRT-0): 400.0 MHz maximum pixel clock
[   548.037] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[   548.037] (--) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
[   548.037] (--) NVIDIA(0): TV encoder: (null)
[   548.037] (--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
[   548.037] (--) NVIDIA(0): DFP-0: Internal Single Link TMDS
[   548.037] (--) NVIDIA(0): DFP-1: 330.0 MHz maximum pixel clock
[   548.037] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[   548.037] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   548.037] (**) NVIDIA(0):     device HP L1908w (CRT-0) (Using EDID frequencies has been
[   548.037] (**) NVIDIA(0):     enabled on all display devices.)
[   548.039] (==) NVIDIA(0): 
[   548.039] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   548.039] (==) NVIDIA(0):     will be used as the requested mode.
[   548.039] (==) NVIDIA(0): 
[   548.039] (II) NVIDIA(0): Validated MetaModes:
[   548.039] (II) NVIDIA(0):     "CRT-0:nvidia-auto-select"
[   548.039] (II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
[   548.080] (--) NVIDIA(0): DPI set to (89, 87); computed from "UseEdidDpi" X config
[   548.080] (--) NVIDIA(0):     option
[   548.080] (--) Depth 24 pixmap format is 32 bpp
[   548.080] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[   548.088] (II) NVIDIA(0): Setting mode "CRT-0:nvidia-auto-select"
[   548.142] (II) Loading extension NV-GLX
[   548.176] (==) NVIDIA(0): Disabling shared memory pixmaps
[   548.176] (==) NVIDIA(0): Backing store disabled
[   548.176] (==) NVIDIA(0): Silken mouse enabled
[   548.176] (**) NVIDIA(0): DPMS enabled
[   548.181] (II) Loading extension NV-CONTROL
[   548.182] (II) Loading extension XINERAMA
[   548.182] (II) Loading sub module "dri2"
[   548.182] (II) LoadModule: "dri2"
[   548.182] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   548.182] (II) Module dri2: vendor="X.Org Foundation"
[   548.182] 	compiled for 1.12.4, module version = 1.2.0
[   548.182] 	ABI class: X.Org Server Extension, version 6.0
[   548.182] (II) NVIDIA(0): [DRI2] Setup complete
[   548.182] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   548.182] (--) RandR disabled
[   548.182] (II) Initializing built-in extension Generic Event Extension
[   548.182] (II) Initializing built-in extension SHAPE
[   548.182] (II) Initializing built-in extension MIT-SHM
[   548.182] (II) Initializing built-in extension XInputExtension
[   548.182] (II) Initializing built-in extension XTEST
[   548.182] (II) Initializing built-in extension BIG-REQUESTS
[   548.182] (II) Initializing built-in extension SYNC
[   548.182] (II) Initializing built-in extension XKEYBOARD
[   548.182] (II) Initializing built-in extension XC-MISC
[   548.182] (II) Initializing built-in extension SECURITY
[   548.182] (II) Initializing built-in extension XINERAMA
[   548.182] (II) Initializing built-in extension XFIXES
[   548.182] (II) Initializing built-in extension RENDER
[   548.182] (II) Initializing built-in extension RANDR
[   548.182] (II) Initializing built-in extension COMPOSITE
[   548.182] (II) Initializing built-in extension DAMAGE
[   548.183] (II) Initializing extension GLX
[   548.534] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[   548.534] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   548.534] (II) LoadModule: "evdev"
[   548.534] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[   548.553] (II) Module evdev: vendor="X.Org Foundation"
[   548.553] 	compiled for 1.12.3.901, module version = 2.7.3
[   548.553] 	Module class: X.Org XInput Driver
[   548.553] 	ABI class: X.Org XInput driver, version 16.0
[   548.553] (II) Using input driver 'evdev' for 'Power Button'
[   548.553] (**) Power Button: always reports core events
[   548.553] (**) evdev: Power Button: Device: "/dev/input/event3"
[   548.553] (--) evdev: Power Button: Vendor 0 Product 0x1
[   548.553] (--) evdev: Power Button: Found keys
[   548.553] (II) evdev: Power Button: Configuring as keyboard
[   548.553] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input3/event3"
[   548.553] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   548.553] (**) Option "xkb_rules" "evdev"
[   548.553] (**) Option "xkb_model" "evdev"
[   548.553] (**) Option "xkb_layout" "us"
[   548.577] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[   548.577] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   548.577] (II) Using input driver 'evdev' for 'Power Button'
[   548.577] (**) Power Button: always reports core events
[   548.577] (**) evdev: Power Button: Device: "/dev/input/event2"
[   548.577] (--) evdev: Power Button: Vendor 0 Product 0x1
[   548.577] (--) evdev: Power Button: Found keys
[   548.577] (II) evdev: Power Button: Configuring as keyboard
[   548.577] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2/event2"
[   548.577] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[   548.577] (**) Option "xkb_rules" "evdev"
[   548.577] (**) Option "xkb_model" "evdev"
[   548.577] (**) Option "xkb_layout" "us"
[   548.578] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event4)
[   548.578] (II) No input driver specified, ignoring this device.
[   548.578] (II) This device may have been added with another device file.
[   548.578] (II) config/udev: Adding input device HDA Intel Line (/dev/input/event5)
[   548.578] (II) No input driver specified, ignoring this device.
[   548.578] (II) This device may have been added with another device file.
[   548.578] (II) config/udev: Adding input device HDA Intel Front Mic (/dev/input/event6)
[   548.578] (II) No input driver specified, ignoring this device.
[   548.578] (II) This device may have been added with another device file.
[   548.578] (II) config/udev: Adding input device HDA Intel Rear Mic (/dev/input/event7)
[   548.578] (II) No input driver specified, ignoring this device.
[   548.578] (II) This device may have been added with another device file.
[   548.578] (II) config/udev: Adding input device HDA Intel Front Headphone (/dev/input/event8)
[   548.579] (II) No input driver specified, ignoring this device.
[   548.579] (II) This device may have been added with another device file.
[   548.579] (II) config/udev: Adding input device HDA Intel Line Out (/dev/input/event9)
[   548.579] (II) No input driver specified, ignoring this device.
[   548.579] (II) This device may have been added with another device file.
[   548.579] (II) config/udev: Adding input device Microsoft Microsoft Optical Mouse with Tilt Wheel (/dev/input/event1)
[   548.579] (**) Microsoft Microsoft Optical Mouse with Tilt Wheel: Applying InputClass "evdev pointer catchall"
[   548.579] (II) Using input driver 'evdev' for 'Microsoft Microsoft Optical Mouse with Tilt Wheel'
[   548.579] (**) Microsoft Microsoft Optical Mouse with Tilt Wheel: always reports core events
[   548.579] (**) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Device: "/dev/input/event1"
[   548.579] (--) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Vendor 0x45e Product 0xd1
[   548.579] (--) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Found 9 mouse buttons
[   548.579] (--) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Found scroll wheel(s)
[   548.579] (--) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Found relative axes
[   548.579] (--) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Found x and y relative axes
[   548.579] (II) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Configuring as mouse
[   548.579] (II) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Adding scrollwheel support
[   548.579] (**) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: YAxisMapping: buttons 4 and 5
[   548.579] (**) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   548.579] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0/input/input1/event1"
[   548.579] (II) XINPUT: Adding extended input device "Microsoft Microsoft Optical Mouse with Tilt Wheel" (type: MOUSE, id 8)
[   548.580] (II) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: initialized for relative axes.
[   548.580] (**) Microsoft Microsoft Optical Mouse with Tilt Wheel: (accel) keeping acceleration scheme 1
[   548.580] (**) Microsoft Microsoft Optical Mouse with Tilt Wheel: (accel) acceleration profile 0
[   548.580] (**) Microsoft Microsoft Optical Mouse with Tilt Wheel: (accel) acceleration factor: 2.000
[   548.580] (**) Microsoft Microsoft Optical Mouse with Tilt Wheel: (accel) acceleration threshold: 4
[   548.580] (II) config/udev: Adding input device Microsoft Microsoft Optical Mouse with Tilt Wheel (/dev/input/mouse0)
[   548.580] (II) No input driver specified, ignoring this device.
[   548.580] (II) This device may have been added with another device file.
[   548.580] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[   548.580] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[   548.581] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[   548.581] (**) AT Translated Set 2 keyboard: always reports core events
[   548.581] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[   548.581] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[   548.581] (--) evdev: AT Translated Set 2 keyboard: Found keys
[   548.581] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[   548.581] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[   548.581] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[   548.581] (**) Option "xkb_rules" "evdev"
[   548.581] (**) Option "xkb_model" "evdev"
[   548.581] (**) Option "xkb_layout" "us"
[   550.471] (II) evdev: Power Button: Close
[   550.471] (II) UnloadModule: "evdev"
[   550.471] (II) evdev: Power Button: Close
[   550.471] (II) UnloadModule: "evdev"
[   550.472] (II) evdev: Microsoft Microsoft Optical Mouse with Tilt Wheel: Close
[   550.472] (II) UnloadModule: "evdev"
[   550.472] (II) evdev: AT Translated Set 2 keyboard: Close
[   550.472] (II) UnloadModule: "evdev"
[   550.596] Server terminated successfully (0). Closing log file.

No idea what's going on. Any help would be appreciated.

Last edited by biltong (2012-10-05 15:45:53)

Offline

#2 2012-10-05 15:31:00

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,709

Re: [solved]X starts then exits immediately when using mate

Did you follow the Beginners' Guide suggestion to install twm, xterm, and xclock to test X? Did it work?

https://wiki.archlinux.org/index.php/Be … ide#Test_X

I know it says the steps are optional, but it's usually a good idea, especially if you have problems.

Last edited by 2ManyDogs (2012-10-05 15:33:10)

Offline

#3 2012-10-05 15:35:48

biltong
Member
From: South Africa
Registered: 2011-09-01
Posts: 116

Re: [solved]X starts then exits immediately when using mate

Yes, that works fine, so it must be a mate problem.

Offline

#4 2012-10-05 15:40:03

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: [solved]X starts then exits immediately when using mate

Should be dbus-launch and not dbus_launch.

Try it with just this as stated in the wiki:

exec ck-launch-session mate-session

Offline

#5 2012-10-05 15:41:07

biltong
Member
From: South Africa
Registered: 2011-09-01
Posts: 116

Re: [solved]X starts then exits immediately when using mate

Pres wrote:

Should be dbus-launch and not dbus_launch.

Try it with just this as stated in the wiki:

exec ck-launch-session mate-session

That fixed it, and I feel like an idiot now. Thank you big_smile

Offline

#6 2012-10-05 15:47:00

Pres
Member
Registered: 2011-09-12
Posts: 423

Re: [solved]X starts then exits immediately when using mate

No worries. Don't forget to mark it as solved.

Offline

Board footer

Powered by FluxBB