You are not logged in.

#1 2012-06-16 21:52:37

pouar
Member
Registered: 2011-11-03
Posts: 54
Website

can only use mouse in links as root

I can't get links to use the mouse as root, in root it works perfectly, but in non-root the mouse doesn't work. tried everything I could think of and google didn't help

here's the last part in /var/log/everything.log

Jun 16 16:41:12 localhost /usr/sbin/gpm[8266]: *** info [daemon/startup.c(136)]: 
Jun 16 16:41:12 localhost /usr/sbin/gpm[8266]: Started gpm successfully. Entered daemon mode.
Jun 16 16:41:17 localhost acpid: client connected from 862[0:10]
Jun 16 16:41:17 localhost acpid: 1 client rule loaded
Jun 16 16:41:17 localhost acpid: client connected from 862[0:10]
Jun 16 16:41:17 localhost acpid: 1 client rule loaded
Jun 16 16:42:41 localhost acpid: client 862[0:10] has disconnected
Jun 16 16:42:44 localhost acpid: client 862[0:10] has disconnected
Jun 16 16:42:51 localhost acpid: client connected from 862[0:10]
Jun 16 16:42:51 localhost acpid: 1 client rule loaded
Jun 16 16:42:51 localhost acpid: client connected from 862[0:10]
Jun 16 16:42:51 localhost acpid: 1 client rule loaded
Jun 16 16:43:27 localhost acpid: client 862[0:10] has disconnected
Jun 16 16:43:27 localhost acpid: client 862[0:10] has disconnected
Jun 16 16:43:33 localhost acpid: client connected from 862[0:10]
Jun 16 16:43:33 localhost acpid: 1 client rule loaded
Jun 16 16:43:33 localhost acpid: client connected from 862[0:10]
Jun 16 16:43:33 localhost acpid: 1 client rule loaded
Jun 16 16:48:01 localhost acpid: client 862[0:10] has disconnected
Jun 16 16:48:04 localhost acpid: client 862[0:10] has disconnected
Jun 16 16:48:07 localhost /usr/sbin/gpm[8266]: *** warning [daemon/processconn.c(128)]: 
Jun 16 16:48:07 localhost /usr/sbin/gpm[8266]: Failed gpm connect attempt by uid 1000 for vc /dev/tty2
Jun 16 16:48:07 localhost xlinks: *** info 
Jun 16 16:48:07 localhost xlinks: Warning: closing connection
Jun 16 16:48:12 localhost acpid: client connected from 862[0:10]
Jun 16 16:48:12 localhost acpid: 1 client rule loaded
Jun 16 16:48:12 localhost acpid: client connected from 862[0:10]
Jun 16 16:48:12 localhost acpid: 1 client rule loaded

here's the parameters in /etc/conf.d/gpm

GPM_ARGS="-m /dev/input/mice -t imps2 -3 -R"

I'm also in the tty and video user groups

Last edited by pouar (2012-06-17 01:48:24)


Yep, I'm a diaperfur now, I guess

while :;do if windows sucks;then mv windows /dev/null;pacman -Sy linux;fi;done
for i in {\ metal,core,grind};do echo death$i rules\!;done

Offline

#2 2012-10-05 19:52:39

pouar
Member
Registered: 2011-11-03
Posts: 54
Website

Re: can only use mouse in links as root

huh, it just started working, I'm not sure what I did, so I won't be marking this as solved since the answer to fixing it wasn't given


Yep, I'm a diaperfur now, I guess

while :;do if windows sucks;then mv windows /dev/null;pacman -Sy linux;fi;done
for i in {\ metal,core,grind};do echo death$i rules\!;done

Offline

Board footer

Powered by FluxBB