You are not logged in.

#1 2012-10-06 13:40:11

iodine
Member
Registered: 2011-09-20
Posts: 14

No wireless using NetworkManager after switch to systemd.

I have this weird problem with NetworkManager. It will not see any wireless networks. However doing

ip link set wlan0 up
wpa_supplicant -B -Dwext -i wlan0 -c /etc/wpa_supplicant.conf

and finally

dhcpcd wlan0

Brings the network up.

Using

iwlist wlan0 scan | less

I can also see list of all the networks.
Could you please suggest where the problem might be?

Offline

#2 2012-10-06 18:36:18

ArchLinux
Member
Registered: 2012-06-09
Posts: 15

Re: No wireless using NetworkManager after switch to systemd.

Are you sure the daemon is running?

Offline

#3 2012-10-06 18:56:01

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: No wireless using NetworkManager after switch to systemd.

$ systemctl is-active networkmanager.service 

Offline

#4 2012-10-06 22:00:02

iodine
Member
Registered: 2011-09-20
Posts: 14

Re: No wireless using NetworkManager after switch to systemd.

The daemon is running. I also removed network daemon from rc.conf and added networkmanager instead preceeded by dbus daemon. Doing systemctl shows me that networkmanager.service is active.

Found this thread - https://bbs.archlinux.org/viewtopic.php?id=150087

I also have

sys-subsystem-net-devices-wlan0.device loaded inactive dead sys-subsystem-net-devices-wlan0.device

But I don't know how to use "service file" properly.

Offline

#5 2012-10-06 22:21:00

ninian
Member
From: United Kingdom
Registered: 2008-02-24
Posts: 694
Website

Re: No wireless using NetworkManager after switch to systemd.

WonderWoofy wrote:
$ systemctl is-active networkmanager.service
$ systemctl is-active NetworkManager.service

methinks?

Offline

#6 2012-10-06 22:27:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: No wireless using NetworkManager after switch to systemd.

@ninian, that is probably so... I don;t use network manager, but I would certainly believe that they would do something rediculous like capitalize in a directory full of lowercase.  That is why I love my zsh and its simple spell checkng.

Offline

#7 2012-10-06 22:30:36

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,977

Re: No wireless using NetworkManager after switch to systemd.

iodine wrote:

The daemon is running. I also removed network daemon from rc.conf and added networkmanager instead preceeded by dbus daemon. Doing systemctl shows me that networkmanager.service is active.

Hold up, once you enable NetworkManager.service in systemd, you remove it from rc.conf, not add it. I don't think that it would cause this problem, but you never know.

Offline

#8 2012-10-07 00:01:55

iodine
Member
Registered: 2011-09-20
Posts: 14

Re: No wireless using NetworkManager after switch to systemd.

Scimmia wrote:
iodine wrote:

The daemon is running. I also removed network daemon from rc.conf and added networkmanager instead preceeded by dbus daemon. Doing systemctl shows me that networkmanager.service is active.

Hold up, once you enable NetworkManager.service in systemd, you remove it from rc.conf, not add it. I don't think that it would cause this problem, but you never know.

Hmm, are you sure? Wiki says something different.

Offline

#9 2012-10-07 00:26:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,977

Re: No wireless using NetworkManager after switch to systemd.

Yeah, that section of the wiki isn't very clear. You only need to start NetworkManager once, either with systemd or with rc.conf, not with both. The section that mentions adding networkmanager and dbus is assuming you're not running systemd.

Offline

#10 2012-10-07 01:00:19

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,977

Re: No wireless using NetworkManager after switch to systemd.

Wiki edited, the section about systemd had just been added without regard for anything else in that section. The part that mentions that NetworkManager won't do anything until you load an applet and tell it to isn't correct, but I'm still trying to figure out the best way to say it.

Offline

#11 2012-10-07 07:46:57

iodine
Member
Registered: 2011-09-20
Posts: 14

Re: No wireless using NetworkManager after switch to systemd.

Scimmia wrote:

Yeah, that section of the wiki isn't very clear. You only need to start NetworkManager once, either with systemd or with rc.conf, not with both. The section that mentions adding networkmanager and dbus is assuming you're not running systemd.

Ah, okay. Well, I removed networkmanager from DAEMONS list in rc.conf, but no effect.

Offline

#12 2012-10-07 08:58:50

iodine
Member
Registered: 2011-09-20
Posts: 14

Re: No wireless using NetworkManager after switch to systemd.

This is what I found in journal:

systemd[1]: Job sys-subsystem-net-devices-wlan0.device/start timed out.
systemd[1]: Timed out waiting for device sys-subsystem-net-devices-wlan0.device.
systemd[1]: Dependency failed for WPA supplicant daemon (interface-specific version).
systemd[1]: Job wpa_supplicant@wlan0.service/start failed with result 'dependency'.
systemd[1]: Job sys-subsystem-net-devices-wlan0.device/start failed with result 'timeout'.

Which is again the same problem as here - https://bbs.archlinux.org/viewtopic.php?id=150087
Then I replaced in /usr/lib/systemd/system/wpa_supplicant@.service sys-subsystem-net-devices-wlan0.device with sys-devices-pci0000:00-0000:00:1d.0-usb5-5\x2d1-5\x2d1.3-5\x2d1.3:1.0-net-wlan0.device.

Now I can see messages from NetworkManager in journalctl. These caught my attention:

NetworkManager[346]: <warn> /sys/devices/virtual/net/lo: couldn't determine device driver; ignoring...
NetworkManager[346]: <warn> /sys/devices/virtual/net/lo: couldn't determine device driver; ignoring...
NetworkManager[346]: <error> [1349605382.573890] [nm-supplicant-interface.c:897] interface_add_cb(): (wlan0): error adding interface: Unit wpa_supplicant.service failed to load: No such file or directory. See system logs and 'systemctl status wpa_supplicant.service' for details.
NetworkManager[346]: dbus_g_proxy_cancel_call: assertion `pending != NULL' failed
NetworkManager[346]: <info> (wlan0): supplicant interface state: starting -> down
NetworkManager[346]: <warn> Trying to remove a non-existant call id.
$ systemctl status wpa_supplicant.service
wpa_supplicant.service
	  Loaded: error (Reason: No such file or directory)
	  Active: inactive (dead)

(Very detailed, yes)

Also in systemctl -a:

sys-devices-pci0000:00-0000:00:1d.0-usb3-3\x2d1-3\x2d1.3-3\x2d1.3:1.0-net-wlan0.device   loaded active   plugged       DWA-125 Wireless N 150 Adapter(rev.A2) [Ralink RT3070]
sys-devices-pci0000:00-0000:00:1d.0-usb5-5\x2d1-5\x2d1.3-5\x2d1.3:1.0-net-wlan0.device   loaded inactive dead          sys-devices-pci0000:00-0000:00:1d.0-usb5-5\x2d1-5\x2d1.3-5\x2d1.3:1.0-net-wlan0.device

Offline

Board footer

Powered by FluxBB