You are not logged in.

#1 2012-10-08 13:58:15

olaf.the.lost.viking
Member
Registered: 2011-07-19
Posts: 21

update to linux-3.5.6-1 not shown

Hi!

When upgrading my system, pacman shows me linux-3.5.5-1 as the newest kernel and wants to update to it (I am still using 3.4.5-1). But this archive is no longer available on the servers. I even used ftp.archlinux.org to be sure that this isn't a mirror problem.

How can I ignore this update? What's the reason for the kernel to be updated only to 3.5.5 even though the archives are no longer on the mirrors? Could it be related to the virtualbox-update which is also offered at the same time?

[root@taris ~]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Targets (49): avogadro-1.1.0-1  calligra-braindump-2.5.3-1  calligra-filters-2.5.3-1  calligra-flow-2.5.3-1  calligra-handbook-2.5.3-1
              calligra-karbon-2.5.3-1  calligra-kexi-2.5.3-1  calligra-krita-2.5.3-1  calligra-libs-2.5.3-1  calligra-pics-2.5.3-1
              calligra-plan-2.5.3-1  calligra-plugins-2.5.3-1  calligra-servicetypes-2.5.3-1  calligra-sheets-2.5.3-1  calligra-stage-2.5.3-1
              calligra-templates-2.5.3-1  calligra-words-2.5.3-1  filesystem-2012.10-1  hdparm-9.42-1  jack-0.121.3-7  kdebase-workspace-4.9.2-2
              libshout-1:2.3.1-1  libusbx-1.0.14-1  linux-3.5.5-1  lirc-utils-1:0.9.0-30  net-snmp-5.7.1-4  netcfg-2.8.11-1  rekonq-1.2-1
              sqlite-3.7.14.1-1  systemd-194-1  systemd-sysvcompat-194-1  telepathy-kde-accounts-kcm-0.5.1-1  telepathy-kde-approver-0.5.1-1
              telepathy-kde-auth-handler-0.5.1-1  telepathy-kde-call-ui-0.5.1-1  telepathy-kde-common-internals-0.5.1-1
              telepathy-kde-contact-applet-0.5.1-1  telepathy-kde-contact-list-0.5.1-1  telepathy-kde-contact-runner-0.5.1-1
              telepathy-kde-filetransfer-handler-0.5.1-1  telepathy-kde-integration-module-0.5.1-1  telepathy-kde-presence-applet-0.5.1-1
              telepathy-kde-send-file-0.5.1-1  telepathy-kde-text-ui-0.5.1-1  telepathy-logger-qt-0.5.1-1  tp_smapi-0.41-8  twisted-12.2.0-1
              util-linux-2.22-7  virtualbox-host-modules-4.2.0-5

Total Download Size:    41.40 MiB
Total Installed Size:   389.49 MiB
Net Upgrade Size:       -20.95 MiB

Proceed with installation? [Y/n] 
:: Retrieving packages from core...
error: failed retrieving file 'linux-3.5.5-1-x86_64.pkg.tar.xz' from ftp.archlinux.org : Given file does not exist
warning: failed to retrieve some files from core
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

Thank you


I switched to OlafLostViking to match the IRC alias.

Offline

#2 2012-10-08 14:01:25

jdarnold
Member
From: Medford MA USA
Registered: 2009-12-15
Posts: 459
Website

Re: update to linux-3.5.6-1 not shown

Don't think your mirrors are up to date, as I just got upgraded to 3.5.6-1 this morning.

Edit: Oops, sorry. Your post said 3.5.5-1 but the title says 3.5.6-1.

But, like I said, I upgraded okay this morning (about an hour ago).

Last edited by jdarnold (2012-10-08 14:02:30)


My tech blog: Daemon Dancing in the Dark
My Arch Linux blog: ArChatter

Offline

#3 2012-10-08 14:07:22

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: update to linux-3.5.6-1 not shown

pacman uses the first working mirror, so you have to put an up-to-date one at the very top of you mirrorlist.
linux packages have just been updated, so maybe try again in a few hours.

Edit: If you need just linux, you can download it manually from http://www.archlinux.org/packages/core/x86_64/linux/ (there's a 'Download From Mirror' link on the top right).

Last edited by karol (2012-10-08 14:09:17)

Offline

#4 2012-10-08 14:13:03

olaf.the.lost.viking
Member
Registered: 2011-07-19
Posts: 21

Re: update to linux-3.5.6-1 not shown

Thank you two for such a fast answer! :-)

I wrote 3.5.6 in the title as this is the up-to-date version. But my pacman wants to update to 3.5.5. And this archive is no longer on the mirrors. And in the example above I used only the archlinux-reference server and deactivated all other mirrors. So this isn't the problem. Manually downloading the archive wouldn't work, as they are no longer available. The main question is why pacman wants to update to an outdated version.


I switched to OlafLostViking to match the IRC alias.

Offline

#5 2012-10-08 14:17:56

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: update to linux-3.5.6-1 not shown

olaf.the.lost.viking wrote:

Manually downloading the archive wouldn't work, as they are no longer available.

I meant 'if you want to manually download linux 3.5.6-1' - click the link and see for yourself. I've just downloaded it w/o a problem.

olaf.the.lost.viking wrote:

The main question is why pacman wants to update to an outdated version.

Run 'pacman -Syyu' and see if it helps.

Last edited by karol (2012-10-08 14:19:13)

Offline

#6 2012-10-08 14:28:28

olaf.the.lost.viking
Member
Registered: 2011-07-19
Posts: 21

Re: update to linux-3.5.6-1 not shown

karol wrote:

Run 'pacman -Syyu' and see if it helps.

Great - thank you! I still don't know what actually happened, but with this forced refresh I now have 3.5.6-1 in the pacman update list.


I switched to OlafLostViking to match the IRC alias.

Offline

#7 2012-10-08 14:38:11

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: update to linux-3.5.6-1 not shown

I was using mirrors.kernel.org, as they were the fastest for my location.  I would consistenty max out my 3MB/s of bandwidth using those mirrors.  But after some time I noticed that they would take quite a while to update what the rss was telling me should be there.  Maybe your issue is the same, maybe not.  Just thought I would throw it out there.

Here is the thread I started asking about it.
https://bbs.archlinux.org/viewtopic.php?id=149280

Offline

Board footer

Powered by FluxBB