You are not logged in.

#1 2012-11-02 06:27:56

paullik
Member
Registered: 2012-01-13
Posts: 12

[SOLVED] Xfce and systemd conflict when suspending

Hello.

If I don't start X and issue systemctl suspend from a tty it all works well, the computer suspends.

If I start X and enter Xfce then both the suspend button from the logout menu in Xfce and systemctl suspend in a terminal yield the same behavior, the system tries to sleep, but the cooler is still running and the LED is still on (it should blink) and the only way out of this state is by using the restart button.

I start X like this: https://wiki.archlinux.org/index.php/Start_X_at_Login
At the advice of gtmanfred on IRC I checked https://wiki.archlinux.org/index.php/Ge … ermissions, it all seems fine.

In my .xinitrc I have:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

[ -f /etc/xprofile ] && . /etc/xprofile
[ -f ~/.xprofile ] && . ~/.xprofile

# exec gnome-session
# exec startkde
exec startxfce4
# ...or the Window Manager of your choice

I don't know what logs to show...

I have pm-utils installed because it is needed by upower and xfce4-session respectively, but if I try to use pm-suspend it yields the same behavior as described above.

The system is up-to-date.

What should I do to get it to suspend from Xfce?

PS: Oh, if I start X and then switch to a tty and then issue systemctl suspend I get the same erroneous behavior.

Last edited by paullik (2012-11-05 18:47:57)

Offline

#2 2012-11-02 09:10:31

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,323

Re: [SOLVED] Xfce and systemd conflict when suspending

Did you try setting the "HandleXXX" values to ignore as described here?

Offline

#3 2012-11-02 11:49:27

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

skunktrader wrote:

Did you try setting the "HandleXXX" values to ignore as described here?

I haven't tried those before because I read that they are related to suspending the computer from buttons and I'm trying to suspend from software.

Anyway, I tried now, but I got no positive results.

Offline

#4 2012-11-02 18:48:49

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

Ok, tried with linux-lts, same erroneous behavior as above...

Any ideas?

Also someone said on IRC that the video driver might cause issues, I have an ATI and xf86-video-ati drivers installed...

Last edited by paullik (2012-11-02 18:51:05)

Offline

#5 2012-11-02 22:25:18

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: [SOLVED] Xfce and systemd conflict when suspending

Are you really using the method described here?

Because that article seems to be re-edited several times each week (it's different every time).

Note: This runs X on the same tty used to login, which is required in order to maintain the login session.


Maybe this is still relevant: https://wiki.archlinux.org/index.php/Ta … X_at_Login

Last edited by DSpider (2012-11-02 22:26:54)


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#6 2012-11-03 08:39:28

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

DSpider wrote:

Are you really using the method described here?

Yes.

I tried what you said here, but with no success, suspend acts the same.

Offline

#7 2012-11-03 09:42:46

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Xfce and systemd conflict when suspending

Do you have systemd-sysvcompat installed?

as root:

# pacman -S --needed systemd-sysvcompat

and replace whatever it asks you to replace.  It will likely ask to replace sysvinit with systemd-sysvcompat.

Let us know if this worked for you.

Offline

#8 2012-11-03 10:52:14

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

akspecs wrote:

Do you have systemd-sysvcompat installed?

as root:

# pacman -S --needed systemd-sysvcompat

and replace whatever it asks you to replace.  It will likely ask to replace sysvinit with systemd-sysvcompat.

Let us know if this worked for you.

warning: systemd-sysvcompat-195-2 is up to date -- skipping
 there is nothing to do

systemd-sysvcompat it's ok,  it's a fresh install of arch...

Suspend still not working.

Offline

#9 2012-11-03 20:05:51

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Xfce and systemd conflict when suspending

Installing that worked for me.  I had similar problems to what you had earlier. 

Since you are running XFCE via the "startx" command from what I understand, what daemons do you have running via rc.conf?  Also, what services do you have enabled?  Check with "$ systemctl list-unit-files" and while scrolling through that list type /enabled and hit enter and scroll through them with the lowercase "n" and uppercase "N" (shift + n ) and post them back here.  I would think having dbus enabled through the DAEMONS=(...dbus...) in rc.conf (if you don't already) might help things out though don't count on it.

Offline

#10 2012-11-03 21:43:46

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

akspecs wrote:

Installing that worked for me.  I had similar problems to what you had earlier. 

Since you are running XFCE via the "startx" command from what I understand, what daemons do you have running via rc.conf?  Also, what services do you have enabled?  Check with "$ systemctl list-unit-files"
and while scrolling through that list type /enabled and hit enter and scroll through them with the lowercase "n" and uppercase "N" (shift + n ) and post them back here.

I'm not that newbie smile

I would think having dbus enabled through the DAEMONS=(...dbus...) in rc.conf (if you don't already) might help things out though don't count on it.

These are my enabled daemons:

getty@.service                         enabled 
net-auto-wired.service                 enabled 
ntpd.service                           enabled 
remote-fs.target                       enabled 

I have no rc.conf since this is a fresh, pure systemd install.

The dbus entries are listed in the unit files as "static":

dbus-org.freedesktop.hostname1.service static  
dbus-org.freedesktop.locale1.service   static  
dbus-org.freedesktop.login1.service    static  
dbus-org.freedesktop.timedate1.service static  
dbus.service                           static  
dbus.socket                            static 

Offline

#11 2012-11-03 22:14:33

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Xfce and systemd conflict when suspending

try this :

# systemctl enable syslog-ng.service
# systemctl enable syslog.service

reboot and try sleeping / hibernating... etc...

Offline

#12 2012-11-03 22:22:10

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

akspecs wrote:

try this :

# systemctl enable syslog-ng.service
# systemctl enable syslog.service

reboot and try sleeping / hibernating... etc...

Both commands fail with:

Failed to issue method call: No such file or directory

But what relation is between the logging system and my issue?

Last edited by paullik (2012-11-03 22:23:09)

Offline

#13 2012-11-03 22:35:11

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Xfce and systemd conflict when suspending

You see, I just converted my system to be all systemd.  I had the exact symptoms you present and doing what I told you I got it to work.  I don't know what exactly it was, but I got it to work eventually.  So sorry, just throwing ideas.

EDIT:

In fact there is no relation.  I just got rid of it.  I had some old legacy crap that I thought needed but it uses systemd's builtin way in a much nicer fashion.

To stimulate interest, what groups is your user apart of.  Post the output of "$ groups"

Last edited by akspecs (2012-11-04 07:00:52)

Offline

#14 2012-11-04 07:22:07

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

akspecs wrote:

To stimulate interest, what groups is your user apart of.  Post the output of "$ groups"

users

Offline

#15 2012-11-04 23:04:01

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Xfce and systemd conflict when suspending

Now I know with systemd it isn't likely neccessary, but I would consider trying to add your user to the "power" group to try things out.  I am apart of the pwer group and things work good for me.  Try it out.

# gpasswd -a youruser power

You will also need pm-utils installed, but it's a dependency of xfce4-session and xfce4-powermanager so I assume you already have it.  Adding your user to the group and rebooting should do the trick, so post back if it doesn't.

Offline

#16 2012-11-05 12:59:26

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

akspecs wrote:

Adding your user to the group and rebooting should do the trick, so post back if it doesn't.

Nope, it doesn't work.

Offline

#17 2012-11-05 18:47:39

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

Thank you all for the help!

I somehow managed to solve the problem by mistake.

In order to get 3D acceleration with my video card I had to pass

pci=nomsi

to the kernel, this also seems to solve the suspend issue since suspend is working now.

Marked as [SOLVED]

Offline

#18 2012-11-05 21:30:52

akspecs
Member
Registered: 2012-02-11
Posts: 169

Re: [SOLVED] Xfce and systemd conflict when suspending

paullik wrote:

Thank you all for the help!

I somehow managed to solve the problem by mistake.

In order to get 3D acceleration with my video card I had to pass

pci=nomsi

to the kernel, this also seems to solve the suspend issue since suspend is working now.

Marked as [SOLVED]

Good work!  What kind of a system are you running?  What card is it?  This is actually an interesting bug which I've read about a while back on laptops with certain nvidia cards where if they turn off their computers, the card is still sucking battery for whatever reason, and if I am not mistaken the same solution you had was needed along with a particular shutdown script.

Offline

#19 2012-11-06 11:58:48

paullik
Member
Registered: 2012-01-13
Posts: 12

Re: [SOLVED] Xfce and systemd conflict when suspending

Well, I have an ATI X1600 video card:

[paullik@eucaryota ~]$ lspci | grep -i vga
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 71c3 (rev 9e)

And as motherboard an ASUS P5VD2 MXSE.

I think the HDD and ram configuration is irrelevant.

Offline

Board footer

Powered by FluxBB