You are not logged in.

#1 2012-11-19 03:02:34

jbritton
Member
Registered: 2011-03-15
Posts: 41

Turning Num Lock off at boot? [SOLVED]

So I just did a fresh install, so everything is running systemd. My issue is that the number lock is turned on at startup on my laptop (which doesn't have a keypad) so I have to turn it off before I can login. I need it to be off in console for my login so numlockx is no use for me.

Everything in the wiki seems to refer to turning it on at boot.

I'm sure there is a simple solution, but I'm just not sure where to look.

Last edited by jbritton (2012-11-19 15:39:38)

Offline

#2 2012-11-19 08:36:56

Awebb
Member
Registered: 2010-05-06
Posts: 4,301

Re: Turning Num Lock off at boot? [SOLVED]

This is very unusual for a linux system indeed. We usually have to dig ourselves in balls deep to find the light of having it turned ON on boot. You probably will visit your bios screen and flip that switch that forces your laptop to turn it on.

Offline

#3 2012-11-19 09:12:37

DSpider
Member
From: Romania
Registered: 2009-08-23
Posts: 2,273

Re: Turning Num Lock off at boot? [SOLVED]

Install the numlockx package and run:

$ numlockx off
$ numlockx on

Maybe set it to run automatically at boot. However, as the name implies, it only works after X has started; it doesn't work from the console. You'll get something like:

$ numlockx off
Error opening display!

You may find an option for it in the BIOS.


"How to Succeed with Linux"

I have made a personal commitment not to reply in topics that start with a lowercase letter. Proper grammar and punctuation is a sign of respect, and if you do not show any, you will NOT receive any help (at least not from me).

Offline

#4 2012-11-19 15:40:21

jbritton
Member
Registered: 2011-03-15
Posts: 41

Re: Turning Num Lock off at boot? [SOLVED]

It was in the BIOS settings. Marking as [SOLVED]. Thanks!

Offline

Board footer

Powered by FluxBB