You are not logged in.

#1 2012-11-24 21:02:36

mrkent
Member
Registered: 2012-11-01
Posts: 5

How do I get virtualbox to work on an older kernel?

I'm currently on 3.4.9-1-ARCH due to some bugs with newer versions of the kernel that affects my laptop. I'd like to install virtualbox that works with my current kernel, but I'm not sure how to do it. I suppose if I can use older version that doesn't require 3.6, that would be the best solution.

$ yaourt -S --force virtualbox-host-modules
resolving dependencies...
warning: ignoring package linux-3.6.7-1
warning: cannot resolve "linux>=3.6", a dependency of "virtualbox-host-modules"
:: The following package cannot be upgraded due to unresolvable dependencies:
      virtualbox-host-modules

Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: virtualbox-host-modules: requires linux>=3.6

Offline

#2 2012-11-24 21:06:39

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: How do I get virtualbox to work on an older kernel?

There is information about that in the wiki:

https://wiki.archlinux.org/index.php/Virtualbox


ᶘ ᵒᴥᵒᶅ

Offline

#3 2012-11-24 21:07:12

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: How do I get virtualbox to work on an older kernel?

You should always check the wiki before asking here - in this case, you need the custom kernel section of the virtualbox page.

Offline

#4 2012-11-24 21:17:25

mrkent
Member
Registered: 2012-11-01
Posts: 5

Re: How do I get virtualbox to work on an older kernel?

I actually did that, and was still confused.

# dkms install vboxhost/$(pacman -Q virtualbox|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
Error! echo
Your kernel headers for kernel 3.4.9-1-ARCH cannot be found at
/usr/lib/modules/3.4.9-1-ARCH/build or /usr/lib/modules/3.4.9-1-ARCH/source.

Offline

#5 2012-11-24 22:01:54

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: How do I get virtualbox to work on an older kernel?

mrkent wrote:

I actually did that, and was still confused.

You forgot to mention it. wink

You need the linux-headers package for this.

Edit: the linux-headers for your running kernel that is, not the one currently in [core]

Last edited by litemotiv (2012-11-24 22:03:05)


ᶘ ᵒᴥᵒᶅ

Offline

Board footer

Powered by FluxBB