You are not logged in.

#1 2012-11-24 14:37:07

Liberis
Member
Registered: 2012-11-11
Posts: 8

[SOLVED] No graphical environment after linux headers 3.6.7

Hello..
I 've been using arch for about 2 weeks,everything worked fine until i upgraded linux headers to 3.6.7 (having no login manager) startx crashes and system restarts unfortunally cant post any logs coz i cant access my computer
tried in xinitrc xfce and compiz standalone and both did not work
Using ati propiertary drivers 12.9.... Tried reinstalling them but again no fix...
PS first post btw!!! smile

Last edited by Liberis (2012-11-25 00:42:51)

Offline

#2 2012-11-24 15:44:01

jv2112
Member
Registered: 2011-07-23
Posts: 154

Re: [SOLVED] No graphical environment after linux headers 3.6.7

try

sudo systemctl enable name.service  --> substitute name for the login manager you use. ( slim , lxdm et cettera)

Hope this helps smile


Life is pleasant. Death is peaceful. It's the transition that's troublesome. Isaac Asimov - / -  My Pastebin

Offline

#3 2012-11-24 15:54:45

Liberis
Member
Registered: 2012-11-11
Posts: 8

Re: [SOLVED] No graphical environment after linux headers 3.6.7

Tried adding a login manager as you said but after login same results black screen and reboot
also found out in xorg log that after some lines with /usr/lib/xorg/modules/drivers/fglrx_drv.so im getting a segmention fault.... Sorry for my english..

Offline

#4 2012-11-24 16:22:30

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [SOLVED] No graphical environment after linux headers 3.6.7

It sounds like you need to rebuild the Catalyst module for your new kernel. I don't have an AMD card myself, but information should be available in the wiki:

https://wiki.archlinux.org/index.php/Catalyst


ᶘ ᵒᴥᵒᶅ

Offline

#5 2012-11-24 17:06:54

Liberis
Member
Registered: 2012-11-11
Posts: 8

Re: [SOLVED] No graphical environment after linux headers 3.6.7

Litemotiv you were right there was not any fglrx module loaded so i followed the wiki and now the only difference is that after startx or startxfce4 all im getting is a black screen where i cant change to an another tty and im forced to reboot

Offline

#6 2012-11-24 21:10:14

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: [SOLVED] No graphical environment after linux headers 3.6.7

Does /var/log/Xorg.0.log mention anything relevant?


ᶘ ᵒᴥᵒᶅ

Offline

#7 2012-11-25 00:40:08

Liberis
Member
Registered: 2012-11-11
Posts: 8

Re: [SOLVED] No graphical environment after linux headers 3.6.7

Solved it.. smile reinstalled the drivers directly from amd(there was some instructions in https://wiki.archlinux.org/index.php/AM … y_from_AMD ) and everything worked just fine tongue
Xorg.log was giving seg fault after some lines about the fglrx module .. anyway thanks for your help smile

Offline

Board footer

Powered by FluxBB