You are not logged in.

#1 2012-12-29 06:33:29

Grelot
Member
Registered: 2012-12-29
Posts: 2

Wifi works but not Ethernet (Only giving me an IPV6 address)

Hello everyone,

I recently decided to learn more about Linux, so I installed Arch Linux on my Thinkpad T410.
The installation went well, the wifi is working so i had no problem finding package and stuff but y ethernet connexion is not working.
When i plug the ethernet cable, eth0 take an IPV6 adress and i can't ping anything (if i deactivate the wifi).

[grelot@T410 ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 00:1f:16:35:a2:57 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::21f:16ff:fe35:a257/64 scope link
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 576 qdisc mq state UP qlen 1000
    link/ether 00:24:d7:02:15:04 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.104/24 brd 255.255.255.255 scope global wlan0

[grelot@T410 ~]$ ifconfig eth0
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet6 fe80::21f:16ff:fe35:a257  prefixlen 64  scopeid 0x20<link>
        ether 00:1f:16:35:a2:57  txqueuelen 1000  (Ethernet)
        RX packets 1096  bytes 97247 (94.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 620 (620.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf2400000-f2420000

[grelot@T410 ~]$ lspci | grep -i net
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 06)
03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)

[grelot@T410 ~]$ lsmod
Module                  Size  Used by
fuse                   69213  3
snd_hda_codec_hdmi     24529  4
coretemp                6071  0
kvm_intel             124718  0
kvm                   374014  1 kvm_intel
joydev                  9992  0
nvidia               9340873  81
arc4                    2040  2
snd_hda_codec_conexant    47159  1
snd_hda_intel          26181  7
snd_hda_codec          98034  3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
crc32c_intel            1988  0
ghash_clmulni_intel     4278  0
aesni_intel            42082  3
qcserial                5205  0
iwldvm                171052  0
usb_wwan                7781  1 qcserial
acpi_cpufreq            5934  1
mperf                   1300  1 acpi_cpufreq
btusb                  12373  0
mac80211              426350  1 iwldvm
bluetooth             192234  2 btusb
usbserial              30544  2 qcserial,usb_wwan
e1000e                180224  0
aes_x86_64              7556  1 aesni_intel
uvcvideo               72788  0
videobuf2_vmalloc       2469  1 uvcvideo
videobuf2_memops        2283  1 videobuf2_vmalloc
videobuf2_core         24073  1 uvcvideo
videodev              100860  2 uvcvideo,videobuf2_core
media                  10406  2 uvcvideo,videodev
tpm_tis                 9195  0
iTCO_wdt                5256  0
aes_generic            26139  2 aesni_intel,aes_x86_64
thinkpad_acpi          62562  0
snd_hwdep               6429  1 snd_hda_codec
tpm                    13798  1 tpm_tis
psmouse                71952  0
serio_raw               4690  0
processor              26856  1 acpi_cpufreq
pcspkr                  1900  0
ablk_helper             1973  1 aesni_intel
snd_pcm                75735  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
ac                      2537  0
mei                    32666  0
thermal                 8120  0
video                  11277  0
battery                 6774  0
tpm_bios                5090  1 tpm
iTCO_vendor_support     1930  1 iTCO_wdt
i2c_i801                9572  0
mxm_wmi                 1468  0
iwlwifi               125182  1 iwldvm
intel_agp              10745  0
lpc_ich                10610  0
i2c_core               20708  3 i2c_i801,nvidia,videodev
wmi                     8380  1 mxm_wmi
intel_gtt              15660  1 intel_agp
nvram                   5907  1 thinkpad_acpi
intel_ips              11964  0
evdev                  10267  14
cryptd                  8742  3 ghash_clmulni_intel,aesni_intel,ablk_helper
button                  4663  0
snd_page_alloc          7218  2 snd_pcm,snd_hda_intel
snd_timer              18935  1 snd_pcm
snd                    60189  21 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_hda_codec,snd_hda_intel,thinkpad_acpi
soundcore               5443  1 snd
cfg80211              177109  3 iwlwifi,mac80211,iwldvm
rfkill                 15605  5 cfg80211,thinkpad_acpi,bluetooth
microcode              12346  0
ext4                  440435  2
crc16                   1360  2 ext4,bluetooth
jbd2                   78802  1 ext4
mbcache                 6027  1 ext4
sr_mod                 14824  0
sd_mod                 29560  4
cdrom                  35521  1 sr_mod
ahci                   21361  3
libahci                20024  1 ahci
sdhci_pci              10834  0
sdhci                  23695  1 sdhci_pci
ehci_hcd               41817  0
libata                167757  2 ahci,libahci
mmc_core               82791  2 sdhci,sdhci_pci
firewire_ohci          31942  0
scsi_mod              133434  3 libata,sd_mod,sr_mod
firewire_core          53174  1 firewire_ohci
crc_itu_t               1364  1 firewire_core
usbcore               150472  6 btusb,uvcvideo,qcserial,usbserial,ehci_hcd,usb_wwan
usb_common               955  1 usbcore

I tried many thing i found on the forum but so far nothing worked.
I'm pretty new at this so I hope you can help me wise Linux users smile

Regards,
Grelot

Last edited by Grelot (2012-12-29 06:34:08)

Offline

#2 2012-12-29 06:55:44

jocheem67
Member
Registered: 2009-11-09
Posts: 207

Re: Wifi works but not Ethernet (Only giving me an IPV6 address)

Offline

#3 2012-12-29 11:16:18

Grelot
Member
Registered: 2012-12-29
Posts: 2

Re: Wifi works but not Ethernet (Only giving me an IPV6 address)

Thanks for your quick answer !

I already tried dhcpcd, here is what happened :

[grelot@T410 ~]$ sudo dhcpcd
[sudo] password for grelot:
dhcpcd[2471]: version 5.6.3 starting
dhcpcd[2471]: wlan0: configured as a router, not a host
dhcpcd[2471]: eth0: sending IPv6 Router Solicitation
dhcpcd[2471]: eth0: sendmsg: Cannot assign requested address
dhcpcd[2471]: eth0: rebinding lease of 192.168.1.107
dhcpcd[2471]: wlan0: rebinding lease of 192.168.1.104
dhcpcd[2471]: eth0: acknowledged 192.168.1.107 from 192.168.1.1 `'
dhcpcd[2471]: eth0: checking for 192.168.1.107
dhcpcd[2471]: wlan0: acknowledged 192.168.1.104 from 192.168.1.1 `'
dhcpcd[2471]: wlan0: leased 192.168.1.104 for 7200 seconds
dhcpcd[2511]: wlan0: wlan0: MTU set to 576
dhcpcd[2471]: forked to background, child pid 2527
[grelot@T410 ~]$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::21f:16ff:fe35:a257  prefixlen 64  scopeid 0x20<link>
        ether 00:1f:16:35:a2:57  txqueuelen 1000  (Ethernet)
        RX packets 1225  bytes 312865 (305.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 364  bytes 37469 (36.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf2400000-f2420000 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 8  bytes 592 (592.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 592 (592.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 576
        inet 192.168.1.104  netmask 255.255.255.0  broadcast 255.255.255.255
        ether 00:24:d7:02:15:04  txqueuelen 1000  (Ethernet)
        RX packets 487  bytes 65943 (64.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1440  bytes 163931 (160.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I'll try Netcfg and keep you posted about the result.

Offline

Board footer

Powered by FluxBB