You are not logged in.

#1 2013-01-02 17:52:43

MGoldrich
Member
Registered: 2012-12-22
Posts: 1

Wifi only connects after boot half of the time.

As the title says, only about half of the time I boot I will get a working connection. It seems that my wireless network is properly identified each time and a connection is established to the wifi device, but I can't actually do things like access web pages unless I reconnect using wifi-menu.

using lsusb, my card is detected as:
Bus 001 Device 003: ID 13b1:000d Linksys WUSB54G v4 802.11g Adapter [Ralink RT2500USB]

I followed the beginner's guide when configuring my network and had the same issue on a previous install of arch on the same device.
Anyone have an idea as to what the problem might be?

Offline

#2 2013-01-02 22:33:35

metgz
Member
From: United States
Registered: 2012-11-13
Posts: 21

Re: Wifi only connects after boot half of the time.

This is a shot in the dark, but, I occasionally encounter a similar problem. Usually, it is because NetworkManager is trying to start on top of another wpa_supplicant process. The next time it won't connect to wifi, try this:

% ps ax | grep wpa

Now, currently, mine outputs this:

519 ?        Ss     0:01 /usr/sbin//wpa_supplicant -u
29264 pts/1    S+     0:00 grep wpa

And it is working.

On my machine, if wifi isn't working, there will be a third wpa_supplicant process with something like 15 arguments. Just kill that process, and see if everything works.

Last edited by metgz (2013-01-02 22:34:30)

Offline

#3 2013-01-03 09:00:19

i_love_penguins
Member
From: Germany
Registered: 2010-03-30
Posts: 46
Website

Re: Wifi only connects after boot half of the time.

Do you use systemd? I have the same issue but never cared about solving it. I think it may be the case that your network drivers sometimes get loaded after netcfg (in my case) has been loaded (because systemd does things in parallel). At least I can remember reading this somewhere smile .. And obviously it is not the right thing.

There is a section about handling dependencies for systemd in the Wiki: https://wiki.archlinux.org/index.php/Sy … pendencies
Maybe this is the case for you.

Last edited by i_love_penguins (2013-01-03 09:07:52)

Offline

#4 2013-01-03 11:39:29

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,025
Website

Re: Wifi only connects after boot half of the time.

I have a ridiculously stupid wifi connection tool I've been working on called swifer-git which is now in the AUR.

It has more non-features than features - but it does ensure that wpa_supplicant and dhcpcd are stopped before it (re)starts them.  So it connects.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

Board footer

Powered by FluxBB