You are not logged in.

#1 2013-01-25 22:46:03

Registered: 2013-01-25
Posts: 2

Static IP frustration :)

Well that was the craziest Capatcha - ever!

I've installed the latest arch linux release on a Reapberry Pi B, booted up, SSH'ed in, created a new user and all is good. Except that I'm really struggling to assign a static IP, I have a DHCP assigned IP so can connect but dhcp assigned addresses can changed so I need to assign a static IP.

Following the newbeginners guide I have:

* added an address
# ip addr add dev eth0

* added a gateway
# ip route add default via

* have a resolv.conf file
# Generated by dhcpcd from eth0
# /etc/resolv.conf.head can replace this line
domain HomeHoward
# /etc/resolv.conf.tail can replace this line

This did not work so then I moved on to the Network configuration page and :

Created the file /etc/systemd/system/network.service

Description=Network Connectivity

ExecStart=/sbin/ip link set dev ${interface} up
ExecStart=/usr/sbin/wpa_supplicant -B -i ${interface} -c /etc/$
ExecStart=/sbin/ip addr add ${address}/${netmask} broadcast ${broadcast} dev ${$
ExecStart=/sbin/ip route add default via ${gateway}

ExecStop=/sbin/ip addr flush dev ${interface}
ExecStop=/sbin/ip link set dev ${interface} down


Created the file /etc/conf.d/network


Then I didn't forget to enable it!

# systemctl enable network

But I still get the DHCP assigned IP address of rather than the static IP

This does not bode well for my first forray into the world on Linux - please can someone tell me where I am going wrong? Please?


#2 2013-01-25 22:55:53

From: Bonn
Registered: 2004-07-05
Posts: 1,950

Re: Static IP frustration :)

You probably have dhcpcd running. You are also not running Arch Linux (which is x86 only and you are on arm)


#3 2013-01-26 05:50:20

Registered: 2013-01-25
Posts: 2

Re: Static IP frustration :)

Hi Pierre and thanks for your reply.

As you probably guessed I am a newbie and not sure what ARM refers to, am I not using ARCH or is this a specific distribution (specifically for the PI for example) and am I therefore in the wrong forum? Apologies if this is the case.

After some research I stopped the DHCPCD service with the
sudo systemctl disable dhcpcd
command and rebooted.

After checking the service was stopped with
sudo systemctl status dhcpcd
dhcpcd.service - dhcpcd on all interfaces
          Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; disabled)
          Active: inactive (dead)

However the IP continues to be instead of the specified sad

How is this even possible when the dhcpdc service has been stopped??? Could dhcpcd have saved a config file somewhere?

The only file in /etc/network.d/interfaces/ is a file called ethernet-static and its contents is

DESCRIPTION='A basic static ethernet connection using iproute'
#ROUTES=(' via')

## For IPv6 autoconfiguration

## For IPv6 static address configuration
#ADDR6=('1234:5678:9abc:def::1/64' '1234:3456::123/96')

this is a little frustrating for what should be a trivial task! Any help gratefully received.


#4 2013-01-26 06:31:13

Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: Static IP frustration :)

Arch does not work on Raspberry Pi. However a port of Arch called ArchARM does which is most likely what you are using.

Please ask on their forum as they will be able to better assist you. They in fact also have a sub-forum for Pi

As a policy we only support Archlinux. … pport_ONLY

Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !


#5 2013-01-26 14:49:07

#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 3,748

Re: Static IP frustration :)

Also, instead of hardcoded static, just asign static ip trough dhcp.

Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest


Board footer

Powered by FluxBB