You are not logged in.

#1 2013-02-06 23:42:00

redrifle
Member
Registered: 2013-02-06
Posts: 3

CPU frequency scaling with cpupower

I can't seem to get cpupower working right, i need to load the performance governor at boot and i have absolutely no idea how to do that.
The wiki says:
Tip: To load a governor at boot, run
# echo <module> > /etc/modules-load.d/<module>

so then i run:
# echo powernow-k8 > /etc/modules-load.d/powernow-k8

for me this does nothing though.

I'm probably making a very simple mistake, and i can't seem to make sense of it by combing through the wiki countless times.
Anyone know what i'm doing wrong?

Offline

#2 2013-02-06 23:47:43

phil
Member
Registered: 2012-09-22
Posts: 72

Re: CPU frequency scaling with cpupower

are you sure you need that? you could post the output of

cpupower frequency-info

Mine is:

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.13 GHz
  available frequency steps: 2.13 GHz, 1.60 GHz, 800 MHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 800 MHz and 2.13 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  boost state support:
    Supported: no
    Active: no

Without having anything like that in /etc/modules-load.d.

Offline

#3 2013-02-06 23:55:52

redrifle
Member
Registered: 2013-02-06
Posts: 3

Re: CPU frequency scaling with cpupower

analyzing CPU 0:
  driver: powernow-k8
  CPUs which run at the same hardware frequency: 0 1
  CPUs which need to have their frequency coordinated by software: 0 1
  maximum transition latency: 109 us.
  hardware limits: 1000 MHz - 3.00 GHz
  available frequency steps: 3.00 GHz, 2.80 GHz, 2.60 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1000 MHz
  available cpufreq governors: ondemand, performance
  current policy: frequency should be within 1000 MHz and 3.00 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  boost state support:
    Supported: no
    Active: no

It also says on the wiki that powernow-k8 is deprecated and that i should use acpi-cpufreq, yet when i try to load it with modprobe i get:

modprobe: ERROR: could not insert 'acpi_cpufreq': Device or resource busy

Offline

#4 2013-02-07 00:23:24

phil
Member
Registered: 2012-09-22
Posts: 72

Re: CPU frequency scaling with cpupower

so this seems to me that your setup is working. ondemand takes care of your cpu frequency and you can switch to performance.
i don't know about the error.

Offline

#5 2013-02-07 00:34:29

redrifle
Member
Registered: 2013-02-06
Posts: 3

Re: CPU frequency scaling with cpupower

phil wrote:

so this seems to me that your setup is working. ondemand takes care of your cpu frequency and you can switch to performance.
i don't know about the error.

Yes i suppose it works but the transition latency between steps is too high for applications to take advantage of it in time so i'd like it to be locked at 3.00GHz from boot, is that even possible?

Offline

#6 2013-02-07 00:52:15

phil
Member
Registered: 2012-09-22
Posts: 72

Re: CPU frequency scaling with cpupower

I guess if you enable the governor performance on boot, you are always at 3 GHz.
Also you could try to tune the ondemand performance which is described in the ArchWiki about CPU Frequency scaling.
https://wiki.archlinux.org/index.php/CP … cy_Scaling

But your computer gets hot faster ... when you are always at 3GHz. That's what would bother me.
Are you running the latest version of cpupower?

Last edited by phil (2013-02-07 00:55:41)

Offline

#7 2013-02-07 05:38:25

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: CPU frequency scaling with cpupower

There is a configuration file and service file for cpupower. Use "pacman -Ql cpupower" to have it dump a list of files in the package. There should be a conf.d file I think... maybe /etc/default... its there though.

As already stated the kernel automatically takes care of performance and powersave for you no matter what processor you have, as long as this funtilnality is supported. So those instructions on the cpupower wiki page are old and likely just remain from when we used cpufreq and this crap was all manual.

Offline

#8 2013-02-07 16:54:14

rebootl
Member
Registered: 2012-01-10
Posts: 427
Website

Re: CPU frequency scaling with cpupower

Hi

Just an addition to what wonderwoofy said:
With the latest update (I think it was the latest), the config file moved from /etc/conf.d/cpupower to /etc/default/cpupower. There you can set the governor you want to use. I use conservative for example:

governor='conservative'

Then you should load that module in /etc/modules-load.d/<any-name>.conf

cpufreq_conservative

The governors are separate modules !
For your case just replace conservative by performance. Make sure the file in /etc/modules-load.d ends with .conf !


Personal website: cem.revamp-it.ch
GitHub: github.com/rebootl

Offline

#9 2013-02-07 19:39:59

2ManyDogs
Member
Registered: 2012-01-15
Posts: 1,683

Re: CPU frequency scaling with cpupower

redrifle wrote:

Yes i suppose it works but the transition latency between steps is too high for applications to take advantage of it in time

How do you know this? I have seen other people assert this, but have never seen anyone show any statistics that prove it ("it just feels slower" is not a statistic). And I have seen many other people dispute this claim.

so i'd like it to be locked at 3.00GHz from boot, is that even possible?

yes, but as others have told you, this comes at the cost of increased power consumption and unnecessary heat.

Last edited by 2ManyDogs (2013-02-07 19:40:52)

Online

Board footer

Powered by FluxBB