You are not logged in.

#1 2013-02-16 15:56:44

VeXe
Member
Registered: 2013-02-13
Posts: 27

Awesome breaks after defining my own widget variables (textboxes, etc)

Hi, I'm on Arch X64. Running Awesome 3.5 trying to customize it, just wanna add some widgets (specifically launchers).

In my rc.lua file, whenever I add something, like "mytextbox = widget ({ type = "textbox" })" Awesome breaks on restarting it! I can't even log in anymore, each time I type my user/pass, I get in for just a moment, and then awesome quits back to the login (which is gdm in my case)

Note that I read the awesome wiki on widgets, it didn't say to require anything, but just in case, I downloaded and required vicious, like: "vicious = require ("vicious")" didn't change anything.

Why is this happening? am I missing some 'require's? How can I successfully add my widgets?

And one more thing, I've been watching a lot of vids on this thing, most of them have awesome 3.4, a lot of things in the rc.lua file are now different. Like for example, the way they used to add widgets, was by adding them to an array. in 3.5, there's a section for adding stuff to the right/left/center of the taskbar (or whatever it's called)
Can I still add widgets via the 3.4 way? (making an array, and looping through them)

Please help, getting frustrated here! Thanks a bunch!

Offline

#2 2013-02-16 16:16:21

Stebalien
Member
Registered: 2010-04-27
Posts: 1,218
Website

Re: Awesome breaks after defining my own widget variables (textboxes, etc)


Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#3 2013-02-18 12:27:00

floby
Member
Registered: 2013-02-16
Posts: 2

Re: Awesome breaks after defining my own widget variables (textboxes, etc)

VeXe wrote:

Hi, I'm on Arch X64. Running Awesome 3.5 trying to customize it, just wanna add some widgets (specifically launchers).

In my rc.lua file, whenever I add something, like "mytextbox = widget ({ type = "textbox" })" Awesome breaks on restarting it! I can't even log in anymore, each time I type my user/pass, I get in for just a moment, and then awesome quits back to the login (which is gdm in my case)

Note that I read the awesome wiki on widgets, it didn't say to require anything, but just in case, I downloaded and required vicious, like: "vicious = require ("vicious")" didn't change anything.

Why is this happening? am I missing some 'require's? How can I successfully add my widgets?

And one more thing, I've been watching a lot of vids on this thing, most of them have awesome 3.4, a lot of things in the rc.lua file are now different. Like for example, the way they used to add widgets, was by adding them to an array. in 3.5, there's a section for adding stuff to the right/left/center of the taskbar (or whatever it's called)
Can I still add widgets via the 3.4 way? (making an array, and looping through them)

Please help, getting frustrated here! Thanks a bunch!

mytextbox = widget ({ type = "textbox" })"
is now
wibox.widget.textbox()

The code changed, the good man above posted the relevant documentation for this.


ohgodwhatisthisimnotverygoodatcomputers

Offline

#4 2013-02-18 12:52:32

Antoine
Member
From: Picton Ontario
Registered: 2012-10-11
Posts: 90

Re: Awesome breaks after defining my own widget variables (textboxes, etc)

Install Vicious

At the top of your rc.lua add:

local vicious = require("vicious") 

And then take a look at this article where I set up a simple vicious widget when I was migrating to 3.5

Offline

Board footer

Powered by FluxBB