You are not logged in.

#1 2013-02-23 06:56:59

chisleu
Member
Registered: 2012-08-15
Posts: 22

Starting xfce4 on a tightvnc session from within a normal xfce session

I have "exec startxfce4" in my .vnc/xstartup.

Unfortunately when I try to start vnc from within an XFCE4 session, it complains that

"X server already running on display :2"
"Xlib: extension "RANDR" mission on display ":2".
"xfce4-session: Another session manager is already running"

I think it's confusing my current session with the session I'm trying to start on a different display. Perhaps this is because of environment variables?

It works perfectly if I start it from a command line, however I never use the command line on this system and want to be able to launch it from within xfce4.

Anyone have any ideas? I've been looking at trying to remove environment variables.

Offline

#2 2013-02-23 11:05:49

graysky
Member
From: The worse toilet in Scotland
Registered: 2008-12-01
Posts: 8,647
Website

Re: Starting xfce4 on a tightvnc session from within a normal xfce session

Is your "XFCE4 session" a live one?  In other words, not a virtual one?  If so, it should be running on :0 by default.  What is the output of:

$ ps aux | grep vnc

Do you have stale pid files in $HOME/.vnc by chance?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Online

#3 2013-02-24 03:04:54

chisleu
Member
Registered: 2012-08-15
Posts: 22

Re: Starting xfce4 on a tightvnc session from within a normal xfce session

graysky wrote:

Is your "XFCE4 session" a live one?  In other words, not a virtual one?  If so, it should be running on :0 by default.  What is the output of:

$ ps aux | grep vnc

Do you have stale pid files in $HOME/.vnc by chance?

I'm running the vnc server on :2 I believe. because I'm launching startvnc from a terminator window from within an xfce4 session, it complains that a session was already detected. I'm not sure what is causing this. I removed almost all the environment variables.

Again, if I run the same command from a fresh console command prompt, it works perfectly. Somehow it is seeing the state of the xfce4 session running on 0:0 and confusing it with the display it was told to start on (0:2)

It's just a hassle logging in on the console and starting it up.



A separate issue, I've tried disabling dpms and screen blanking in my .xinitrc, but when I close my lid it still goes into suspend mode. I have the power settings for this disabled so I'm not sure how it's happening sad

I'm still beating on it. If I find a solution to either I'll post up.

EDIT: it was systemd suspending the system, not X or Xfce.

In /etc/systemd/logind.conf

I added the line: HandleLidSwitch=ignore

Now I'm good to go on that front! Still working on the vnc issue. For now I'm going to start it from the console, but I really would like to find a way to start it from in X as I autologin and startx on startup.

Last edited by chisleu (2013-02-24 16:24:09)

Offline

Board footer

Powered by FluxBB