You are not logged in.

#1 2013-02-24 06:05:24

creese
Member
Registered: 2012-07-21
Posts: 26

When Using Nvidia Driver, Consoles are Blank

Since switching to the Nvidia driver, when I switch consoles using Ctrl-Alt-Fn, I get a blank screen. Any idea what is causing this. I have a MacBook 5,1.

Offline

#2 2013-02-24 10:16:50

loafer
Member
From: the pub
Registered: 2009-04-14
Posts: 1,674

Re: When Using Nvidia Driver, Consoles are Blank

A quicks earch with Google finds threads in these forums, the Ubuntu forums and nvidia  forums going back over a year regarding this issue.  It seems to be a fairly common occurrence.  I have a GeForce 9400 and get the same thing with the nvidia driver.


All men have stood for freedom...
For freedom is the man that will turn the world upside down.
Gerrard Winstanley.

Offline

#3 2013-04-08 22:34:18

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

Re: When Using Nvidia Driver, Consoles are Blank

Same here. Any solutions?

Offline

#4 2013-04-08 22:49:06

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

Re: When Using Nvidia Driver, Consoles are Blank

Ok, workaround: add "vga=normal" to your kernel command line. Works for me. The main error has to be fixed by nvidia. There's nothing we can do.

Offline

#5 2013-04-08 22:54:10

Gusar
Member
Registered: 2009-08-25
Posts: 3,408

Re: When Using Nvidia Driver, Consoles are Blank

Thorsten Reinbold wrote:

The main error has to be fixed by nvidia.

It won't be. They're very clear about not supporting anything but a text console.

Offline

#6 2013-04-09 08:33:48

cjazz
Member
Registered: 2009-03-12
Posts: 43

Re: When Using Nvidia Driver, Consoles are Blank

Gusar wrote:
Thorsten Reinbold wrote:

The main error has to be fixed by nvidia.

It won't be.

Really? For me, the problem was solved with the 304.88-2 version of the nvidia-304xx driver. A similar outcome was reported in the thread at https://bbs.archlinux.org/viewtopic.php?id=160037.

Last edited by cjazz (2013-04-09 08:34:24)

Offline

#7 2013-04-09 14:14:28

Gusar
Member
Registered: 2009-08-25
Posts: 3,408

Re: When Using Nvidia Driver, Consoles are Blank

cjazz wrote:

Really? For me, the problem was solved with the 304.88-2 version of the nvidia-304xx driver.

By pure chance. Every linux forum around has threads about that message the nvidia driver shows when you're running a framebuffer console. Nvidia isn't doing anything to support them. They're not deliberately breaking them either, so it does work for many people, but that's, as I said, by pure chance.

Offline

Board footer

Powered by FluxBB